Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to install SELinux with SystemD and KDE Plasma?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
maxmodulo
n00b
n00b


Joined: 23 Jun 2018
Posts: 29

PostPosted: Tue Jul 03, 2018 5:05 pm    Post subject: How to install SELinux with SystemD and KDE Plasma? Reply with quote

Hi everyone,

Is there a documented path to install SELinux on a system that already has systemd and plasma running? My profile is currently:
Code:
[20]  default/linux/amd64/17.0/desktop/plasma/systemd (stable)

In retrospect it appears I probably should have setup SELinux before the graphical environment etc. Although looking through the listed options I can't see an obvious path to a system with all of: SELinux, systemd, and plasma.
Code:
  [12]  default/linux/amd64/17.0 (stable)
  [13]  default/linux/amd64/17.0/selinux (stable)
  [14]  default/linux/amd64/17.0/hardened (stable)
  [15]  default/linux/amd64/17.0/hardened/selinux (stable)
  [16]  default/linux/amd64/17.0/desktop (stable)
  [17]  default/linux/amd64/17.0/desktop/gnome (stable)
  [18]  default/linux/amd64/17.0/desktop/gnome/systemd (stable)
  [19]  default/linux/amd64/17.0/desktop/plasma (stable)
  [20]  default/linux/amd64/17.0/desktop/plasma/systemd (stable) *
  [21]  default/linux/amd64/17.0/developer (stable)
  [22]  default/linux/amd64/17.0/no-multilib (stable)
  [23]  default/linux/amd64/17.0/no-multilib/hardened (stable)
  [24]  default/linux/amd64/17.0/no-multilib/hardened/selinux (stable)
  [25]  default/linux/amd64/17.0/systemd (stable)
  [26]  default/linux/amd64/17.0/x32 (dev)


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21754
Location: here

PostPosted: Tue Jul 03, 2018 7:36 pm    Post subject: Reply with quote

You can combine profiles
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
maxmodulo
n00b
n00b


Joined: 23 Jun 2018
Posts: 29

PostPosted: Wed Jul 04, 2018 1:45 pm    Post subject: Reply with quote

fedeliallalinea wrote:
You can combine profiles

Gracias, fedeliallalinea! I will do this.
Back to top
View user's profile Send private message
maxmodulo
n00b
n00b


Joined: 23 Jun 2018
Posts: 29

PostPosted: Wed Jul 04, 2018 5:28 pm    Post subject: Reply with quote

I've combined these profiles:

Code:
  [13]  default/linux/amd64/17.0/selinux (stable)
  [20]  default/linux/amd64/17.0/desktop/plasma/systemd (stable)


To check what a world rebuild will do I've run emerge:
Code:
emerge -DNua --complete-graph @world

for which the output reveals [blocks] re eudev and systemd:
Code:
....
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/eudev-3.2.5)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/eudev-3.2.5)
[blocks B      ] sys-fs/eudev ("sys-fs/eudev" is blocking sys-apps/gentoo-systemd-integration-7, sys-apps/systemd-238-r7)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/dbus:0

  (sys-apps/dbus-1.10.24:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/dbus-1.6:=[user-session=] required by (net-wireless/bluez-5.49-r1:0/3::gentoo, ebuild scheduled for merge)
                          ^^^^^^^^^^^^^                                                                                                                     

  (sys-apps/dbus-1.10.24:0/0::gentoo, installed) pulled in by
    >=sys-apps/dbus-1.9.8[systemd] required by (sys-apps/systemd-238-r7:0/2::gentoo, installed)
                          ^^^^^^^                                                                                                 


It might be possible to solve this slot collision
by applying all of the following changes:
   - sys-apps/dbus-1.10.24 (Change USE: +systemd)

eudev isn't used with systemd and the output suggests to "Change USE: +systemd", but I already have 'systemd' in my /etc/portage/make.conf

Cheers for helping a sad Gentoo noob! :oops:
Back to top
View user's profile Send private message
maxmodulo
n00b
n00b


Joined: 23 Jun 2018
Posts: 29

PostPosted: Wed Jul 04, 2018 5:53 pm    Post subject: Reply with quote

It seems Gentoo doesn't have systemd working with SELinux.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum