Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed to emerge /dev-libs/cyrus-sasl-2.1.26-r9
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Rejoy
n00b
n00b


Joined: 09 Jul 2018
Posts: 20

PostPosted: Mon Jul 09, 2018 4:00 am    Post subject: Failed to emerge /dev-libs/cyrus-sasl-2.1.26-r9 Reply with quote

Hi,

I am installling gentoo for the first time. After the grub install and reboot , I tried am emerge --ask --verbose --update --deep --newuse --with-deps=y @world. The compilation fails for package /dev-libs/cyrus-s6-sasl-2.1.26-r9 with makefile errors. The complete logs have been posted at https://paste.pound-python.org/show/ED9otZ30I6EnZaQuAS3N/

lines 5322-28

Code:
make[2]: *** [Makefile:747: otp.lo] Error 1
make[2]: Leaving directory '/var/tmp/portage/dev-libs/cyrus-sasl-2.1.26-r9/work/cyrus-sasl-2.1.26-abi_x86_32.x86/plugins'
make[1]: *** [Makefile:589: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-libs/cyrus-sasl-2.1.26-r9/work/cyrus-sasl-2.1.26-abi_x86_32.x86'
make: *** [Makefile:498: all] Error 2
 * ERROR: dev-libs/cyrus-sasl-2.1.26-r9::gentoo failed (compile phase):
 *   emake failed

Any help would be appreciated.

Thanks,
Rejoy

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21754
Location: here

PostPosted: Mon Jul 09, 2018 5:45 am    Post subject: Reply with quote

What version of openssl you installed?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Rejoy
n00b
n00b


Joined: 09 Jul 2018
Posts: 20

PostPosted: Mon Jul 09, 2018 6:15 am    Post subject: Reply with quote

Hi,

this is what was listed
dev-libs/openssl-1.1.0h-r2

By the way, I have made changes to make.conf. I have added bindist mmx sse sse2 icu to global useflags and aslo set EMERGE_DEFAULTS_OPTS="--autounmask-write" and am trying to recompile packages. Openssl was first of the the packages that got rebuilt.

Thanks
Rejoy
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21754
Location: here

PostPosted: Mon Jul 09, 2018 6:22 am    Post subject: Reply with quote

openssl-1.1.0 are hard masked you should downgrade to 1.0.2o.
Remove also bindist use flag is only useful if you redistribute some precompiled packages
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Rejoy
n00b
n00b


Joined: 09 Jul 2018
Posts: 20

PostPosted: Mon Jul 09, 2018 6:32 am    Post subject: Reply with quote

Hi,


I ll try out your suggestion. How do I do an emerge @world ensuring that the Openssl package is not updated to its latest version.

edit: I unmerged Openssl, then installed the 1.0.2 version and used --exclude=openssl along with emerge --ask --deep --newuse --with-bdeps=y @world and the rest of the packages were installed.


Thanks
Rejoy
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum