Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gestione di gentoo : aggiornare sistema
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 620

PostPosted: Wed Jul 11, 2018 11:40 pm    Post subject: Reply with quote

giusto per provare :

ho creato il VDI della Sabayon in uso , quindi filesystem montato etc etc

file immagine risultante : ~96 GB (ovviamente dipende dal disco di origine e quello che c'è installato)

Il primo avvio ho dovuto forzare il check dei filesystem manualmente (Ovviamente mentre clonavo il disco il filesystem era occupato e si è trovato qualche discrepanza)

Ora ho una disco virtuale identico dove poter smanettare.
Vbox permette di effettuare degli snapshots nel caso si volesse ripristinare lo stato della macchina precedente (occhio che anche gli snapshot richiedono spazio disco quindi assicurarsi di avere spazio a sufficienza)

https://imageshack.com/a/img924/6789/yiyjkI.png

Buon test
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Thu Jul 12, 2018 5:37 am    Post subject: Reply with quote

ieri ho interrotto l'aggiornamento di chromium e l'ho disinstallato con

Code:
emerge --depclean --ask  www-client/chromium


alla fine il terminale mi ha dato
questo output
Code:
 * Messages for package media-sound/pulseaudio-11.1-r1:

 * A preallocated buffer-size of 2048 (kB) or higher is recommended for the HD-audio driver!
 * CONFIG_SND_HDA_PREALLOC_SIZE=512


questa mattina ho ridato
Quote:
emerge --update --changed-use --deep --with-bdeps=y @world

dopo
Code:
 emerge --ask  --depclean

ho scritto no alla domanda se volevo eliminare alcuni pacchetti
per ultimo ho dato
Code:
emerge --update --newuse --deep @world

cosi come richiesto da portage.

e il terminale mi ha dato questo
Code:
gentoo /home/trigg # emerge --update --newuse --deep @world
Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

media-gfx/imagemagick:0

  (media-gfx/imagemagick-7.0.8.5:0/7.0.8.5::gentoo, ebuild scheduled for merge) conflicts with
    <media-gfx/imagemagick-7:0/6.9.10.5=[cxx] required by (media-libs/libopenshot-0.1.8:0/0::gentoo, installed)
    ^                      ^^^^^^^^^^^^^     
    <media-gfx/imagemagick-7:0=[cxx] required by (media-libs/libopenshot-0.1.8:0/0::gentoo, installed)
    ^                      ^       

>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
gentoo /home/trigg


una cosa che ho notato è che a fine esecuzione del comando emege --update --newuse --deep @world
tutti i browser non riuscivano a contattare il server o l'host di internet, non riuscivo ad entrare in alcun sito
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19910
Location: here

PostPosted: Thu Jul 12, 2018 6:22 am    Post subject: Reply with quote

Code:
media-gfx/imagemagick:0

  (media-gfx/imagemagick-7.0.8.5:0/7.0.8.5::gentoo, ebuild scheduled for merge) conflicts with
    <media-gfx/imagemagick-7:0/6.9.10.5=[cxx] required by (media-libs/libopenshot-0.1.8:0/0::gentoo, installed)
    ^                      ^^^^^^^^^^^^^     
    <media-gfx/imagemagick-7:0=[cxx] required by (media-libs/libopenshot-0.1.8:0/0::gentoo, installed)
    ^                      ^       

Purtroppo questo lo puoi risolvere solo facendo il downgrade di imagemagick alla versione 6.9.10.5, questo perche' libopenshot non supporta ancora imagemagick-7.
Oppure disinstallando il pacchetto che richiede libopenshot
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 620

PostPosted: Thu Jul 12, 2018 6:30 am    Post subject: Reply with quote

:mrgreen: io non ho capito perchè disinstalli se non riesci a fare l'aggiornamento.
Tienilo. Mal che vada non lo aggiorni
Tutte le opzioni utilizzate nel comando di aggiornamento non sono proprio un obbligo. Puoi aggiornare anche un pezzo alla volta.
Se portage pretende altro ti avisa.
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Thu Jul 12, 2018 9:07 am    Post subject: Reply with quote

ho tolto chromium perchè secondo me non è compatibile con gentoo
firefox lo installi in 10 minuti
vivaldi in 3 minuti
chromium piu di un giorno , per quanto è il mio browser preferito non mi va di usurare il pc per un pacchetto
preferisco togliermi il pacchetto e mantenere l'hardware .

con vivladi mi son sempre trovato bene è la mia seconda scelta , l0unica cosa è che non si iresce a vedere streaming online.

come faccio a fare il downggrade di imagemagick?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19910
Location: here

PostPosted: Thu Jul 12, 2018 9:22 am    Post subject: Reply with quote

Devi mascherare le versioni di imagemagick maggiori della versione 7 con /etc/portage/package.mask
Code:
# echo ">=media-gfx/imagemagick-7.0" >> /etc/portage/package.mask/imagemagick

e poi aggiorni ul sistema
Code:
# emerge -uUD --with-bdeps=y @world

Ricordati in un futuro che hai mascherato la versione 7 di imagemagick
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Thu Jul 12, 2018 10:08 am    Post subject: Reply with quote

Code:
trigg@gentoo ~ $ su
Password:
gentoo /home/trigg # echo ">=media-gfx/imagemagick-7.0" >> /etc/portage/package.mask/imagemagick
gentoo /home/trigg # emerge -uUD --with-bdeps=y @world
Calculating dependencies... done!
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
gentoo /home/trigg #


credo che adesso è tutto aggiornato :)

quindi per aggiornare devo dare

Code:
emerge --update --changed-use --deep --with-bdeps=y @world

e seguire eventuali richieste di portage

per escludere un pacchetto dall'aggiornamento devo dare

Code:
emerge --update --changed-use --deep --with-bdeps=y @world --exclude=categoira/pacchetto



per mascheare un pacchetto devo dare
Code:
echo ">=categoria/pacchetto.versione" >> /etc/portage/package.mask/pacchetto
emerge -uUD --with-bdeps=y @world


come base ci siamo o c'è altro, tipo il comando "oneshot" che ho letto da qualche parte
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19910
Location: here

PostPosted: Thu Jul 12, 2018 10:28 am    Post subject: Reply with quote

trigg wrote:
come base ci siamo o c'è altro, tipo il comando "oneshot" che ho letto da qualche parte

--oneshot o -1 serve per non fare registrare un dato pacchetto nel world file (/var/lib/portage/world).
Questo e' utile quando devi ricompilare un pacchetto che non sia un aggiornamento (in questo caso puoi usare --update).
Qua vedi un esempio di come lavora oneshot
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 620

PostPosted: Thu Jul 12, 2018 10:58 am    Post subject: Reply with quote

se si vuole togliere un pachetto al world (senza editare il relativo file) o ricompilarlo con "-1" , c'è l'opzione "--deselect"
Code:
--deselect [ y | n ]
              Remove  atoms  and/or  sets from the world file. This action is implied by uninstall actions, including --depclean, --prune and --unmerge. Use --deselect=n in order to prevent uninstall actions from removing atoms from the
              world file.


Comunque ancora non ho capito la storia di Chromium/Chrome e la compatibilità. E' un pacchetto che richiede molto tempo di compilazione quello sì , così come libreoffice e pochi altri.
Comunque sia chromium che libreoffice richiedono molto spazio per la compilazione (portage ti avvisa in merito) , se compili in ram , assicurati di avere molta ram a disposizione o fai in modo che sol quei pacchetti vengano compilati direttamente sul .
Qualche spunto lo si trova qui

Per Vivaldi e lo streaming video , credo che ci voglia qualche sua estensione (utilizzando il codice di chrome , qualcosa a riguardo a flash-player et simili)
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 620

PostPosted: Thu Jul 12, 2018 11:34 am    Post subject: Reply with quote

trigg wrote:
ieri ho interrotto l'aggiornamento di chromium e l'ho disinstallato con

Code:
emerge --depclean --ask  www-client/chromium


alla fine il terminale mi ha dato
questo output
Code:
 * Messages for package media-sound/pulseaudio-11.1-r1:

 * A preallocated buffer-size of 2048 (kB) or higher is recommended for the HD-audio driver!
 * CONFIG_SND_HDA_PREALLOC_SIZE=512



Qui devi impostare al valore richiest (2048 o superiore) la dimensione del buffer per l'audio driver. A livello kernel (e ricompilarlo dopo averlo modificato)
Il valore attualmente settato è inferiore e potresti (anzi li avrai) problemi con l'audio.

Basicamente basta un "sed" se non vuoi cercare tra tutte le opzioni (di default indicherò /usr/src/linux/.config , ovviamente adattalo alla tua config se ne hai una alternativa da qualche parte(
Code:
# sed -i 's/CONFIG_SND_HDA_PREALLOC_SIZE=.*/CONFIG_SND_HDA_PREALLOC_SIZE=2048/' /usr/src/linux/.config


ricompila il kernel con la config modificata
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Thu Jul 12, 2018 12:19 pm    Post subject: Reply with quote

ciao sabayonino
questa mattina ho ridato i comadi per aggiornare e non è più usctio quel tipo di output
non so se vale la pena modificaare il kernel , in altre parole non ho proprio idea da dove incominciare.
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 620

PostPosted: Thu Jul 12, 2018 2:54 pm    Post subject: Reply with quote

Quel tipo di output salterà fuori con le applicazioni che potrebbero utilizzare il dispositivo audio... Tipo chromium


Non sono sicuro , ma nell ebuild dovrebbe esserci il relativo warning
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Thu Jul 12, 2018 3:57 pm    Post subject: Reply with quote

se verrà fuori
darò il tuo comadno
Code:
sed -i 's/CONFIG_SND_HDA_PREALLOC_SIZE=.*/CONFIG_SND_HDA_PREALLOC_SIZE=2048/' /usr/src/linux/.config

di kernel ne so quanto un neonato che non ha ancora preso il latte

prima ho installato wmctrl ho dato emerge --sync
ed ho letto la news
Code:

2018-07-11-portage-sync-allow-hardlinks
  Title                     Portage rsync hardlink support
  Author                    Zac Medico <zmedico@gentoo.org>
  Posted                    2018-07-11
  Revision                  1

For users of the rsync tree, beginning with sys-apps/portage-2.3.42,
the default behavior for sync operations will use hardlinks in order
to ensure that a repository remains in a valid state if something
goes wrong [1]. For example, if signature verification fails during a
sync operation, the new hardlink behavior will preserve the previous
state of the repository.

The new behavior may conflict with configurations that restrict the
use of hardlinks, such as overlay filesystems. Therefore, users will
have to set "sync-allow-hardlinks = no" in repos.conf if they have
a configuration that restricts the use of hardlinks, but this should
not be very common:

[DEFAULT]
sync-allow-hardlinks = no

Note that it is possible to sync more efficiently using git [2]
instead of rsync, though git consumes an increasing amount of disk
space over time unless shallow pull is enabled via the sync-depth
option in repos.conf [3] (requires sys-apps/portage-2.3.42 or later).

[1] https://bugs.gentoo.org/660410 sys-apps/portage: use rsync
    --link-dest to implement atomic repository updates (and abort if
    signature verification fails)
[2] https://wiki.gentoo.org/wiki/Portage_Security#git-mirror_repo
[3] https://bugs.gentoo.org/552814 sys-apps/portage: support shallow
    git pull by setting sync-depth = 1 in repos.conf


mi dice di aggiungere la riga sync-allow-hardlinks = no in make.conf
giusto?
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 620

PostPosted: Thu Jul 12, 2018 5:29 pm    Post subject: Reply with quote

Il warnng del kernel è relativo a

media-sound/pulseaudio che su chromium è una USE (abilita il server audio al browser)

l'ebuild di pulseaudio contiene :
Code:
pkg_pretend() {
        CONFIG_CHECK="~HIGH_RES_TIMERS"
        WARNING_HIGH_RES_TIMERS="CONFIG_HIGH_RES_TIMERS:\tis not set (required for enabling timer-based scheduling in pulseaudio)\n"
        check_extra_config

        if linux_config_exists; then
                local snd_hda_prealloc_size=$(linux_chkconfig_string SND_HDA_PREALLOC_SIZE)
                if [ -n "${snd_hda_prealloc_size}" ] && [ "${snd_hda_prealloc_size}" -lt 2048 ]; then
                        ewarn "A preallocated buffer-size of 2048 (kB) or higher is recommended for the HD-audio driver!"
                        ewarn "CONFIG_SND_HDA_PREALLOC_SIZE=${snd_hda_prealloc_size}"
                fi
        fi
}


che non fa altro che controllare la dimensione del buffer audio a livello del kernel.
Quindi tutti i pacchetti che hanno come USE "pulseaudio" abilitato probabilmente ti daranno questo avviso

I pacchetti in oggetto al momento sono grossomodo questi , non specifici per versione.
Code:
equery h pulseaudio
 * Searching for USE flag pulseaudio ...
[IP-] [  ] app-accessibility/espeak-1.48.04-r1:0
[IP-] [  ] app-accessibility/speech-dispatcher-0.8.7:0
[IP-] [  ] app-admin/conky-1.10.8-r1:0
[IP-] [  ] app-emulation/qemu-2.12.0-r3:0
[I--] [??] app-emulation/wine-any-2.19:2.19
[IP-] [  ] dev-java/icedtea-bin-3.7.0:8
[IP-] [  ] dev-qt/qtmultimedia-5.9.6:5/5.9
[I--] [??] dev-qt/qtwebengine-5.9.6:5/5.9
[IP-] [  ] dev-util/electron-1.6.16:1.6
[IP-] [  ] kde-plasma/plasma-desktop-5.12.6:5
[IP-] [  ] kde-plasma/plasma-meta-5.12.6:5
[I--] [??] mail-client/thunderbird-52.8.0:0
[IP-] [  ] media-libs/libao-1.2.2:0
[IP-] [  ] media-libs/libcanberra-0.30-r5:0
[IP-] [  ] media-libs/libsdl-1.2.15-r9:0
[I--] [??] media-libs/libsdl-2.0.0_pre7001:2
[IP-] [  ] media-libs/libsdl2-2.0.8-r1:0
[IP-] [  ] media-libs/openal-1.18.2-r1:0
[IP-] [  ] media-libs/phonon-4.10.1:0
[IP-] [  ] media-libs/xine-lib-1.2.9-r1:1
[IP-] [  ] media-plugins/alsa-plugins-1.1.5:0
[IP-] [  ] media-plugins/gst-plugins-meta-1.12.4:1.0
[IP-] [  ] media-sound/clementine-1.3.1_p20180523:0
[IP-] [  ] media-sound/mpg123-1.25.10:0
[IP-] [  ] media-sound/sox-14.4.2-r1:0
[IP-] [  ] media-tv/kodi-17.6-r2:0
[IP-] [M ] media-video/ffmpeg-3.4.2-r1:0/55.57.57
[IP-] [  ] media-video/vlc-3.0.3-r1:0/5-9
[IP-] [  ] www-client/chromium-67.0.3396.87:0
[IP-] [  ] www-client/firefox-61.0:0

_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Fri Jul 13, 2018 9:32 am    Post subject: Reply with quote

allora ho dato
Code:
sed -i 's/CONFIG_SND_HDA_PREALLOC_SIZE=.*/CONFIG_SND_HDA_PREALLOC_SIZE=2048/' /usr/src/linux/.config



Code:
echo "sync-allow-hardlinks = no" >> /etc/portage/make.conf

questa riga non è stata riconosciuta da emerge --sync , quindi l'ho eliminata

dopo ho dato
Code:
emerge --sync


Code:
emerge --update --changed-use --deep --with-bdeps=y @world


Code:
emerge --ask --depclean

ho dato yes
e mi ha restituito a fine compilazione
Code:
!!! existing preserved libs:
>>> package: media-sound/mpg123-1.25.6
 *  - /usr/lib64/libmpg123.so.0
 *  - /usr/lib64/libmpg123.so.0.44.5
 *      used by /usr/lib64/vlc/plugins/codec/libmpg123_plugin.so (media-video/vlc-3.0.3-r1)
>>> package: media-sound/jack-audio-connection-kit-0.125.0
 *  - /usr/lib64/libjack.so.0
 *  - /usr/lib64/libjack.so.0.0.28
 *      used by /usr/bin/audacity (media-sound/audacity-2.1.3-r1)
Use emerge @preserved-rebuild to rebuild packages using these libraries


quindi ho lanciato
Code:
 emerge @preserved-rebuild

dopo
Code:
emerge --ask --depclean

e non c'era niente da eliminare infine ho dato
Code:
 emerge --update --newuse --deep @world

che mi dato questo
Code:
gentoo /home/trigg # emerge --update --newuse --deep @world
Calculating dependencies... done!
>>> Auto-cleaning packages..

>>> No outdated packages were found on your system.



penso che adesso è quasi tutto ok
l'unica cosa rimasta da fare è di eliminare i
3GB di compilazione di chromium interrotta
mi sono rimasti 9 GB di spazio libero
e devo rimuovere i 3 GB di compilazione creati dall'aggiornamento di chromium che ho disinstallato
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19910
Location: here

PostPosted: Fri Jul 13, 2018 11:52 am    Post subject: Reply with quote

trigg wrote:
Code:
echo "sync-allow-hardlinks = no" >> /etc/portage/make.conf

questa riga non è stata riconosciuta da emerge --sync , quindi l'ho eliminata

Questa e' da mettere nel /etc/portage/repos.conf/gentoo.conf, non nel make.conf

trigg wrote:
penso che adesso è quasi tutto ok
l'unica cosa rimasta da fare è di eliminare i
3GB di compilazione di chromium interrotta
mi sono rimasti 9 GB di spazio libero
e devo rimuovere i 3 GB di compilazione creati dall'aggiornamento di chromium che ho disinstallato

Questo lo puoi fare eliminando le directory sotto /var/tmp/portage/ o facendo un riavvio.
Ogni tanto usa anche eclean-dist (pacchetto app-portage/gentoolkit) questo elimina le vecchie versioni dei sorgenti che si trovano in /usr/portage/distfiles
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Fri Jul 13, 2018 12:20 pm    Post subject: Reply with quote

liberati quasi 5GB di spazio :)

aggiunto
echo "sync-allow-hardlinks = no" >> /etc/portage/repos.conf/gentoo.conf

e adesso ci siamo :
devo aprire un nuovo topic riguardo smplayer e l'audio di simple screen record

grazie penso di aver capito come fare a tenere aggiornato e pulito il sistema
Back to top
View user's profile Send private message
mscarpa69
n00b
n00b


Joined: 15 Jul 2018
Posts: 3

PostPosted: Sun Jul 15, 2018 2:08 pm    Post subject: Reply with quote

Cari tutti,
sono nuovo del forum e non so quindi se sbaglio a rispondere a questo messaggio per sottoporre un problema che ho e su cui non sono sicuro su come proseguire.

Ho un sistema basto su ~amd64 e provando a verificare un aggiornamento di sistema con il comando
Code:

emerge --update --newuse --deep --with-bdeps=y --verbose-conflicts -p @world

ho avuto come output
Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-crypt/openpgp-keys-gentoo-release-20180706 [20180530] USE="{-test%}"
[ebuild     U  ] dev-util/gperf-3.1 [3.0.4]
[ebuild     U  ] media-libs/libuninameslist-20091231-r1 [20091231]
[ebuild   R    ] sys-apps/keyutils-1.5.9-r4  KERNEL="(linux%*)"
[ebuild     U  ] sys-apps/coreutils-8.29-r1 [8.28-r1] USE="split-usr%*"
[ebuild     U  ] sys-libs/zlib-1.2.11-r2 [1.2.11-r1]
[ebuild  N     ] dev-libs/icu-60.2  USE="-debug -doc -examples -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] sys-libs/libunwind-1.2.1-r1 [1.2.1]
[ebuild  N     ] dev-libs/icu-58.2-r1  USE="-debug -doc -examples -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] media-libs/freetype-2.9.1-r3 [2.8]
[ebuild     U  ] dev-libs/libnl-3.4.0 [3.2.28] USE="debug%* threads%*" PYTHON_TARGETS="python3_6%*"
[ebuild     U  ] dev-python/pyxattr-0.6.0-r1 [0.5.5] PYTHON_TARGETS="python3_6%*"
[ebuild     U  ] dev-python/pyrsistent-0.14.2 [0.13.0]
[ebuild     U  ] virtual/perl-MIME-Base64-3.150.0-r4 [3.150.0-r3]
[ebuild     U  ] virtual/perl-CPAN-Meta-YAML-0.18.0-r3 [0.18.0-r2]
[ebuild   R    ] sys-apps/lm_sensors-3.4.0_p20170901  KERNEL="(linux%*)"
[ebuild     U  ] virtual/perl-Digest-1.170.100_rc-r7 [1.170.100_rc-r6]
[ebuild     U  ] virtual/perl-Text-ParseWords-3.300.0-r4 [3.300.0-r3]
[ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.700.0-r5 [1.700.0-r4]
[ebuild     U  ] sys-apps/sed-4.5 [4.2.2] USE="-forced-sandbox%"
[ebuild     U  ] app-arch/tar-1.30 [1.29-r3]
[ebuild     U  ] sys-devel/gdb-8.1-r1 [7.12.1] PYTHON_SINGLE_TARGET="-python3_6%" PYTHON_TARGETS="python3_6%*"
[ebuild  NS    ] sys-devel/gcc-7.3.0-r3 [6.4.0-r1] USE="cxx fortran (multilib) nls nptl openmp pch (pie) sanitize ssp vtv (-altivec) -cilk -debug -doc (-fixed-point) -go -graphite (-hardened) (-jit) (-libssp) -mpx -objc -objc++ -objc-gc -pgo -regression-test -vanilla"
[ebuild  NS    ] sys-kernel/gentoo-sources-4.14.52 [4.9.95] USE="-build -experimental -symlink"
[ebuild     U  ] kde-frameworks/kf-env-5 [4]
[ebuild     U  ] dev-qt/qtcore-5.9.6 [5.9.4-r2]
[ebuild     U  ] dev-qt/qtxml-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtconcurrent-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qttest-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtpaths-5.9.6 [5.9.4]
[ebuild     U  ] app-crypt/libsecret-0.18.6-r1 [0.18.6] ABI_X86="32%* (64%*) (-x32)"
[ebuild  NS   #] dev-qt/qtcore-4.8.7-r4 [5.9.4-r2] USE="exceptions glib iconv icu ssl (-aqua) -debug -libressl -pch -qt3support" ABI_X86="32 (64) (-x32)"
[ebuild  N    #] dev-qt/qttranslations-4.8.7  ABI_X86="32 (64) (-x32)"
[ebuild     U  ] media-libs/harfbuzz-1.8.1 [1.7.6]
[ebuild   R    ] media-libs/libv4l-1.10.1  KERNEL="(linux%*)"
[ebuild     U  ] sys-libs/libcap-2.25 [2.24-r2]
[ebuild   R    ] net-vpn/openvpn-2.4.6  KERNEL="(linux%*)"
[ebuild     U  ] dev-qt/qtsql-5.9.6-r1 [5.9.4-r1]
[ebuild   R    ] net-fs/cifs-utils-6.7  KERNEL="(linux%*)"
[ebuild   R    ] x11-drivers/xf86-input-evdev-2.10.6  KERNEL="(linux%*)"
[ebuild   R    ] x11-drivers/xf86-input-libinput-0.27.1  KERNEL="(linux%*)"
[ebuild     U  ] net-misc/curl-7.61.0 [7.60.0]
[ebuild     U  ] dev-db/mysql-connector-c++-1.1.9 [1.1.6]
[ebuild     U  ] sys-apps/man-pages-4.15 [4.14]
[ebuild     U  ] sys-apps/util-linux-2.32-r4 [2.30.2-r1]
[ebuild     U  ] sys-apps/gptfdisk-1.0.3 [1.0.1]
[ebuild   R    ] sys-fs/lvm2-2.02.145-r2  KERNEL="(linux%*)"
[ebuild   R    ] sys-fs/cryptsetup-1.7.5  KERNEL="(linux%*)"
[ebuild   R    ] sys-fs/udev-238  KERNEL="(linux%*)"
[ebuild     U  ] net-misc/openssh-7.7_p1-r6 [7.7_p1-r4]
[ebuild     U  ] app-crypt/gpgme-1.11.1 [1.10.0]
[ebuild   R    ] sys-fs/udisks-2.7.4-r1  KERNEL="(linux%*)"
[ebuild     U  ] app-text/texlive-core-2017-r4 [2017-r3]
[ebuild   R    ] sys-apps/dbus-1.10.24  KERNEL="(linux%*)"
[ebuild     U  ] dev-qt/qtdbus-5.9.6 [5.9.4]
[ebuild   R    ] net-print/cups-2.2.7  KERNEL="(linux%*)"
[ebuild     U  ] dev-qt/qtgui-5.9.6 [5.9.4-r3]
[ebuild     U  ] x11-libs/gtk+-3.22.30 [3.22.29]
[ebuild     U  ] x11-libs/gtk+-2.24.32 [2.24.31-r1]
[ebuild   R    ] net-fs/samba-4.5.16  KERNEL="(linux%*)"
[ebuild     U  ] dev-qt/qdbus-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtwidgets-5.9.6-r1 [5.9.4-r1]
[ebuild     U  ] dev-qt/qtx11extras-5.9.6 [5.9.4]
[ebuild   R    ] net-dialup/ppp-2.4.7-r6  KERNEL="(linux%*)"
[ebuild     U ~] net-im/skypeforlinux-8.25.0.5 [8.22.0.2]
[ebuild     U  ] www-client/google-chrome-67.0.3396.99 [67.0.3396.87]
[ebuild     U  ] dev-qt/qtsvg-5.9.6 [5.9.4-r2]
[ebuild     U  ] dev-qt/qtscript-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtprintsupport-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtopengl-5.9.6 [5.9.4]
[ebuild     U  ] app-arch/p7zip-16.02-r4 [16.02-r2]
[ebuild     U  ] x11-libs/qscintilla-2.10.4 [2.10.3]
[ebuild     U  ] net-misc/networkmanager-1.10.10 [1.8.4] USE="-ovs%"
[ebuild     U  ] dev-qt/qtnetwork-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtxmlpatterns-5.9.6 [5.9.4]
[ebuild     U  ] sys-boot/unetbootin-661 [657]
[ebuild     U  ] dev-qt/qtdeclarative-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/linguist-tools-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtgraphicaleffects-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/designer-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtquickcontrols-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtwayland-5.9.6 [5.9.4-r1]
[ebuild     U  ] dev-qt/qtvirtualkeyboard-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtsensors-5.9.6 [5.9.4]
[ebuild     U  ] dev-qt/qtquickcontrols2-5.9.6 [5.9.4]
[ebuild     U  ] kde-frameworks/kirigami-5.46.0-r1 [5.46.0]
[ebuild     U  ] media-sound/pulseaudio-11.1-r1 [11.1] USE="qt5%*"
[ebuild   R    ] app-emulation/virtualbox-5.1.36  KERNEL="(linux%*)"
[ebuild     U  ] dev-qt/qtmultimedia-5.9.6 [5.9.4-r1]
[ebuild     U  ] media-video/vlc-3.0.3-r1 [3.0.2-r1]
[ebuild     U  ] mail-client/thunderbird-52.9.0 [52.8.0]
[ebuild     U  ] net-misc/networkmanager-openvpn-1.8.4 [1.8.2]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-60.2:0/60.2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/60.2= required by (media-libs/raptor-2.0.14:2/2::gentoo, installed)
                ^^^^^^^^                                                                                                 
    dev-libs/icu:0/60.2= required by (app-text/libmspub-0.1.4:0/0::gentoo, installed)
                ^^^^^^^^                                                                                                 
    >=dev-libs/icu-4.4:0/60.2= required by (dev-tex/bibtexu-3.71_p20170524:0/0::gentoo, installed)
                      ^^^^^^^^                                                                                                       
    dev-libs/icu:0/60.2= required by (app-text/libebook-0.1.2-r1:0/0::gentoo, installed)
                ^^^^^^^^                                                                                                   
    dev-libs/icu:0/60.2= required by (media-libs/libzmf-0.0.2:0/0::gentoo, installed)
                ^^^^^^^^                                                                                                 
    dev-libs/icu:0/60.2= required by (dev-qt/qtwebkit-5.9.1:5/5.9::gentoo, installed)
                ^^^^^^^^                                                                                                 
    dev-libs/icu:0/60.2= required by (media-libs/libcdr-0.1.4:0/0::gentoo, installed)
                ^^^^^^^^                                                                                                 
    dev-libs/icu:0/60.2= required by (media-libs/libvisio-0.1.6:0/0::gentoo, installed)
                ^^^^^^^^                                                                                                   
    dev-libs/icu:0/60.2= required by (dev-libs/libical-2.0.0-r3:0/2::gentoo, installed)
                ^^^^^^^^                                                                                                   
    >=dev-libs/icu-51.2-r1:0/60.2=[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/libxml2-2.9.8:2/2::gentoo, installed)
                          ^^^^^^^^                                                                                                                             
    >=dev-libs/icu-3.6:0/60.2=[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/boost-1.65.0:0/1.65.0::gentoo, installed)
                      ^^^^^^^^                                                                                                                                 
    dev-libs/icu:0/60.2= required by (app-office/libreoffice-6.0.3.2:0/0::gentoo, installed)
                ^^^^^^^^                                                                                                       
    dev-libs/icu:0/60.2=[abi_x86_32(-),abi_x86_64(-)] required by (dev-db/sqlite-3.23.1:3/3::gentoo, installed)
                ^^^^^^^^                                                                                                                           
    dev-libs/icu:0/60.2= required by (app-text/libqxp-0.0.1:0/0::gentoo, installed)
                ^^^^^^^^                                                                                               

  (dev-libs/icu-58.2-r1:0/58.2::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/icu-59:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.7-r4:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^ ^                                                                                                                                                                                                                                                                                                                       


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by dev-qt/qttranslations-4.8.7::gentoo
# /usr/portage/profiles/package.mask:
# Andreas Sturmlechner <asturm@gentoo.org> (26 Jun 2018)
# Mask Qt4 for removal. Bug #631788
=dev-qt/qtcore-4.8.7-r4
# required by dev-qt/qtcore-4.8.7-r4::gentoo
# required by dev-vcs/svn2git-1.0.10::gentoo
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Andreas Sturmlechner <asturm@gentoo.org> (26 Jun 2018)
# Mask Qt4 for removal. Bug #631788
=dev-qt/qttranslations-4.8.7

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


Con questo messaggio ho due dubbi su come proseguire senza rendere instabile la mia installazione.

Il primo e' che non so come risolvere il coflitto sullo slot relativo al pacchetto qt-core.
Il secondo e' relativo la fatto che qt-core-4.8.7-r4 dovrebbe essere smascherato per essere installato; potrei farlo (anche con l'autounmask) ma mi chiedo se e' possibile avere il sistema completamente migrato a qt5 visto che qt4 e' mascherato.
Ho cercato se esiste qualche guida per la migrazione ma non la ho trovata; spero di aver cercato bene e mi scuso se la domanda e' ridondante.

Come potrei procedere per avere un aggiornameto il piu' "pulito" possibile?

Ringrazio per qualunque suggerimento possa farmi sbloccare da questa situaizone di incertezza.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19910
Location: here

PostPosted: Sun Jul 15, 2018 2:28 pm    Post subject: Reply with quote

Prima di tutto benvenuto nel forum di gentoo.

Solitamente se hai un nuovo problema apri un nuovo thread, e vero che si parla di aggiornamento ma il tuo e' un problema specifico.

Per passare al tuo problema qua mi pare sia solo il pacchetto dev-qt/qtcore-4.8.7 (fra poco verra' anche rimosso) che crea il blocco, questo viene richiesto dal pacchetto dev-vcs/svn2git-1.0.10 che non piu' presente in portage tree con questa versione.
Per risolvere basta che smascheri la version 1.0.11-r1 di svn2git che dipende dalle qt5.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
mscarpa69
n00b
n00b


Joined: 15 Jul 2018
Posts: 3

PostPosted: Sun Jul 15, 2018 6:22 pm    Post subject: Reply with quote

Grazie mille per il suggerimento e mi scuso per l'errore.
Pensavo che il thread fosse pertinente e quindi che non fosse adeguato farne un altro.
Starò più attento in futuro.

Appena rientro provo a smascherare la versione adatta di svn2git e provo a riaggoiornare.

Oppure dovrebbe anche andare se tolgo completamente svn2git con un unmerge, giusto?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19910
Location: here

PostPosted: Sun Jul 15, 2018 6:50 pm    Post subject: Reply with quote

mscarpa69 wrote:
Oppure dovrebbe anche andare se tolgo completamente svn2git con un unmerge, giusto?

Anche va bene se non e' una dipendenza di qualche altro pacchetto se no cerca di installarlo di nuovo
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
mscarpa69
n00b
n00b


Joined: 15 Jul 2018
Posts: 3

PostPosted: Mon Jul 16, 2018 7:24 am    Post subject: Reply with quote

Ho fatto l'unmerge di svn2git e l'aggiornamento e' andato a buon fine.
Dopo gli usuali
Code:
emerge --depclean
e
Code:
 revdep-rebuild
l'installazione e' coerente e le qt sono aggiornate alle qt5 senza alcun riferimento alle qt4.

Grazie mille per il prezioso suggerimento..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum