Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Configuring xorg for amdgpu
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
stephansama
n00b
n00b


Joined: 11 Jul 2018
Posts: 2

PostPosted: Wed Jul 11, 2018 3:08 pm    Post subject: Configuring xorg for amdgpu Reply with quote

Hey all, I built my computer not too long ago and installed gentoo on it.

I didn't install a de as I wanted to use i3 with gaps instead.

But my system only displays in 1024x768.

I updated the kernel
I added the use flags
I added a preferred option inside of a monitor conf (but unable to use specific monitor name since)
Xrandr only gives me that it failed to get the size of the gamma.

I don't know where I'm going wrong.

CPU: Ryzen 5 1600
GPU: RX 460
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44195
Location: 56N 3W

PostPosted: Wed Jul 11, 2018 4:48 pm    Post subject: Reply with quote

stephansama,

Welcome to Gentoo.

Please put your /var/log/Xorg.0.log onto a pastebin site and post the link.
Its too big to fit into a post.

wgetpaste can help you.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
stephansama
n00b
n00b


Joined: 11 Jul 2018
Posts: 2

PostPosted: Wed Jul 11, 2018 5:07 pm    Post subject: Reply with quote

NeddySeagoon wrote:

Please put your /var/log/Xorg.0.log onto a pastebin site and post the link.
Its too big to fit into a post.


Here it is https://pastebin.com/89Kj41Y0
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44195
Location: 56N 3W

PostPosted: Wed Jul 11, 2018 5:26 pm    Post subject: Reply with quote

stephansama,

Code:
[     7.817] Current Operating System: Linux gentoo-rx516 4.14.52-gentoo #1 SMP Mon Jul 9 14:27:19 CDT 2018 x86_64
the amdgpu driver was rewritten for kernel 4.15.0 and lots of things that were turmed off by default became enabled.

Code:
[     7.928] (II) RADEON: Driver for ATI/AMD Radeon chipsets:

You are trying to use the Radeon driver, not amdgpu but that fails
Code:
[     7.931] (EE) open /dev/dri/card0: No such file or directory

because kernel support is missing.

Eventually, Xorg starts with the fbdev driver
Code:
[     7.931] (--) FBDEV(0): Virtual size is 1024x768 (pitch 1024)


Upgrade your kernel to the current testing kernel, thats 4.17.x
Follow the wiki for kernel settings, a few other things, then run
Code:
emerge -uNDav @world
so the settings take effect.

Eventually, the log should show something like my
Code:
 [    46.905] (--) AMDGPU(0): Chipset: "AMD Radeon (TM) RX 460 Graphics" (ChipID = 0x67ef)

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum