Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Docker Error starting daemon
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Kubaschi
n00b
n00b


Joined: 16 Jul 2018
Posts: 1

PostPosted: Fri Jul 20, 2018 9:11 pm    Post subject: Docker Error starting daemon Reply with quote

Greetings,

I have a problem getting docker setup on my gentoo laptop.

dockerd manual start:
Code:

WARN[2018-07-20T23:00:31.892424228+02:00] Running modprobe bridge br_netfilter failed with message: modprobe: WARNING: Module bridge not found in directory /lib/modules/4.14.52-gentoo
modprobe: WARNING: Module br_netfilter not found in directory /lib/modules/4.14.52-gentoo
, error: exit status 1
WARN[2018-07-20T23:00:31.905500757+02:00] Running modprobe nf_nat failed with message: `modprobe: ERROR: could not insert 'nf_nat': Exec format error
insmod /lib/modules/4.14.52-gentoo/kernel/net/netfilter/nf_nat.ko`, error: exit status 1
INFO[2018-07-20T23:00:31.935282597+02:00] Default bridge (docker0) is assigned with an IP address 172.17.0.0/16. Daemon option --bip can be used to set a preferred IP address
Error starting daemon: Error initializing network controller: Error creating default "bridge" network: package not installed


Kernel values related to bridge:
Code:

grep BRIDGE /boot/config-4.14.52-gentoo
CONFIG_BRIDGE_NETFILTER=y
# CONFIG_BRIDGE_NF_EBTABLES is not set
CONFIG_BRIDGE=y
CONFIG_BRIDGE_IGMP_SNOOPING=y
CONFIG_DRM_BRIDGE=y
CONFIG_DRM_PANEL_BRIDGE=y
# CONFIG_EDAC_SBRIDGE is not set


Trying to add a bridge manually with brctl gives me the same error as what docker tells me:
Code:

brctl addbr docker0
add bridge failed: Package not installed


Does anyone has an idea where I am missing something ?

Thanks in advance
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 814

PostPosted: Sat Jul 21, 2018 6:48 pm    Post subject: Reply with quote

looks like you're missing some crucial modules:
Quote:
424228+02:00] Running modprobe bridge br_netfilter failed with message: modprobe:


and there is another problem:
Quote:
`modprobe: ERROR: could not insert 'nf_nat': Exec format error
insmod /lib/modules/4.14.52-gentoo/kernel/net/netfilter/nf_nat.ko`,


try to re-compile your kernel with all the necessary modules (listed in the docker-ebuild); some stuff works better with docker as modules. Maybe this solves the second error, too.
GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum