Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Amdgpu + mesa compiled with video_cards_radeonsi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
jimmij
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2008
Posts: 139

PostPosted: Tue Aug 21, 2018 2:45 pm    Post subject: Amdgpu + mesa compiled with video_cards_radeonsi Reply with quote

I have amdgpu (stoney, device 98e4) which, according to https://wiki.gentoo.org/wiki/AMDGPU, should be set in make.conf as VIDEO_CARDS='amdgpu radeonsi'. Everything works fine under gnome3 or in console, but when I log-in to mate or pure sawfish I observe very strange behavior: I can run a terminal and even firefox, but some operations (for example switching the workspace) freeze all windows. Actually they don't freeze, just the graphics don't get "refreshed", so I can hear the sound, click or even write commands (blindfold) in the terminal to get the job done. I'm able to refresh the screen manually by switching to VT and back, sometimes switching between windows works as refresher too, although not always.

Now, I was able to pinpoint the problem to media-libs/mesa; the issue exists only when mesa is compiled with "radeonsi" flag, replacing it to "radeon" solves the problem. Obviously this is not the real solution because with radeon driver I cannot get my card working properly, for example mplayer cannot run in fullscreen mode and claims my driver is wrong. So, for now I have to work in gnome3 which I really hate, but because it works there I suspect that the problem lies not in kernel or mesa but rather in Xorg.conf somewhere. I didn't play with this myself, so far everything is on auto-mode, but I don't see anything wrong in /var/log/Xorg.0.log, drivers are being detected and configured properly.

My current set-up:
kernel: gentoo-sources-4.18.3
mesa: newest git version (**9999)
xorg-drivers: **9999

Any suggestions where to dig further?
_________________
Vanitas vanitatum et omnia vanitas.
Libera temet ex inferis.
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 697
Location: tra veneto e friuli (italy)

PostPosted: Tue Aug 21, 2018 9:40 pm    Post subject: Re: Amdgpu + mesa compiled with video_cards_radeonsi Reply with quote

jimmij wrote:
I have amdgpu (stoney, device 98e4)
[...snip...]
Obviously this is not the real solution because with radeon driver I cannot get my card working properly, for example mplayer cannot run in fullscreen mode and claims my driver is wrong. So, for now I have to work in gnome3 which I really hate, but because it works there I suspect that the problem lies not in kernel or mesa but rather in Xorg.conf somewhere.

Stoney is a GCN-3 card, so, if I'm correct, only amdgpu kernel module can works.
You can disable the radeon kernel driver at bootprompt with:
Code:
modprobe.blacklist=radeon


You can leave both radeon and radeonsi USE for mesa and xorg-drivers:
Code:
xdarma@ichigo ~ $ eix --installed-with-use --only-names video_cards_radeonsi
media-libs/mesa
x11-base/xorg-drivers

Code:
xdarma@ichigo ~ $ eix --installed-with-use --only-names video_cards_radeon
media-libs/mesa
x11-base/xorg-drivers
x11-libs/libdrm

Code:
xdarma@ichigo ~ $ eix --installed-with-use --only-names video_cards_amdgpu
virtual/opencl
x11-base/xorg-drivers
x11-libs/libdrm

_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
jimmij
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2008
Posts: 139

PostPosted: Tue Aug 21, 2018 11:08 pm    Post subject: Re: Amdgpu + mesa compiled with video_cards_radeonsi Reply with quote

xdarma wrote:
jimmij wrote:
I have amdgpu (stoney, device 98e4)
[...snip...]
Obviously this is not the real solution because with radeon driver I cannot get my card working properly, for example mplayer cannot run in fullscreen mode and claims my driver is wrong. So, for now I have to work in gnome3 which I really hate, but because it works there I suspect that the problem lies not in kernel or mesa but rather in Xorg.conf somewhere.

Stoney is a GCN-3 card, so, if I'm correct, only amdgpu kernel module can works.
You can disable the radeon kernel driver at bootprompt with:
Code:
modprobe.blacklist=radeon


I didn't compile radeon into the kernel, so have nothing to blacklist.
_________________
Vanitas vanitatum et omnia vanitas.
Libera temet ex inferis.
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 697
Location: tra veneto e friuli (italy)

PostPosted: Wed Aug 22, 2018 6:41 am    Post subject: Reply with quote

I don't think you can use the radeon xorg driver with the amdgpu kernel driver:
Code:
xdarma@ichigo ~ $ grep radeon /var/log/Xorg.0.log
[    20.701] Kernel command line: BOOT_IMAGE=/boot/kernel-opencl-x86_64-4.17.12-gentoo.s1 root=/dev/md6 ro rootfstype=btrfs video=1920x1080 modprobe.blacklist=radeon amdgpu.si_support=1 amdgpu.cik_support=1
[    20.725] (II) LoadModule: "radeon"
[    20.726] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
[    20.728] (II) Module radeon: vendor="X.Org Foundation"
[    21.180] (II) UnloadModule: "radeon"
[    21.180] (II) Unloading radeon
[    21.180] (II) AMDGPU(0): [DRI2]   DRI driver: radeonsi
[    21.180] (II) AMDGPU(0): [DRI2]   VDPAU driver: radeonsi

My card is a GCN-1 generation (radeonsi), the radeon kernel driver is blacklisted, Xorg unload the radeon driver and keep in use the amdgpu driver.

I'm using this setup for make.conf:
Code:
xdarma@ichigo ~ $ grep VIDEO /etc/portage/make.conf
VIDEO_CARDS="vesa amdgpu radeon radeonsi"

_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
jimmij
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2008
Posts: 139

PostPosted: Wed Aug 22, 2018 9:00 am    Post subject: Reply with quote

xdarma wrote:
I don't think you can use the radeon xorg driver with the amdgpu kernel driver:

I don't use radeon driver, I use amdgpu_drv.so loaded from /usr/lib/xorg/modules/drivers/. In fact I tried to remove "radeon" everywhere to avoid any conflicts, there is only one package which forcibly, by itself, sets video_cards_radeon flag and it is x11-libs/libdrm (required by mesa); but it uses also video_cards_amdgpu, so perhaps I should try to recompile it somehow without video_cards_radeon as well?
_________________
Vanitas vanitatum et omnia vanitas.
Libera temet ex inferis.
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 697
Location: tra veneto e friuli (italy)

PostPosted: Wed Aug 22, 2018 9:24 am    Post subject: Reply with quote

My system works with the opposite setup: full support for all amdgpu, radeon and radeonsi.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
jimmij
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2008
Posts: 139

PostPosted: Mon Aug 27, 2018 10:37 pm    Post subject: Reply with quote

If someone struggle with similar problem:
I solved this issue by disabling DRM_AMD_DC_FBC, located at
-> Device Drivers
-> Graphics support
-> Display Engine Configuration
-> AMD DC - Enable new display engine
-> AMD FBC - Enable Frame Buffer Compression
_________________
Vanitas vanitatum et omnia vanitas.
Libera temet ex inferis.
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 697
Location: tra veneto e friuli (italy)

PostPosted: Tue Aug 28, 2018 6:33 pm    Post subject: Reply with quote

Enabling all relevant USE does not solve the various problems?
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum