Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Radeon™ RX Vega M GH graphics
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Wizumwalt
Guru
Guru


Joined: 20 Aug 2006
Posts: 474

PostPosted: Sun Aug 26, 2018 6:22 am    Post subject: Radeon™ RX Vega M GH graphics Reply with quote

I have a NUC8i7HVK which has Radeon™ RX Vega M GH graphics. I've been following the AMDGPU Gentoo wiki page, but to no avail. I'm a bit confused as to exactly what "family" this SoC is, and not sure if the 4.14.65 kernel has the needed support.

When I run startx, I get constantly get:
Code:
Fatal Server error:
(EE) no screens found(EE)
(EE)

Thoughts?
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7094
Location: Saint Amant, Acadiana

PostPosted: Sun Aug 26, 2018 11:00 am    Post subject: Reply with quote

There is kernel driver database at cateee.net, you can check there.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3961
Location: Dallas area

PostPosted: Sun Aug 26, 2018 11:13 am    Post subject: Reply with quote

Does sysrescuecd run? If so you can see what it says with lspci.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43213
Location: 56N 3W

PostPosted: Sun Aug 26, 2018 11:39 am    Post subject: Reply with quote

Wizumwalt,

Put the entire /var/log/Xorg.0.log onto a pastebin.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Wizumwalt
Guru
Guru


Joined: 20 Aug 2006
Posts: 474

PostPosted: Sun Aug 26, 2018 6:08 pm    Post subject: Reply with quote

Here's the Xorg log ...
https://pastebin.com/bgL2Yk1E
Back to top
View user's profile Send private message
Wizumwalt
Guru
Guru


Joined: 20 Aug 2006
Posts: 474

PostPosted: Sun Aug 26, 2018 6:10 pm    Post subject: Reply with quote

Anon-E-moose wrote:
Does sysrescuecd run? If so you can see what it says with lspci.

It's now booting from the SSD and reports ...
Code:
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Device 694c (rev c0) (prog-if 00 [VGA Controller])

Also, I believe the chipset name is Polaris 22, but that's not listed either.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43213
Location: 56N 3W

PostPosted: Sun Aug 26, 2018 6:17 pm    Post subject: Reply with quote

Wizumwalt,

The automatic hardware detection shows
Code:
[   483.462] (==) Matched intel as autoconfigured driver 0
[   483.462] (==) Matched ati as autoconfigured driver 1
[   483.462] (==) Matched modesetting as autoconfigured driver 2
[   483.462] (==) Matched fbdev as autoconfigured driver 3
[   483.462] (==) Matched vesa as autoconfigured driver 4


It loaded all of those correctly and found that it can't use any of them.

You actually have two graphics cards
Code:
[   483.462] (--) PCI: (0:0:2:0) 8086:591b:8086:2073 rev 4, Mem @ 0x2ffe000000/16777216, 0x2fa0000000/268435456, I/O @ 0x0000f000/64
[   483.462] (--) PCI:*(0:1:0:0) 1002:694c:8086:2073 rev 192, Mem @ 0x90000000/268435456, 0xa0000000/2097152, 0xdb500000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072


Xorg claim that your kernel is
Code:
[   483.457] Current Operating System: Linux localhost 4.14.65-gentoo #5 SMP Sun Aug 26 13:27:19 CDT 2018 x86_64


The amdgpu driver in the kernel was not complete until 4.17 and needed kernel command line parameters to force it to work at least until kernel 4.15 or 4.16.

Try the current ~arch kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7094
Location: Saint Amant, Acadiana

PostPosted: Sun Aug 26, 2018 6:18 pm    Post subject: Reply with quote

OK, I looked it up for you on cateee.net. 694c was first included in kernel 4.18.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Wizumwalt
Guru
Guru


Joined: 20 Aug 2006
Posts: 474

PostPosted: Sun Aug 26, 2018 10:55 pm    Post subject: Reply with quote

Thanks for the help on this. Unfortunately, 4.18.5 locks up at
Code:
[   0.309528] fb: switching to amdgpudrmfb from EFI VGA

Guess I'll have to wait a while to put this machine in commission.

Update: actually, it's not locked or crashed as it still passes events through (e.g., ctrl-alt-del), but it just won't continue.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7094
Location: Saint Amant, Acadiana

PostPosted: Mon Aug 27, 2018 3:26 am    Post subject: Reply with quote

Maybe it actually continues booting with screen blank. It would be useful to see the dmesg.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43213
Location: 56N 3W

PostPosted: Mon Aug 27, 2018 7:26 am    Post subject: Reply with quote

Wizumwalt,

That sounds like missing firmware and at 309.528ms into the boot process, amdgpu has to be built in, so the firmware needs to be built in too.
There is a lot of it too ...
Code:
ls /lib/firmware/amdgpu/vegam*
/lib/firmware/amdgpu/vegam_ce.bin    /lib/firmware/amdgpu/vegam_mec.bin  /lib/firmware/amdgpu/vegam_sdma1.bin  /lib/firmware/amdgpu/vegam_uvd.bin
/lib/firmware/amdgpu/vegam_me.bin    /lib/firmware/amdgpu/vegam_pfp.bin  /lib/firmware/amdgpu/vegam_sdma.bin   /lib/firmware/amdgpu/vegam_vce.bin
/lib/firmware/amdgpu/vegam_mec2.bin  /lib/firmware/amdgpu/vegam_rlc.bin  /lib/firmware/amdgpu/vegam_smc.bin


dmesg will tell.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum