Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Dell T7600 RAID and misc issues
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 19 Mar 2015
Posts: 203

PostPosted: Sun Sep 02, 2018 8:00 pm    Post subject: [Solved] Dell T7600 RAID and misc issues Reply with quote

I was doing a quick provision of a new workstation (Dell T7600) and the install went fine and I can boot into it, but when I was starting to create my raid arrays via mdadm I noticed that all but one of my drives were missing.

I am sure I added all the drivers since I always run the latest systemrescuecd then add everything I find in lspci -k, and when booted into my compiled kernel the sata and sas drivers are loaded (ahci, isci), but only my boot drive (120gb ssd) is available. No other drives are listed in lsblk or under /dev.

While booting I can see a raid management screen show up before grub boots. It is called "Intel rapid storage technology enterprise" and when I access it before grub loads it shows all my drives and they are labeled as "non-raid", which is good because I wanted to use mdadm after the kernel boots to use my raid. There are only 4 options in this raid utility and out of the options (create raid, remove raid, reset all raid to non-raid, exit) none of them I think would have any effect on presenting the drives to the booted OS.

I am not entirely sure what the systemrescuecd is doing differently to gain access to all my drives. If I have to though I guess I can use this raid management software rather than mdadm...

Here is dmesg from the systemrescuecd showing the drives being mounted:

Here is dmesg from my booted kernel:

There are two other things that puzzle me in my booted dmesg:

1) [ 5.357202] dell_smbios: No SMBIOS backends available (wmi: -19, smm: -19)
2)[ 5.374421] Unable to create integrity sysfs dir: -19

Any clues to resolve these would be nice as well.


Edit:: I decided to remove dell_smbios from the kernel fixing message 1. It seems more of a security risk than what convenience it serves. From what I read it allows you to configure the BIOS via specific WMI API interfaces, and in all reality if I ever needed to change something in the BIOS at a later date I can reboot.

Edit2:: Fixed message 2. I don't know what its for but CONFIG_SECURITYFS has to be set for the message to go away, and now I have securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime) mounted. Took a look at my laptops config and it is set as well so w/e.

Only thing that is left is the missing drives which I wish I had some clue to go on to try to figure out whats so different between my booted kernel and the systemrescuecd booted liveusb. My next step is to check the BIOS to see if I can turn the intel rapid technogarbage off and see if that changes anything.

Edit3:: Disabling the SATA/SAS raid controller that is built into the SATA/SAS hardware did not change anything. I wouldn't imagine it would seeing as the live USB can find the drives just fine.

Edit4:: I think I narrowed it down to a missing SCSI driver. Which I am not sure. I recall with one of my other servers I had a similar problem and it was due to a missing SCSI AACRAID driver, but that was a easy fix since I could find out what hardware i was using and there was clues left behind. I am not sure with this hardware since there is no hardware raid...

Last edited by abduct on Mon Sep 03, 2018 12:10 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 19 Mar 2015
Posts: 203

PostPosted: Mon Sep 03, 2018 12:09 am    Post subject: Reply with quote

After much searching and rereading the dmesg I provided after cluing in that this is probably a SCSI issue I found this in the log:

[    3.808422] sas: ATA device seen but CONFIG_SCSI_SAS_ATA=N so cannot attach

Enabling this kernel feature fixed the problems and now all the drives are showing up as they should.

New lesson for me I guess since I have never had to enable such a feature on any of my installs.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum