Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
DRM_RADEON changes text consoles to 4k resolution [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
mael
n00b
n00b


Joined: 28 Feb 2018
Posts: 37
Location: Germany

PostPosted: Thu Sep 13, 2018 6:12 pm    Post subject: DRM_RADEON changes text consoles to 4k resolution [SOLVED] Reply with quote

Hi All,

I have a rather silly but annoying problem. I have bought a very big and good Acer ET430k Monitor for my no longer so good working eyes an i use it with an AMD Radeon 290X with the drm_radeon kernel module.

The monitor supports 4k UHD resolution ( 3840 x 2160 ) which i DONT want to use in any case, neither classic linux text consoles nor x. all modes are correctly detected in x.

so far so good i have successfully forced x via a custom xorg.conf.d file to prefer full HD resolution ( 1920 x 1080 ) on the sddm login manager. KDE 5 uses also already full hd as i forced him to via the systemsettings app.

My problem is the needed DRM_RADEON kernel module changes text consoles to the "eye hurting" 4k UHD resolution every time i boot up. x and kde works as expected , but my text mode consoles a completely useless because the letters are unreadable small. they are displayed correctly, just way to small! :oops:

i tried vga kernel parameters and several grub.conf parameters but they seem only to affect the resolution BEFORE the drm_radeon kernel module takes control and boosting my text console to unreadable scales. i just want 1920x1080 :roll:

can anybody tell me how to force a lower resolution with an active drm_radeon kernel module on my classic text mode only linux consoles?
_________________
Gigabyte X99-SLI
Intel Core i7-5960X 16 Threads @ 3 Ghz
64 GB DDR4 RAM @ 2,13 Ghz
AMD Radeon 290X 8 GB RAM
Creative Soundblaster Z
Areca ARC-1883ix-16
16 Samsung 860 EVO 250 GB SSDs @ 3,5 TB RAID 6
Hauppauge HVR-5525
Firmwares are up-to-date


Last edited by mael on Fri Sep 14, 2018 3:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 432

PostPosted: Thu Sep 13, 2018 6:56 pm    Post subject: Reply with quote

If u using HDMI cable then switching cable to cheap HDMI to 1.1 version might force max 1920x1080 maybe ( or 4k with 30Hz, not sure :D)

Disabling modeseting might work - add nomodeset or maybe drm_radeon.modeset=0 ?

Try kernel option video=1920x1080 ? not sure if it will work.

Use bigger font in 4k terminal ? https://forums.gentoo.org/viewtopic-t-1072196-start-0.html -> there is some link
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44182
Location: 56N 3W

PostPosted: Thu Sep 13, 2018 8:36 pm    Post subject: Reply with quote

mael,

Check the name of your framebuffer in dmesg.
It will be something like drmradeonfb

dmesg | grep fb includes
Code:
[    1.498144] vesafb: mode is 1024x768x16, linelength=2048, pages=29
[    1.498147] vesafb: scrolling: redraw
[    1.498149] vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
[    1.498157] vesafb: framebuffer at 0xd0000000, mapped to 0x        (ptrval), using 3072k, total 49152k
[    1.506187] fb0: VESA VGA frame buffer device
[    1.507235] fb: switching to amdgpudrmfb from VESA VGA


On my kernel like, I have vga=0x317 video=vesafb:mtrr:3,ywrap, which gets me the
Code:
vesafb: mode is 1024x768x16,

If you change video=vesafb to video=drmradeonfb, it should apply to your drmradeonfb console.

I don't know the name of your framebuffer. Use what dmesg tells you.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mael
n00b
n00b


Joined: 28 Feb 2018
Posts: 37
Location: Germany

PostPosted: Fri Sep 14, 2018 3:22 pm    Post subject: Reply with quote

many thanks to both of you ...

CASE CLOSED :twisted:

the solution was simpler than i expected!

i just added

Code:
video=1920x1080-32@60


to my kernel parameter and it was nicely working as i expected from my older but still smooth box! seems that drm radeon kernel module still respect those parameters for the classic linux text mode consoles. all "vga=" and grub stuff didnt work at all, so i removed them!

i discovered in the arch wiki a nice article on enforcing lower resolutions on newer high resolution screens with enabled kms, we should adapt such a fine article into our own wiki as soon as possible!

https://wiki.archlinux.org/index.php/kernel_mode_setting

i will mark the thread as solved!

again thank you for your help guys
_________________
Gigabyte X99-SLI
Intel Core i7-5960X 16 Threads @ 3 Ghz
64 GB DDR4 RAM @ 2,13 Ghz
AMD Radeon 290X 8 GB RAM
Creative Soundblaster Z
Areca ARC-1883ix-16
16 Samsung 860 EVO 250 GB SSDs @ 3,5 TB RAID 6
Hauppauge HVR-5525
Firmwares are up-to-date
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum