Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] How to disable 2D acceleration for xorg-video-intel
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 06 Jan 2016
Posts: 130
Location: Germany

PostPosted: Sun Sep 16, 2018 4:50 pm    Post subject: [Solved] How to disable 2D acceleration for xorg-video-intel Reply with quote

Hallo friends.
I'm using Gentoo with Plasma 5.13.5, Systemd.This is my system:
emerge --info
Portage 2.3.40 (python 3.6.5-final-0, default/linux/amd64/17.0/desktop/plasma/systemd, gcc-7.3.0, glibc-2.26-r7, 4.18.5-gentoo_tuxedo x86_64)
System uname: Linux-4.18.5-gentoo_tuxedo-x86_64-Intel-R-_Core-TM-_i7-7700T_CPU_@_2.90GHz-with-gentoo-2.4.1
KiB Mem:     7842200 total,    954012 free
KiB Swap:    8392700 total,   8392700 free
Timestamp of repository gentoo: Sun, 16 Sep 2018 10:00:01 +0000
Head commit of repository gentoo: 9dd60d7be9f12d51e4974e12a1ff536544cb4b86
sh bash 4.4_p12
ld GNU ld (Gentoo 2.30 p2) 2.30.0
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.15::gentoo, 3.6.5::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r2::gentoo
sys-devel/binutils:       2.30-r2::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r7::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-verify-metamanifest: no
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24

CFLAGS="-march=broadwell -O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=broadwell -O2 -pipe"
EMERGE_DEFAULT_OPTS="--jobs=8 --load-average=6"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j9 -l8"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi activities aes alsa amd64 avx avx2 berkdb bluetooth branding bzip2 cairo cdda cdr cli crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif f16c fam ffmpeg flac fma3 fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi kwallet lcms ldap libnotify libtirpc mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pclmul pcre pdf phonon plasma png policykit popcnt ppds qml qt5 readline sdl seccomp semantic-desktop sockets spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="de en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby23" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

I just installes simplescreenrecorder which I remember a good, fass recording tool for desktop recording.
But I have trouble, when I am playing the recorded desktop (I saved in mp4 format).
There is a recurring flickering which is better described here:

A (possible) solution is also given here:
The recording occasionally flickers, showing parts of the desktop background instead of windows
This is a known problem with Mutter-based window managers, which are used by GNOME 3 and Cinnamon. Since this is a window manager flaw, other recording software is affected by this too. For Intel GPUs, the flickering can sometimes be eliminated by uninstalling the driver for 2D acceleration (xserver-xorg-video-intel, xf86-video-intel or similar). If that doesn't help, then the only solution is to switch to a different window manager, or use OpenGL recording.

I only have a cpu built in gpu in my intel processor, a HD630 gpu with 128MBytes shared memory.
I would like to follow the suggestion, so, how can I disable 2D acceleration , how can I the similar module to xserver-xorg-video-intel in Gentoo?
And: Will this affect anything in my Plasma?
Or: Do you have experiences with this topic (flickering of ssr recorded mp4 files) and you know how to prevent flickering?

Thank you very much in advance.


Last edited by linuxfluesterer on Wed Sep 19, 2018 2:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 06 Jan 2016
Posts: 130
Location: Germany

PostPosted: Wed Sep 19, 2018 2:43 pm    Post subject: Reply with quote

Hallo friends.
I got the solution. It was my mistake, to misunderstand the solution given in the linked url before.
I assumed, that xf86-video-intel was not x86-64 ( I must have been really blind or stupid).
But then I was given a hint to uninstall x11-drivers/xf86-video-intel, what I tried then.
The result is fine. Now, after testing with unmerged xf86-video-intel, my video recorded from screen doesn't flash any more.

I hope, I could help others with the same problem here.

Thank you for reading my thread.

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum