Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
grub-install: error: unknown filesystem during install
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
phirephoto
n00b
n00b


Joined: 23 Sep 2018
Posts: 24

PostPosted: Mon Oct 01, 2018 4:13 am    Post subject: Reply with quote

phirephoto wrote:
DONAHUE wrote:
emerge -avuND --keep-going world is running at 12 of 28 packages. sys-apps/openrc, net-misc/netifrc, sys-apps/sysvinit in etc/portage/package.mask to prevent blocks
emerge finished, WORLD IS UPDATED



* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.
:(

https://paste.pound-python.org/show/hpLFmLRdudSvyIVzIed5/


Oh boy. looks like the system got rebooted - loose power cable (it's a laptop). Now it boots to
root block device() :: !! Could not find the root block device in .
!! Please specify another value or:
!! - press Enter for the Same
!! - type "shell" for a shell
!! - type "q" to skip....

Did I just have a totally screwed up install?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Mon Oct 01, 2018 12:30 pm    Post subject: Reply with quote

no, system disrupted not destroyed.
The particular error
Quote:
Could not find the root block device in .
suggests a kernel configuration problem (initramfs may not have run), I think it should have told us "in /dev/sda4" instead of "in" . At the prompt you can enter /dev/sda4 and see if the message changes.
Mount the gentoo partitions, run
Code:
lspci -k | wgetpaste -t
wgetpaste -t proc/cpuinfo
wgetpaste -t /mnt/gentoo/usr/src/linux/.config
post the url's. Will examine the .config.
The removal of sysvinit, openrc, and failure of systemd to install leaves a system that has no initialization capability which will mean a failure to start the system even after the kernel looks in the right place, can read the disk, and can read the file system.
Boot the install media, mount the gentoo partitions, and enter the chroot to regain control.

The test of the updated systemd-239-r1 ebuild passed! No need to use systemd-9999.
When in the chroot:
If sys-apps/systemd-9999 is in /etc/portage/package.mask and/or /etc/portage/package.accept_keywords, remove it/them. Check that sys-apps/openrc, sys-apps/sysvinit, and sys-fs/eudev are in /etc/portage/package.mask. Then run:
Code:
emerge --sync
emerge -1av --keep-going systemd #do not use wgetpaste
# if the emerge fails post the comments that appear after the package build list
# particularly interested in what is trying to draw in sysvinit
# then run the next line
ls /usr/portage/sys-apps/systemd/files/239-debug-extra.patch
# to verify the patch is in your system

# if systemd installs run
emerge -avuND world
If emerge world fails skip the package list but post or pastebin the comments.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum