Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Detecting FAN sensors on laptop MSI PS42, lm_sensors.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Jackalope
n00b
n00b


Joined: 24 Sep 2018
Posts: 8

PostPosted: Fri Sep 28, 2018 6:01 am    Post subject: Detecting FAN sensors on laptop MSI PS42, lm_sensors. Reply with quote

I have a problem with my new laptop msi ps42 i7 - fan start cool increasing only after throttling on 90+ degrees.
I think this behavior set by vendor, there is no BIOS settings about this.

I can't use fancontrol because sensors-detect can't find fan sensors.
Code:
 $ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +78.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +71.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +70.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +78.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +70.0°C  (high = +100.0°C, crit = +100.0°C)

acpitz-virtual-0
Adapter: Virtual device
temp1:        +82.0°C  (crit = +100.0°C)
temp2:        +27.8°C  (crit = +119.0°C)
temp3:        +29.8°C  (crit = +119.0°C)

acpitz-virtual-0
Adapter: Virtual device
temp1:        +82.0°C  (crit = +100.0°C)
temp2:        +27.8°C  (crit = +119.0°C)
temp3:        +29.8°C  (crit = +119.0°C)

iwlwifi-virtual-0
Adapter: Virtual device
temp1:        +33.0°C 

After throttling cooling is normal and in full load temperature become ~70 degrees and turbine works normal & noisy.

Maybe I am needed to turn on some kernel options? Or there is no fancontrol support for my fan yet?
Back to top
View user's profile Send private message
astor86
n00b
n00b


Joined: 19 Feb 2016
Posts: 54

PostPosted: Mon Oct 22, 2018 10:10 am    Post subject: Reply with quote

I write here since my issue could be similar to your. this is the output of my `sensors`
Code:
$ sensors
iwlwifi-virtual-0
Adapter: Virtual device
temp1:        +42.0°C 

acpitz-virtual-0
Adapter: Virtual device
temp1:        +73.0°C  (crit = +120.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +81.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +78.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +74.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +81.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +62.0°C  (high = +100.0°C, crit = +100.0°C)


My issue is that when I compile for a long time (e.g., updating gentoo) my system reboots even though I do not reach 100 degrees. Is there a way such that I can control fan speed, or do something else to reduce the temperature before rebooting? Am I missing something?

Many thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum