Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
not going to the world.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
miisha
n00b
n00b


Joined: 02 May 2018
Posts: 11

PostPosted: Sun Oct 07, 2018 5:59 pm    Post subject: not going to the world. Reply with quote

Hi. Help please.
cat /etc/portage/make.conf
Code:
CFLAGS="-O2 -pipe -march=sandybridge -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
ABI_X86="64 32"
ABI="amd64"
CPU_FLAGS_X86="mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
# NOTE: This stage was built with the bindist Use flag enabled
USE="-bindist openrc -gtk -gtk2 -gnome -qt4 -qt5 -qt -kde -systemd -selinux gdbm tokenizer curl cli ssi ncurses readline reflection spl iconv flv addition ssl perl pcre zlib sub webdav imap status random-index http2 ssl http-cache cups gzip javascript fpm php python ruby rust mysql sqlite mysqli pdo alsa ipv4 ipv6 ssl tls usb build bash-completion static-libs tcpd anacron"

PORTDIR="/usr/portage"
DISTDIR="/usr/portage/distfiles"
PKGDIR="/usr/portage/packages"

L10N="ru"
LINGUAS="ru en"
# FEATURES="ccache parallel-fetch metadata-transfer"
# CCACHE_SIZE="5G"
# DISTCC_DIR="/tmp/.distcc"
# DISTCCD_OPTS="-allow 192.168.1.0/24"

# This sets the language of build output to English.
# Please keep this setting intact when reporting bugs.
LC_MESSAGES=C
MAKEOPTS="-j3"

#PORTAGE_BINHOST="http://packages.gentooexperimental.org/packages/amd64-stable/"
PORTAGE_BINHOST="http://tinderbox.dev.gentoo.org/default/linux/amd64/"

EMERGE_DEFAULT_OPTS="--jobs 1 --keep-going"


code tags added by Neddyseagoon.

emerge --verbose --update --deep --newuse @world
    * ERROR: sys-apps/man-db-2.7.6.1-r2::gentoo failed (compile phase):
    * emake failed
    *
    * If you need support, post the output of `emerge --info '=sys-apps/man-db-2.7.6.1-r2::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-apps/man-db-2.7.6.1-r2::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/work/man-db-2.7.6.1'
    * S: '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/work/man-db-2.7.6.1'

    >>> Failed to emerge sys-apps/man-db-2.7.6.1-r2, Log file:

    >>> '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/temp/build.log'
    *** Resuming merge...

    These are the packages that would be merged, in order:

    Calculating dependencies... done!
    [ebuild R ] net-firewall/iptables-1.6.1-r3:0/12::gentoo USE="ipv6 static-libs* -conntrack -netlink -nftables -pcap" 0 KiB

    Total: 1 package (1 reinstall), Size of downloads: 0 KiB

    >>> Emerging (1 of 1) net-firewall/iptables-1.6.1-r3::gentoo
    * Fetching files in the background.
    * To view fetch progress, run in another terminal:
    * tail -f /var/log/emerge-fetch.log
    * iptables-1.6.1.tar.bz2 BLAKE2B SHA512 size ;-) ... [ ok ]
    >>> Unpacking source...
    >>> Unpacking iptables-1.6.1.tar.bz2 to /var/tmp/portage/net-firewall/iptables-1.6.1-r3/work
    tar: This does not look like a tar archive
    tar: Exiting with failure status due to previous errors
    * ERROR: net-firewall/iptables-1.6.1-r3::gentoo failed (unpack phase):
    * unpack: failure unpacking iptables-1.6.1.tar.bz2
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_unpack
    * environment, line 2613: Called default
    * phase-functions.sh, line 868: Called default_src_unpack
    * phase-functions.sh, line 895: Called __eapi0_src_unpack
    * phase-helpers.sh, line 792: Called unpack 'iptables-1.6.1.tar.bz2'
    * phase-helpers.sh, line 442: Called __unpack_tar 'bzip2 -d'
    * phase-helpers.sh, line 364: Called __assert_sigpipe_ok 'unpack: failure unpacking iptables-1.6.1.tar.bz2'
    * isolated-functions.sh, line 45: Called __helpers_die 'unpack: failure unpacking iptables-1.6.1.tar.bz2'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=net-firewall/iptables-1.6.1-r3::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=net-firewall/iptables-1.6.1-r3::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/net-firewall/iptables-1.6.1-r3/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/net-firewall/iptables-1.6.1-r3/temp/environment'.
    * Working directory: '/var/tmp/portage/net-firewall/iptables-1.6.1-r3/work'
    * S: '/var/tmp/portage/net-firewall/iptables-1.6.1-r3/work/iptables-1.6.1'

    >>> Failed to emerge net-firewall/iptables-1.6.1-r3, Log file:

    >>> '/var/tmp/portage/net-firewall/iptables-1.6.1-r3/temp/build.log'

    * Messages for package sys-libs/ncurses-6.1-r2:

    * ERROR: sys-libs/ncurses-6.1-r2::gentoo failed (install phase):
    * emake failed
    *
    * If you need support, post the output of `emerge --info '=sys-libs/ncurses-6.1-r2::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-6.1-r2::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-libs/ncurses-6.1-r2/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-6.1-r2/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-libs/ncurses-6.1-r2/work/ncurses-6.1-abi_x86_64.amd64'
    * S: '/var/tmp/portage/sys-libs/ncurses-6.1-r2/work/ncurses-6.1'

    * Messages for package sys-libs/readline-7.0_p3:

    * emerge --keep-going: sys-libs/readline-7.0_p3 dropped because it requires
    * >=sys-libs/ncurses-5.9-r3:0=[static-libs,abi_x86_32(-),abi_x86_64(-)],
    * >=sys-libs/ncurses-5.9-r3:0=[static-libs,abi_x86_32(-),abi_x86_64(-)]

    * Messages for package sys-libs/gdbm-1.13-r2:

    * emerge --keep-going: sys-libs/gdbm-1.13-r2 dropped because it requires sys-
    * libs/readline:0=[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package dev-db/sqlite-3.24.0:

    * emerge --keep-going: dev-db/sqlite-3.24.0 dropped because it requires sys-
    * libs/readline:0=[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package dev-lang/python-3.6.5:

    * emerge --keep-going: dev-lang/python-3.6.5 dropped because it requires
    * >=dev-db/sqlite-3.3.8:3=

    * Messages for package dev-lang/python-2.7.15:

    * emerge --keep-going: dev-lang/python-2.7.15 dropped because it requires
    * >=dev-db/sqlite-3.3.8:3=

    * Messages for package sys-apps/baselayout-2.4.1-r2:

    * ERROR: sys-apps/baselayout-2.4.1-r2::gentoo failed (unpack phase):
    * unpack: failure unpacking baselayout-2.4.1.tar.bz2
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_unpack
    * environment, line 2282: Called default
    * phase-functions.sh, line 868: Called default_src_unpack
    * phase-functions.sh, line 895: Called __eapi0_src_unpack
    * phase-helpers.sh, line 792: Called unpack 'baselayout-2.4.1.tar.bz2'
    * phase-helpers.sh, line 442: Called __unpack_tar 'bzip2 -d'
    * phase-helpers.sh, line 364: Called __assert_sigpipe_ok 'unpack: failure unpacking baselayout-2.4.1.tar.bz2'
    * isolated-functions.sh, line 45: Called __helpers_die 'unpack: failure unpacking baselayout-2.4.1.tar.bz2'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=sys-apps/baselayout-2.4.1-r2::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-apps/baselayout-2.4.1-r2::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-apps/baselayout-2.4.1-r2/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-apps/baselayout-2.4.1-r2/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-apps/baselayout-2.4.1-r2/work'
    * S: '/var/tmp/portage/sys-apps/baselayout-2.4.1-r2/work/baselayout-2.4.1'

    * Messages for package net-libs/libmnl-1.0.4:

    * ERROR: net-libs/libmnl-1.0.4::gentoo failed (unpack phase):
    * unpack: failure unpacking libmnl-1.0.4.tar.bz2
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_unpack
    * environment, line 1920: Called default
    * phase-functions.sh, line 868: Called default_src_unpack
    * phase-functions.sh, line 895: Called __eapi0_src_unpack
    * phase-helpers.sh, line 792: Called unpack 'libmnl-1.0.4.tar.bz2'
    * phase-helpers.sh, line 442: Called __unpack_tar 'bzip2 -d'
    * phase-helpers.sh, line 364: Called __assert_sigpipe_ok 'unpack: failure unpacking libmnl-1.0.4.tar.bz2'
    * isolated-functions.sh, line 45: Called __helpers_die 'unpack: failure unpacking libmnl-1.0.4.tar.bz2'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=net-libs/libmnl-1.0.4::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=net-libs/libmnl-1.0.4::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/net-libs/libmnl-1.0.4/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/net-libs/libmnl-1.0.4/temp/environment'.
    * Working directory: '/var/tmp/portage/net-libs/libmnl-1.0.4/work'
    * S: '/var/tmp/portage/net-libs/libmnl-1.0.4/work/libmnl-1.0.4'

    * Messages for package app-arch/xz-utils-5.2.3:

    * ERROR: app-arch/xz-utils-5.2.3::gentoo failed (install phase):
    * unable to read SONAME from liblzma.so
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_install
    * environment, line 2364: Called multilib-minimal_src_install
    * environment, line 1677: Called multilib_foreach_abi 'multilib-minimal_abi_src_install'
    * environment, line 1872: Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
    * environment, line 1564: Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
    * environment, line 1562: Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_install'
    * environment, line 323: Called multilib-minimal_abi_src_install
    * environment, line 1667: Called multilib_src_install
    * environment, line 2095: Called gen_usr_ldscript '-a' 'lzma'
    * environment, line 980: Called die
    * The specific snippet of code:
    * [[ -z ${tlib} ]] && die "unable to read SONAME from ${lib}";
    *
    * If you need support, post the output of `emerge --info '=app-arch/xz-utils-5.2.3::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=app-arch/xz-utils-5.2.3::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/app-arch/xz-utils-5.2.3/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/app-arch/xz-utils-5.2.3/temp/environment'.
    * Working directory: '/var/tmp/portage/app-arch/xz-utils-5.2.3/work/xz-5.2.3-abi_x86_64.amd64'
    * S: '/var/tmp/portage/app-arch/xz-utils-5.2.3/work/xz-5.2.3'

    * Messages for package sys-libs/zlib-1.2.11-r2:

    * ERROR: sys-libs/zlib-1.2.11-r2::gentoo failed (install phase):
    * unable to read SONAME from libz.so
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_install
    * environment, line 2757: Called multilib-minimal_src_install
    * environment, line 2039: Called multilib_foreach_abi 'multilib-minimal_abi_src_install'
    * environment, line 2234: Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
    * environment, line 1926: Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
    * environment, line 1924: Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_install'
    * environment, line 418: Called multilib-minimal_abi_src_install
    * environment, line 2029: Called multilib_src_install
    * environment, line 2485: Called gen_usr_ldscript '-a' 'z'
    * environment, line 1342: Called die
    * The specific snippet of code:
    * [[ -z ${tlib} ]] && die "unable to read SONAME from ${lib}";
    *
    * If you need support, post the output of `emerge --info '=sys-libs/zlib-1.2.11-r2::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-libs/zlib-1.2.11-r2::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-libs/zlib-1.2.11-r2/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-libs/zlib-1.2.11-r2/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-libs/zlib-1.2.11-r2/work/zlib-1.2.11-abi_x86_64.amd64'
    * S: '/var/tmp/portage/sys-libs/zlib-1.2.11-r2/work/zlib-1.2.11'

    * Messages for package dev-libs/openssl-1.0.2p:

    * emerge --keep-going: dev-libs/openssl-1.0.2p dropped because it requires
    * >=sys-libs/zlib-1.2.8-r1[static-libs(+),abi_x86_32(-),abi_x86_64(-)],
    * >=sys-libs/zlib-1.2.8-r1[static-libs(+),abi_x86_32(-),abi_x86_64(-)]

    * Messages for package net-misc/openssh-7.7_p1-r9:

    * emerge --keep-going: net-misc/openssh-7.7_p1-r9 dropped because it requires
    * >=dev-libs/openssl-1.0.1:0=[-bindist]

    * Messages for package sys-libs/cracklib-2.9.6-r1:

    * emerge --keep-going: sys-libs/cracklib-2.9.6-r1 dropped because it requires
    * >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-),abi_x86_64(-)], >=sys-
    * libs/zlib-1.2.8-r1[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package sys-libs/pam-1.3.0-r2:

    * emerge --keep-going: sys-libs/pam-1.3.0-r2 dropped because it requires
    * >=sys-libs/cracklib-2.9.1-r1[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package virtual/pam-0-r1:

    * emerge --keep-going: virtual/pam-0-r1 dropped because it requires >=sys-
    * libs/pam-1.1.6-r2[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package sys-apps/file-5.33-r4:

    * emerge --keep-going: sys-apps/file-5.33-r4 dropped because it requires
    * >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-),abi_x86_64(-)], >=sys-
    * libs/zlib-1.2.8-r1[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package dev-libs/libxml2-2.9.8:

    * emerge --keep-going: dev-libs/libxml2-2.9.8 dropped because it requires
    * >=sys-libs/zlib-1.2.8-r1:=[abi_x86_32(-),abi_x86_64(-)], >=sys-
    * libs/zlib-1.2.8-r1:=[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package dev-libs/libxslt-1.1.32:

    * emerge --keep-going: dev-libs/libxslt-1.1.32 dropped because it requires
    * >=dev-libs/libxml2-2.9.1-r5:2[abi_x86_32(-),abi_x86_64(-)], dev-libs/libxml
    * 2:2[python,python_targets_python2_7(-),-python_single_target_python2_7(-)]

    * Messages for package dev-libs/glib-2.52.3:

    * emerge --keep-going: dev-libs/glib-2.52.3 dropped because it requires
    * >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-),abi_x86_64(-)], >=sys-
    * libs/zlib-1.2.8-r1[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package dev-util/pkgconfig-0.29.2:

    * emerge --keep-going: dev-util/pkgconfig-0.29.2 dropped because it requires
    * >=dev-libs/glib-2.34.3[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package virtual/pkgconfig-0-r1:

    * emerge --keep-going: virtual/pkgconfig-0-r1 dropped because it requires
    * >=dev-util/pkgconfig-0.28-r1[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package net-libs/libtirpc-1.0.2-r1:

    * emerge --keep-going: net-libs/libtirpc-1.0.2-r1 dropped because it requires
    * =virtual/pkgconfig-0-r1[abi_x86_32(-),abi_x86_64(-)],
    * >=virtual/pkgconfig-0-r1[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package net-libs/libnsl-1.2.0:

    * emerge --keep-going: net-libs/libnsl-1.2.0 dropped because it requires net-
    * libs/libtirpc[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package dev-libs/mpfr-3.1.6:

    * ERROR: dev-libs/mpfr-3.1.6::gentoo failed (configure phase):
    * econf failed
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_configure
    * environment, line 2304: Called multilib-minimal_src_configure
    * environment, line 1619: Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
    * environment, line 1834: Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
    * environment, line 1549: Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
    * environment, line 1547: Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
    * environment, line 308: Called multilib-minimal_abi_src_configure
    * environment, line 1613: Called multilib_src_configure
    * environment, line 2046: Called econf '--docdir=$(datarootdir)/doc/mpfr-3.1.6' '--enable-static'
    * phase-helpers.sh, line 718: Called __helpers_die 'econf failed'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=dev-libs/mpfr-3.1.6::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=dev-libs/mpfr-3.1.6::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/dev-libs/mpfr-3.1.6/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/dev-libs/mpfr-3.1.6/temp/environment'.
    * Working directory: '/var/tmp/portage/dev-libs/mpfr-3.1.6/work/mpfr-3.1.6-abi_x86_64.amd64'
    * S: '/var/tmp/portage/dev-libs/mpfr-3.1.6/work/mpfr-3.1.6'

    * Messages for package dev-libs/mpc-1.0.3:

    * emerge --keep-going: dev-libs/mpc-1.0.3 dropped because it requires >=dev-
    * libs/mpfr-2.4.2[abi_x86_32(-),abi_x86_64(-),static-libs], >=dev-
    * libs/mpfr-2.4.2[abi_x86_32(-),abi_x86_64(-),static-libs]

    * Messages for package dev-libs/expat-2.2.5:

    * ERROR: dev-libs/expat-2.2.5::gentoo failed (unpack phase):
    * unpack: failure unpacking expat-2.2.5.tar.bz2
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_unpack
    * environment, line 2792: Called default
    * phase-functions.sh, line 868: Called default_src_unpack
    * phase-functions.sh, line 895: Called __eapi0_src_unpack
    * phase-helpers.sh, line 792: Called unpack 'expat-2.2.5.tar.bz2'
    * phase-helpers.sh, line 442: Called __unpack_tar 'bzip2 -d'
    * phase-helpers.sh, line 364: Called __assert_sigpipe_ok 'unpack: failure unpacking expat-2.2.5.tar.bz2'
    * isolated-functions.sh, line 45: Called __helpers_die 'unpack: failure unpacking expat-2.2.5.tar.bz2'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=dev-libs/expat-2.2.5::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=dev-libs/expat-2.2.5::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/dev-libs/expat-2.2.5/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/dev-libs/expat-2.2.5/temp/environment'.
    * Working directory: '/var/tmp/portage/dev-libs/expat-2.2.5/work'
    * S: '/var/tmp/portage/dev-libs/expat-2.2.5/work/expat-2.2.5'

    * Messages for package app-i18n/man-pages-ru-4.16.2383.2383.20180422:

    * ERROR: app-i18n/man-pages-ru-4.16.2383.2383.20180422::gentoo failed (unpack phase):
    * unpack: failure unpacking man-pages-ru_4.16-2383-2383-20180422.tar.bz2
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_unpack
    * environment, line 583: Called default
    * phase-functions.sh, line 868: Called default_src_unpack
    * phase-functions.sh, line 895: Called __eapi0_src_unpack
    * phase-helpers.sh, line 792: Called unpack 'man-pages-ru_4.16-2383-2383-20180422.tar.bz2'
    * phase-helpers.sh, line 442: Called __unpack_tar 'bzip2 -d'
    * phase-helpers.sh, line 364: Called __assert_sigpipe_ok 'unpack: failure unpacking man-pages-ru_4.16-2383-2383-20180422.tar.bz2'
    * isolated-functions.sh, line 45: Called __helpers_die 'unpack: failure unpacking man-pages-ru_4.16-2383-2383-20180422.tar.bz2'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=app-i18n/man-pages-ru-4.16.2383.2383.20180422::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=app-i18n/man-pages-ru-4.16.2383.2383.20180422::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/app-i18n/man-pages-ru-4.16.2383.2383.20180422/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/app-i18n/man-pages-ru-4.16.2383.2383.20180422/temp/environment'.
    * Working directory: '/var/tmp/portage/app-i18n/man-pages-ru-4.16.2383.2383.20180422/work'
    * S: '/var/tmp/portage/app-i18n/man-pages-ru-4.16.2383.2383.20180422/work/man-pages-ru_4.16-2383-2383-20180422'

    * Messages for package sys-apps/man-pages-4.16:

    * emerge --keep-going: sys-apps/man-pages-4.16 dropped because it requires
    * app-i18n/man-pages-ru

    * Messages for package dev-lang/ruby-2.3.7:

    * ERROR: dev-lang/ruby-2.3.7::gentoo failed (unpack phase):
    * unpack: failure unpacking ruby-patches-2.3.7.tar.bz2
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_unpack
    * environment, line 2804: Called default
    * phase-functions.sh, line 868: Called default_src_unpack
    * phase-functions.sh, line 895: Called __eapi0_src_unpack
    * phase-helpers.sh, line 792: Called unpack 'ruby-2.3.7.tar.xz' 'ruby-patches-2.3.7.tar.bz2'
    * phase-helpers.sh, line 442: Called __unpack_tar 'bzip2 -d'
    * phase-helpers.sh, line 364: Called __assert_sigpipe_ok 'unpack: failure unpacking ruby-patches-2.3.7.tar.bz2'
    * isolated-functions.sh, line 45: Called __helpers_die 'unpack: failure unpacking ruby-patches-2.3.7.tar.bz2'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=dev-lang/ruby-2.3.7::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=dev-lang/ruby-2.3.7::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/dev-lang/ruby-2.3.7/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/dev-lang/ruby-2.3.7/temp/environment'.
    * Working directory: '/var/tmp/portage/dev-lang/ruby-2.3.7/work'
    * S: '/var/tmp/portage/dev-lang/ruby-2.3.7/work/ruby-2.3.7'

    * Messages for package app-text/docbook-xsl-stylesheets-1.79.1-r2:

    * emerge --keep-going: app-text/docbook-xsl-stylesheets-1.79.1-r2 dropped
    * because it requires dev-lang/ruby:2.3, virtual/rubygems

    * Messages for package dev-ruby/rubygems-2.7.6-r1:

    * emerge --keep-going: dev-ruby/rubygems-2.7.6-r1 dropped because it requires
    * dev-lang/ruby:2.3, dev-lang/ruby:2.3

    * Messages for package virtual/rubygems-11:

    * emerge --keep-going: virtual/rubygems-11 dropped because it requires >=dev-
    * ruby/rubygems-2.5.1[ruby_targets_ruby23], dev-lang/ruby:2.3, dev-
    * lang/ruby:2.3

    * Messages for package dev-ruby/rake-10.5.0:

    * emerge --keep-going: dev-ruby/rake-10.5.0 dropped because it requires
    * virtual/rubygems[ruby_targets_ruby23], dev-lang/ruby:2.3, dev-lang/ruby:2.3

    * Messages for package dev-ruby/json-1.8.6-r1:

    * emerge --keep-going: dev-ruby/json-1.8.6-r1 dropped because it requires
    * dev-ruby/rake[ruby_targets_ruby23], virtual/rubygems[ruby_targets_ruby23],
    * dev-lang/ruby:2.3, dev-lang/ruby:2.3

    * Messages for package dev-ruby/rdoc-4.3.0:

    * emerge --keep-going: dev-ruby/rdoc-4.3.0 dropped because it requires >=dev-
    * ruby/json-1.4:0[ruby_targets_ruby23], dev-ruby/racc[ruby_targets_ruby23],
    * virtual/rubygems[ruby_targets_ruby23], dev-lang/ruby:2.3, dev-lang/ruby:2.3

    * Messages for package dev-ruby/racc-1.4.14:

    * emerge --keep-going: dev-ruby/racc-1.4.14 dropped because it requires dev-
    * ruby/rake[ruby_targets_ruby23], virtual/rubygems[ruby_targets_ruby23], dev-
    * lang/ruby:2.3, dev-lang/ruby:2.3

    * Messages for package dev-ruby/net-telnet-0.1.1-r1:

    * emerge --keep-going: dev-ruby/net-telnet-0.1.1-r1 dropped because it
    * requires virtual/rubygems[ruby_targets_ruby23], dev-lang/ruby:2.3, dev-
    * lang/ruby:2.3

    * Messages for package dev-ruby/minitest-5.10.3:

    * emerge --keep-going: dev-ruby/minitest-5.10.3 dropped because it requires
    * virtual/rubygems[ruby_targets_ruby23], dev-lang/ruby:2.3, dev-lang/ruby:2.3

    * Messages for package dev-ruby/test-unit-3.2.7:

    * emerge --keep-going: dev-ruby/test-unit-3.2.7 dropped because it requires
    * virtual/rubygems[ruby_targets_ruby23], dev-
    * ruby/power_assert[ruby_targets_ruby23], dev-lang/ruby:2.3, dev-
    * lang/ruby:2.3

    * Messages for package dev-ruby/power_assert-1.1.1:

    * emerge --keep-going: dev-ruby/power_assert-1.1.1 dropped because it
    * requires virtual/rubygems[ruby_targets_ruby23], dev-lang/ruby:2.3, dev-
    * lang/ruby:2.3

    * Messages for package dev-ruby/did_you_mean-1.0.2:

    * emerge --keep-going: dev-ruby/did_you_mean-1.0.2 dropped because it
    * requires virtual/rubygems[ruby_targets_ruby23], dev-lang/ruby:2.3, dev-
    * lang/ruby:2.3

    * Messages for package sys-apps/attr-2.4.47-r2:

    * ERROR: sys-apps/attr-2.4.47-r2::gentoo failed (install phase):
    * unable to read SONAME from libattr.so
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_install
    * environment, line 2360: Called multilib-minimal_src_install
    * environment, line 1678: Called multilib_foreach_abi 'multilib-minimal_abi_src_install'
    * environment, line 1873: Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
    * environment, line 1565: Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
    * environment, line 1563: Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_install'
    * environment, line 324: Called multilib-minimal_abi_src_install
    * environment, line 1668: Called multilib_src_install
    * environment, line 2098: Called gen_usr_ldscript '-a' 'attr'
    * environment, line 981: Called die
    * The specific snippet of code:
    * [[ -z ${tlib} ]] && die "unable to read SONAME from ${lib}";
    *
    * If you need support, post the output of `emerge --info '=sys-apps/attr-2.4.47-r2::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-apps/attr-2.4.47-r2::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-apps/attr-2.4.47-r2/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-apps/attr-2.4.47-r2/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-apps/attr-2.4.47-r2/work/attr-2.4.47-abi_x86_64.amd64'
    * S: '/var/tmp/portage/sys-apps/attr-2.4.47-r2/work/attr-2.4.47'

    * Messages for package sys-apps/acl-2.2.52-r1:

    * emerge --keep-going: sys-apps/acl-2.2.52-r1 dropped because it requires
    * >=sys-apps/attr-2.4.47-r1[abi_x86_32(-),abi_x86_64(-)], >=sys-
    * apps/attr-2.4.47-r1[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package virtual/acl-0-r2:

    * emerge --keep-going: virtual/acl-0-r2 dropped because it requires >=sys-
    * apps/acl-2.2.52-r1[static-libs,abi_x86_32(-),abi_x86_64(-)]

    * Messages for package sys-libs/libcap-2.25:

    * emerge --keep-going: sys-libs/libcap-2.25 dropped because it requires
    * >=sys-apps/attr-2.4.47-r1[abi_x86_32(-),abi_x86_64(-)], >=sys-
    * apps/attr-2.4.47-r1[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package net-misc/iputils-20171016_pre:

    * emerge --keep-going: net-misc/iputils-20171016_pre dropped because it
    * requires sys-libs/libcap

    * Messages for package sys-devel/flex-2.6.4-r1:

    * ERROR: sys-devel/flex-2.6.4-r1::gentoo failed (compile phase):
    * emake failed
    *
    * If you need support, post the output of `emerge --info '=sys-devel/flex-2.6.4-r1::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-devel/flex-2.6.4-r1::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-devel/flex-2.6.4-r1/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-devel/flex-2.6.4-r1/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-devel/flex-2.6.4-r1/work/flex-2.6.4-abi_x86_64.amd64'
    * S: '/var/tmp/portage/sys-devel/flex-2.6.4-r1/work/flex-2.6.4'

    * Messages for package dev-libs/libgpg-error-1.29:

    * ERROR: dev-libs/libgpg-error-1.29::gentoo failed (unpack phase):
    * unpack: failure unpacking libgpg-error-1.29.tar.bz2
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_unpack
    * environment, line 1509: Called default
    * phase-functions.sh, line 868: Called default_src_unpack
    * phase-functions.sh, line 895: Called __eapi0_src_unpack
    * phase-helpers.sh, line 792: Called unpack 'libgpg-error-1.29.tar.bz2'
    * phase-helpers.sh, line 442: Called __unpack_tar 'bzip2 -d'
    * phase-helpers.sh, line 364: Called __assert_sigpipe_ok 'unpack: failure unpacking libgpg-error-1.29.tar.bz2'
    * isolated-functions.sh, line 45: Called __helpers_die 'unpack: failure unpacking libgpg-error-1.29.tar.bz2'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=dev-libs/libgpg-error-1.29::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=dev-libs/libgpg-error-1.29::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/dev-libs/libgpg-error-1.29/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/dev-libs/libgpg-error-1.29/temp/environment'.
    * Working directory: '/var/tmp/portage/dev-libs/libgpg-error-1.29/work'
    * S: '/var/tmp/portage/dev-libs/libgpg-error-1.29/work/libgpg-error-1.29'

    * Messages for package dev-libs/libgcrypt-1.8.3:

    * emerge --keep-going: dev-libs/libgcrypt-1.8.3 dropped because it requires
    * >=dev-libs/libgpg-error-1.25[abi_x86_32(-),abi_x86_64(-)], >=dev-
    * libs/libgpg-error-1.25[abi_x86_32(-),abi_x86_64(-)]

    * Messages for package sys-devel/binutils-2.30-r4:

    * ERROR: sys-devel/binutils-2.30-r4::gentoo failed (compile phase):
    * emake failed
    *
    * If you need support, post the output of `emerge --info '=sys-devel/binutils-2.30-r4::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-devel/binutils-2.30-r4::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-devel/binutils-2.30-r4/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-devel/binutils-2.30-r4/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-devel/binutils-2.30-r4/work/build'
    * S: '/var/tmp/portage/sys-devel/binutils-2.30-r4/work/binutils-2.30'

    * Messages for package sys-apps/util-linux-2.32-r4:

    * ERROR: sys-apps/util-linux-2.32-r4::gentoo failed (install phase):
    * unable to read SONAME from libblkid.so
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_install
    * environment, line 4112: Called multilib-minimal_src_install
    * environment, line 2373: Called multilib_foreach_abi 'multilib-minimal_abi_src_install'
    * environment, line 2568: Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
    * environment, line 2260: Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
    * environment, line 2258: Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_install'
    * environment, line 462: Called multilib-minimal_abi_src_install
    * environment, line 2363: Called multilib_src_install
    * environment, line 2799: Called gen_usr_ldscript '-a' 'blkid' 'fdisk' 'mount' 'smartcols' 'uuid'
    * environment, line 1568: Called die
    * The specific snippet of code:
    * [[ -z ${tlib} ]] && die "unable to read SONAME from ${lib}";
    *
    * If you need support, post the output of `emerge --info '=sys-apps/util-linux-2.32-r4::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-apps/util-linux-2.32-r4::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-apps/util-linux-2.32-r4/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-apps/util-linux-2.32-r4/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-apps/util-linux-2.32-r4/work/util-linux-2.32-abi_x86_64.amd64'
    * S: '/var/tmp/portage/sys-apps/util-linux-2.32-r4/work/util-linux-2.32'

    * Messages for package sys-libs/e2fsprogs-libs-1.43.9:

    * ERROR: sys-libs/e2fsprogs-libs-1.43.9::gentoo failed (install phase):
    * unable to read SONAME from libcom_err.so
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_install
    * environment, line 2434: Called multilib-minimal_src_install
    * environment, line 1755: Called multilib_foreach_abi 'multilib-minimal_abi_src_install'
    * environment, line 1950: Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
    * environment, line 1642: Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
    * environment, line 1640: Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_install'
    * environment, line 336: Called multilib-minimal_abi_src_install
    * environment, line 1745: Called multilib_src_install
    * environment, line 2176: Called gen_usr_ldscript '-a' 'com_err' 'ss'
    * environment, line 1057: Called die
    * The specific snippet of code:
    * [[ -z ${tlib} ]] && die "unable to read SONAME from ${lib}";
    *
    * If you need support, post the output of `emerge --info '=sys-libs/e2fsprogs-libs-1.43.9::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-libs/e2fsprogs-libs-1.43.9::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-libs/e2fsprogs-libs-1.43.9/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-libs/e2fsprogs-libs-1.43.9/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-libs/e2fsprogs-libs-1.43.9/work/e2fsprogs-libs-1.43.9-abi_x86_64.amd64'
    * S: '/var/tmp/portage/sys-libs/e2fsprogs-libs-1.43.9/work/e2fsprogs-libs-1.43.9'

    * Messages for package sys-process/procps-3.3.15-r1:

    * ERROR: sys-process/procps-3.3.15-r1::gentoo failed (install phase):
    * unable to read SONAME from libprocps.so
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_install
    * environment, line 2274: Called gen_usr_ldscript '-a' 'procps'
    * environment, line 1239: Called die
    * The specific snippet of code:
    * [[ -z ${tlib} ]] && die "unable to read SONAME from ${lib}";
    *
    * If you need support, post the output of `emerge --info '=sys-process/procps-3.3.15-r1::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-process/procps-3.3.15-r1::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-process/procps-3.3.15-r1/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-process/procps-3.3.15-r1/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-process/procps-3.3.15-r1/work/procps-ng-3.3.15'
    * S: '/var/tmp/portage/sys-process/procps-3.3.15-r1/work/procps-ng-3.3.15'

    * Messages for package sys-fs/e2fsprogs-1.43.9:

    * ERROR: sys-fs/e2fsprogs-1.43.9::gentoo failed (install phase):
    * unable to read SONAME from libe2p.so
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_install
    * environment, line 2269: Called gen_usr_ldscript '-a' 'e2p' 'ext2fs'
    * environment, line 1225: Called die
    * The specific snippet of code:
    * [[ -z ${tlib} ]] && die "unable to read SONAME from ${lib}";
    *
    * If you need support, post the output of `emerge --info '=sys-fs/e2fsprogs-1.43.9::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-fs/e2fsprogs-1.43.9::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-fs/e2fsprogs-1.43.9/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-fs/e2fsprogs-1.43.9/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-fs/e2fsprogs-1.43.9/work/e2fsprogs-1.43.9'
    * S: '/var/tmp/portage/sys-fs/e2fsprogs-1.43.9/work/e2fsprogs-1.43.9'

    * Messages for package dev-libs/libpcre-8.41-r1:

    * ERROR: dev-libs/libpcre-8.41-r1::gentoo failed (unpack phase):
    * unpack: failure unpacking pcre-8.41.tar.bz2
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_unpack
    * environment, line 2666: Called default
    * phase-functions.sh, line 868: Called default_src_unpack
    * phase-functions.sh, line 895: Called __eapi0_src_unpack
    * phase-helpers.sh, line 792: Called unpack 'pcre-8.41.tar.bz2'
    * phase-helpers.sh, line 442: Called __unpack_tar 'bzip2 -d'
    * phase-helpers.sh, line 364: Called __assert_sigpipe_ok 'unpack: failure unpacking pcre-8.41.tar.bz2'
    * isolated-functions.sh, line 45: Called __helpers_die 'unpack: failure unpacking pcre-8.41.tar.bz2'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=dev-libs/libpcre-8.41-r1::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=dev-libs/libpcre-8.41-r1::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/dev-libs/libpcre-8.41-r1/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/dev-libs/libpcre-8.41-r1/temp/environment'.
    * Working directory: '/var/tmp/portage/dev-libs/libpcre-8.41-r1/work'
    * S: '/var/tmp/portage/dev-libs/libpcre-8.41-r1/work/pcre-8.41'

    * Messages for package sys-apps/portage-2.3.49:

    * ERROR: sys-apps/portage-2.3.49::gentoo failed (unpack phase):
    * unpack: failure unpacking portage-2.3.49.tar.bz2
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_unpack
    * environment, line 3669: Called default
    * phase-functions.sh, line 868: Called default_src_unpack
    * phase-functions.sh, line 895: Called __eapi0_src_unpack
    * phase-helpers.sh, line 792: Called unpack 'portage-2.3.49.tar.bz2'
    * phase-helpers.sh, line 442: Called __unpack_tar 'bzip2 -d'
    * phase-helpers.sh, line 364: Called __assert_sigpipe_ok 'unpack: failure unpacking portage-2.3.49.tar.bz2'
    * isolated-functions.sh, line 45: Called __helpers_die 'unpack: failure unpacking portage-2.3.49.tar.bz2'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=sys-apps/portage-2.3.49::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-apps/portage-2.3.49::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-apps/portage-2.3.49/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.3.49/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-apps/portage-2.3.49/work'
    * S: '/var/tmp/portage/sys-apps/portage-2.3.49/work/portage-2.3.49'

    * Messages for package sys-apps/man-db-2.7.6.1-r2:

    * Defaulting to USE=gdbm due to ambiguous berkdb/gdbm USE flag settings
    * ERROR: sys-apps/man-db-2.7.6.1-r2::gentoo failed (compile phase):
    * emake failed
    *
    * If you need support, post the output of `emerge --info '=sys-apps/man-db-2.7.6.1-r2::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-apps/man-db-2.7.6.1-r2::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/work/man-db-2.7.6.1'
    * S: '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/work/man-db-2.7.6.1'

    * Messages for package net-firewall/iptables-1.6.1-r3:

    * ERROR: net-firewall/iptables-1.6.1-r3::gentoo failed (unpack phase):
    * unpack: failure unpacking iptables-1.6.1.tar.bz2
    *
    * Call stack:
    * ebuild.sh, line 124: Called src_unpack
    * environment, line 2613: Called default
    * phase-functions.sh, line 868: Called default_src_unpack
    * phase-functions.sh, line 895: Called __eapi0_src_unpack
    * phase-helpers.sh, line 792: Called unpack 'iptables-1.6.1.tar.bz2'
    * phase-helpers.sh, line 442: Called __unpack_tar 'bzip2 -d'
    * phase-helpers.sh, line 364: Called __assert_sigpipe_ok 'unpack: failure unpacking iptables-1.6.1.tar.bz2'
    * isolated-functions.sh, line 45: Called __helpers_die 'unpack: failure unpacking iptables-1.6.1.tar.bz2'
    * isolated-functions.sh, line 121: Called die
    * The specific snippet of code:
    * die "$@"
    *
    * If you need support, post the output of `emerge --info '=net-firewall/iptables-1.6.1-r3::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=net-firewall/iptables-1.6.1-r3::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/net-firewall/iptables-1.6.1-r3/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/net-firewall/iptables-1.6.1-r3/temp/environment'.
    * Working directory: '/var/tmp/portage/net-firewall/iptables-1.6.1-r3/work'
    * S: '/var/tmp/portage/net-firewall/iptables-1.6.1-r3/work/iptables-1.6.1'
    *
    * The following 58 packages have failed to build, install, or execute
    * postinst:
    *
    * (sys-libs/ncurses-6.1-r2:0/6::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-libs/ncurses-6.1-r2/temp/build.log'
    * (sys-libs/readline-7.0_p3:0/7::gentoo, ebuild scheduled for merge)
    * (sys-libs/gdbm-1.13-r2:0/1.13::gentoo, ebuild scheduled for merge)
    * (dev-db/sqlite-3.24.0:3/3::gentoo, ebuild scheduled for merge)
    * (dev-lang/python-3.6.5:3.6/3.6m::gentoo, ebuild scheduled for merge)
    * (dev-lang/python-2.7.15:2.7/2.7::gentoo, ebuild scheduled for merge)
    * (sys-apps/baselayout-2.4.1-r2:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-apps/baselayout-2.4.1-r2/temp/build.log'
    * (net-libs/libmnl-1.0.4:0/0.2.0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/net-libs/libmnl-1.0.4/temp/build.log'
    * (app-arch/xz-utils-5.2.3:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/app-arch/xz-utils-5.2.3/temp/build.log'
    * (sys-libs/zlib-1.2.11-r2:0/1::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-libs/zlib-1.2.11-r2/temp/build.log'
    * (dev-libs/openssl-1.0.2p:0/0::gentoo, ebuild scheduled for merge)
    * (net-misc/openssh-7.7_p1-r9:0/0::gentoo, ebuild scheduled for merge)
    * (sys-libs/cracklib-2.9.6-r1:0/0::gentoo, ebuild scheduled for merge)
    * (sys-libs/pam-1.3.0-r2:0/0::gentoo, ebuild scheduled for merge)
    * (virtual/pam-0-r1:0/0::gentoo, ebuild scheduled for merge)
    * (sys-apps/file-5.33-r4:0/0::gentoo, ebuild scheduled for merge)
    * (dev-libs/libxml2-2.9.8:2/2::gentoo, ebuild scheduled for merge)
    * (dev-libs/libxslt-1.1.32:0/0::gentoo, ebuild scheduled for merge)
    * (dev-libs/glib-2.52.3:2/2::gentoo, ebuild scheduled for merge)
    * (dev-util/pkgconfig-0.29.2:0/0::gentoo, ebuild scheduled for merge)
    * (virtual/pkgconfig-0-r1:0/0::gentoo, ebuild scheduled for merge)
    * (net-libs/libtirpc-1.0.2-r1:0/3::gentoo, ebuild scheduled for merge)
    * (net-libs/libnsl-1.2.0:0/2::gentoo, ebuild scheduled for merge)
    * (dev-libs/mpfr-3.1.6:0/4::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/dev-libs/mpfr-3.1.6/temp/build.log'
    * (dev-libs/mpc-1.0.3:0/0::gentoo, ebuild scheduled for merge)
    * (dev-libs/expat-2.2.5:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/dev-libs/expat-2.2.5/temp/build.log'
    * (app-i18n/man-pages-ru-4.16.2383.2383.20180422:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/app-i18n/man-pages-ru-4.16.2383.2383.20180422/temp/build.log'
    * (sys-apps/man-pages-4.16:0/0::gentoo, ebuild scheduled for merge)
    * (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/dev-lang/ruby-2.3.7/temp/build.log'
    * (app-text/docbook-xsl-stylesheets-1.79.1-r2:0/0::gentoo, ebuild scheduled for merge)
    * (dev-ruby/rubygems-2.7.6-r1:0/0::gentoo, ebuild scheduled for merge)
    * (virtual/rubygems-11:0/0::gentoo, ebuild scheduled for merge)
    * (dev-ruby/rake-10.5.0:0/0::gentoo, ebuild scheduled for merge)
    * (dev-ruby/json-1.8.6-r1:0/0::gentoo, ebuild scheduled for merge)
    * (dev-ruby/rdoc-4.3.0:0/0::gentoo, ebuild scheduled for merge)
    * (dev-ruby/racc-1.4.14:0/0::gentoo, ebuild scheduled for merge)
    * (dev-ruby/net-telnet-0.1.1-r1:1/1::gentoo, ebuild scheduled for merge)
    * (dev-ruby/minitest-5.10.3:5/5::gentoo, ebuild scheduled for merge)
    * (dev-ruby/test-unit-3.2.7:2/2::gentoo, ebuild scheduled for merge)
    * (dev-ruby/power_assert-1.1.1:0/0::gentoo, ebuild scheduled for merge)
    * (dev-ruby/did_you_mean-1.0.2:1/1::gentoo, ebuild scheduled for merge)
    * (sys-apps/attr-2.4.47-r2:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-apps/attr-2.4.47-r2/temp/build.log'
    * (sys-apps/acl-2.2.52-r1:0/0::gentoo, ebuild scheduled for merge)
    * (virtual/acl-0-r2:0/0::gentoo, ebuild scheduled for merge)
    * (sys-libs/libcap-2.25:0/0::gentoo, ebuild scheduled for merge)
    * (net-misc/iputils-20171016_pre:0/0::gentoo, ebuild scheduled for merge)
    * (sys-devel/flex-2.6.4-r1:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-devel/flex-2.6.4-r1/temp/build.log'
    * (dev-libs/libgpg-error-1.29:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/dev-libs/libgpg-error-1.29/temp/build.log'
    * (dev-libs/libgcrypt-1.8.3:0/20::gentoo, ebuild scheduled for merge)
    * (sys-devel/binutils-2.30-r4:2.30/2.30::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-devel/binutils-2.30-r4/temp/build.log'
    * (sys-apps/util-linux-2.32-r4:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-apps/util-linux-2.32-r4/temp/build.log'
    * (sys-libs/e2fsprogs-libs-1.43.9:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-libs/e2fsprogs-libs-1.43.9/temp/build.log'
    * (sys-process/procps-3.3.15-r1:0/6::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-process/procps-3.3.15-r1/temp/build.log'
    * (sys-fs/e2fsprogs-1.43.9:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-fs/e2fsprogs-1.43.9/temp/build.log'
    * (dev-libs/libpcre-8.41-r1:3/3::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/dev-libs/libpcre-8.41-r1/temp/build.log'
    * (sys-apps/portage-2.3.49:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-apps/portage-2.3.49/temp/build.log'
    * (sys-apps/man-db-2.7.6.1-r2:0/0::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/temp/build.log'
    * (net-firewall/iptables-1.6.1-r3:0/12::gentoo, ebuild scheduled for merge), Log file:
    * '/var/tmp/portage/net-firewall/iptables-1.6.1-r3/temp/build.log'
    *
Back to top
View user's profile Send private message
duane
n00b
n00b


Joined: 03 Jun 2002
Posts: 56
Location: Oklahoma City

PostPosted: Sun Oct 07, 2018 10:31 pm    Post subject: Reply with quote

It looks like there's a problem with tar/bzip2 or all your packages are broken. Have you tried doing this?

emerge -1av app-arch/tar app-arch/bzip2

or maybe this?

emerge -avuDN @system
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Mon Oct 08, 2018 1:04 am    Post subject: Reply with quote

Commenting on your make.conf first:
Why do you have CHOST, ABI, etc?
Have you verified CPU_FLAGS?
Are you a gentoo developer with access to tinderbox.dev.gentoo.org for PORTAGE_BINHOST?

Have you successfully completed an emerge --sync?

Remove the --keep-going and try emerge just one package.. any one?
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43192
Location: 56N 3W

PostPosted: Mon Oct 08, 2018 9:55 am    Post subject: Reply with quote

miisha,

What are you trying to do?

Your make.conf is very unusual.
Do not use
Code:
PORTAGE_BINHOST="http://tinderbox.dev.gentoo.org/default/linux/amd64/"
current portage will ignore it anyway as its content is three years old and the ebuilds to use such out of date packages will mostly be gone.

Your
Code:
emerge --verbose --update --deep --newuse @world

    * ERROR: sys-apps/man-db-2.7.6.1-r2::gentoo failed (compile phase):
    * emake failed
    *
    * If you need support, post the output of `emerge --info '=sys-apps/man-db-2.7.6.1-r2::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=sys-apps/man-db-2.7.6.1-r2::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/temp/environment'.
    * Working directory: '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/work/man-db-2.7.6.1'
    * S: '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/work/man-db-2.7.6.1'

    >>> Failed to emerge sys-apps/man-db-2.7.6.1-r2, Log file:

>>>  '/var/tmp/portage/sys-apps/man-db-2.7.6.1-r2/temp/build.log'
*** Resuming merge...
and subequent entries, just tell us that 'it broke' without telling why.
The part I quoted does tell what we need to be able to help.

Use wgetpaste to put those files onto a pastebin site and post the links.
They are far too big for a post.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
miisha
n00b
n00b


Joined: 02 May 2018
Posts: 11

PostPosted: Mon Oct 08, 2018 3:10 pm    Post subject: I changed the config. Reply with quote

Code:
CFLAGS="-O2 -pipe -march=sandybridge -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"

emerge bzip2
Code:

 * Messages for package app-arch/bzip2-1.0.6-r10:

 * FAILED postinst: 1
 * ERROR: app-arch/bzip2-1.0.6-r10::gentoo failed (postinst phase):
 *   filter-bash-environment.py failed
 *
 * Call stack:
 *            ebuild.sh, line  792:  Called __ebuild_main 'postinst'
 *   phase-functions.sh, line 1009:  Called __filter_readonly_variables '--filter-path' '--filter-sandbox' '--
 *   phase-functions.sh, line  149:  Called die
 * The specific snippet of code:
 *      "${PORTAGE_PYTHON:-/usr/bin/python}" "${PORTAGE_BIN_PATH}"/filter-bash-environment.py "${filtered_vars
bash-environment.py failed"
 *
 * If you need support, post the output of `emerge --info '=app-arch/bzip2-1.0.6-r10::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-arch/bzip2-1.0.6-r10::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-arch/bzip2-1.0.6-r10/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-arch/bzip2-1.0.6-r10/temp/environment'.
 * Working directory: '/usr/lib64/python3.6/site-packages'
 * S: '/var/tmp/portage/app-arch/bzip2-1.0.6-r10/work/bzip2-1.0.6'
 * ERROR: app-arch/bzip2-1.0.6-r10::gentoo failed:
 *   toolchain-funcs.eclass could not be found by inherit()
 *
 * Call stack:
 *        misc-functions.sh, line  17:  Called source '/usr/lib/portage/python3.6/ebuild.sh'
 *                ebuild.sh, line 635:  Called source '/var/db/pkg/app-arch/bzip2-1.0.6-r10/bzip2-1.0.6-r10.eb
 *   bzip2-1.0.6-r10.ebuild, line   9:  Called inherit 'toolchain-funcs' 'multilib-minimal'
 *                ebuild.sh, line 300:  Called die
 * The specific snippet of code:
 *              [[ -z ${location} ]] && die "${1}.eclass could not be found by inherit()"
 *
 * If you need support, post the output of `emerge --info '=app-arch/bzip2-1.0.6-r10::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-arch/bzip2-1.0.6-r10::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/._unmerge_/app-arch/bzip2-1.0.6-r10/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/._unmerge_/app-arch/bzip2-1.0.6-r10/temp/die.en
 * Working directory: '/var/tmp/portage/._unmerge_/app-arch/bzip2-1.0.6-r10/homedir'
 * S: '/var/tmp/portage/._unmerge_/app-arch/bzip2-1.0.6-r10/work/bzip2-1.0.6'
 *
 * The following package has failed to build, install, or execute postinst:
 *
 *  (app-arch/bzip2-1.0.6-r10:0/1::gentoo, ebuild scheduled for merge) (postinst failed)
 *


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Mon Oct 08, 2018 3:24 pm    Post subject: Re: I changed the config. Reply with quote

Code:
 * If you need support, post the output of `emerge --info '=app-arch/bzip2-1.0.6-r10::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-arch/bzip2-1.0.6-r10::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-arch/bzip2-1.0.6-r10/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-arch/bzip2-1.0.6-r10/temp/environment'.
 * Working directory: '/usr/lib64/python3.6/site-packages'
 * S: '/var/tmp/portage/app-arch/bzip2-1.0.6-r10/work/bzip2-1.0.6'

If you have trouble with English language, did you know there is a Russian forum?
https://forums.gentoo.org/index.php?c=11
_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
miisha
n00b
n00b


Joined: 02 May 2018
Posts: 11

PostPosted: Mon Oct 08, 2018 3:37 pm    Post subject: Reply with quote

That's alright.
I hope you too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum