Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] libcurl.so.4: no version information available
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
MALDATA
n00b
n00b


Joined: 07 Apr 2011
Posts: 41

PostPosted: Fri Nov 02, 2018 5:10 pm    Post subject: [SOLVED] libcurl.so.4: no version information available Reply with quote

Hi all,

I'm trying to get the VPN Unlimited application installed on my machine, but running the application results in the following errors:

Code:

# /usr/bin/vpn-unlimited-daemon
/usr/bin/vpn-unlimited-daemon: /usr/lib64/libcurl.so.4: no version information available (required by /usr/lib64/libvpnu_private_sdk.so.1)
/usr/bin/vpn-unlimited-daemon: symbol lookup error: /usr/lib64/libvpnu_private_sdk.so.1: undefined symbol: EVP_MD_CTX_new


Googling this error turns up a lot of results, and the cause is always that there are multiple curl installations on the machine. This PC only has one, installed normally through portage.

For background, I installed this application recently on a machine running Arch, for which there is an existing user-supplied package. It worked fine on that machine, so now I'm basically trying to follow along with that package build script to get it installed on Gentoo. Looking into the Arch package more in-depth, it is dependent on a curl installation that is built without versioned symbols. This appears to be done by configuring the curl build using the --disable-versioned-symbols flag. On the Gentoo machine, curl-config --configure does report that my curl was configured with this option, so it seems like it should be fine.

Also, if I peek into the libvpnu_private_sdk.so.1 library for which this is required, I can see that it needs libcurl.so.4:

Code:

# readelf -d /usr/lib/libvpnu_private_sdk.so.1 | head

Dynamic section at offset 0x1c8240 contains 34 entries:
  Tag        Type                         Name/Value
 0x0000000000000001 (NEEDED)             Shared library: [libcares.so.2]
 0x0000000000000001 (NEEDED)             Shared library: [libcurl.so.4]
...


And that library exists:

Code:

# ls -l /usr/lib/libcurl*
-rw-r--r-- 1 root root 1004322 Oct 31 20:42 /usr/lib/libcurl.a
lrwxrwxrwx 1 root root      16 Oct 31 20:42 /usr/lib/libcurl.so -> libcurl.so.4.5.0
lrwxrwxrwx 1 root root      16 Oct 31 20:42 /usr/lib/libcurl.so.4 -> libcurl.so.4.5.0
-rwxr-xr-x 1 root root  488224 Oct 31 20:42 /usr/lib/libcurl.so.4.5.0


I also noticed that the Arch package creates a bunch of additional symlinks by doing
Code:

  for version in 3 4.0.0 4.1.0 4.2.0 4.3.0 4.4.0; do
    ln -s libcurl-compat.so.4.5.0 "${pkgdir}"/usr/lib/libcurl.so.${version}
  done


I created these links on my system as well, making it
Code:

# ls -l /usr/lib/libcurl*
-rw-r--r-- 1 root root 1004322 Oct 31 20:42 /usr/lib/libcurl.a
lrwxrwxrwx 1 root root      16 Oct 31 20:42 /usr/lib/libcurl.so -> libcurl.so.4.5.0
lrwxrwxrwx 1 root root      16 Nov  2 12:05 /usr/lib/libcurl.so.3 -> libcurl.so.4.5.0
lrwxrwxrwx 1 root root      16 Oct 31 20:42 /usr/lib/libcurl.so.4 -> libcurl.so.4.5.0
lrwxrwxrwx 1 root root      16 Nov  2 12:05 /usr/lib/libcurl.so.4.0.0 -> libcurl.so.4.5.0
lrwxrwxrwx 1 root root      16 Nov  2 12:05 /usr/lib/libcurl.so.4.1.0 -> libcurl.so.4.5.0
lrwxrwxrwx 1 root root      16 Nov  2 12:05 /usr/lib/libcurl.so.4.2.0 -> libcurl.so.4.5.0
lrwxrwxrwx 1 root root      16 Nov  2 12:05 /usr/lib/libcurl.so.4.3.0 -> libcurl.so.4.5.0
lrwxrwxrwx 1 root root      16 Nov  2 12:05 /usr/lib/libcurl.so.4.4.0 -> libcurl.so.4.5.0
-rwxr-xr-x 1 root root  488224 Oct 31 20:42 /usr/lib/libcurl.so.4.5.0


But I get the same error, so I removed those links.

Does anyone have any insight on what's going wrong here?


Last edited by MALDATA on Sat Nov 03, 2018 5:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4217
Location: Dallas area

PostPosted: Fri Nov 02, 2018 5:20 pm    Post subject: Reply with quote

related to the openssl version, I think it needs 1.10 or greater for that
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22219
Location: here

PostPosted: Fri Nov 02, 2018 6:14 pm    Post subject: Reply with quote

You have enabled curl_ssl_openssl use flag to curl? post emerge -pvq curl
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
MALDATA
n00b
n00b


Joined: 07 Apr 2011
Posts: 41

PostPosted: Fri Nov 02, 2018 6:50 pm    Post subject: Reply with quote

Quote:
You have enabled curl_ssl_openssl use flag to curl? post emerge -pvq curl


Yes, curl_ssl_openssl is enabled:

Code:

$ emerge -pvq curl
[ebuild   R   ] net-misc/curl-7.62.0  USE="ipv6 ldap ssl static-libs threads -adns -brotli -http2 -idn -kerberos -metalink -rtmp -samba -ssh -test" ABI_X86="(64) -32 (-x32)" CURL_SSL="openssl -axtls -gnutls -libressl -mbedtls -nss (-winssl)"


Quote:
related to the openssl version, I think it needs 1.10 or greater for that


I currently have 1.0.2p installed. If you don't mind, could you tell me a little more? How can you identify if an application needs 1.10 or greater?
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4217
Location: Dallas area

PostPosted: Fri Nov 02, 2018 6:58 pm    Post subject: Reply with quote

Quote:
undefined symbol: EVP_MD_CTX_new


http://manpages.ubuntu.com/manpages/bionic/man3/EVP_DigestInit.3ssl.html


But ... using openssl versions 1.1 and greater can cause problems with other apps.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22219
Location: here

PostPosted: Fri Nov 02, 2018 7:26 pm    Post subject: Reply with quote

Anon-E-moose is right, try to download version 4.22 if work with openssl-1.0
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
MALDATA
n00b
n00b


Joined: 07 Apr 2011
Posts: 41

PostPosted: Fri Nov 02, 2018 8:22 pm    Post subject: Reply with quote

Quote:
Anon-E-moose is right, try to download version 4.22 if work with openssl-1.0


Good call. I'll see if I can make that work. If I can't, I'll post here again, if I can I'll mark this as solved. Until then, thank you both for the help, I appreciate it!
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14075

PostPosted: Sat Nov 03, 2018 12:53 am    Post subject: Reply with quote

If you get it to work, please post the ebuild you use to install it. Such an ebuild may be useful to others, and would hopefully discourage people from copying the files into place by hand.
Back to top
View user's profile Send private message
MALDATA
n00b
n00b


Joined: 07 Apr 2011
Posts: 41

PostPosted: Sat Nov 03, 2018 5:01 pm    Post subject: Reply with quote

Quote:
If you get it to work, please post the ebuild you use to install it. Such an ebuild may be useful to others, and would hopefully discourage people from copying the files into place by hand.


Yes, I will definitely do that. This got me to the point where I can get the application to run, but there must be some other problem, because I can't get the VPN to connect. I'll open another thread to try to debug that, but for now, I'm marking this as solved.

As an aside, you don't need to use version 4.22. The download page for the application has separate downloads for Debian and Ubuntu, so 4.23 for Debian works. The Ubuntu ones seem to be linked against openssl 1.1.

Thanks for the help, everyone!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum