Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201811-02 ] Python
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Fri Nov 09, 2018 2:26 am    Post subject: [ GLSA 201811-02 ] Python Reply with quote

Gentoo Linux Security Advisory

Title: Python: Buffer overflow (GLSA 201811-02)
Severity: normal
Exploitable: remote
Date: 2018-11-09
Bug(s): #647862
ID: 201811-02

Synopsis

A buffer overflow in Python might allow remote attackers to cause a
Denial of Service condition.


Background

Python is an interpreted, interactive, object-oriented programming
language.


Affected Packages

Package: dev-lang/python
Vulnerable: < 2.7.15
Unaffected: >= 2.7.15
Architectures: All supported architectures


Description

A buffer overflow vulnerability have been discovered in Python. Please
review the CVE identifiers referenced below for details.


Impact

A remote attacker, in special situations such as function as a service,
could violate a trust boundary and cause a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All Python users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/python-2.7.15:2.7"
   


References


CVE-2018-1000030


Last edited by GLSA on Thu Mar 21, 2019 4:16 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum