Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg.conf on nvidia G72
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 22 Jun 2009
Posts: 89
Location: Denmark

PostPosted: Thu Nov 15, 2018 6:17 am    Post subject: xorg.conf on nvidia G72 Reply with quote

Question xorg / nvidia driver configuration.

I tried nouveau driver, but it is slow so I am using the propritary driver that is available for G72 (that would be 304.137I. It works fine (except vaapi tools is badly supported above 2 by the driver of nvidias and badly supported for below 2 for Gentoo). This is not the problem as vaapi can be disabled, but I have problems getting any VESA modes working (talking about the resolutions). I can scale to lower resolutions with xrandr --output LVDS-0 --scale-from "width x height", but I would like to have access to other resolutions for fullscreen.
While I got the platform working I got problems getting any and all VESA modes running on my desktop except the native max resolution of the laptop. My xorg only seems to support max resolution on my desktops.

SuSE's tool hwinfo guves the following with the command "hwinfo --framebuffer" when run as root:

02: None 00.0: 11001 VESA Framebuffer
  [Created at bios.459]
  Unique ID: rdCR.rvmobcPWZy1
  Hardware Class: framebuffer
  Model: "NVIDIA G72 Board - e464h0"
  Vendor: "NVIDIA Corporation"
  Device: "G72 Board - e464h0"
  SubVendor: "NVIDIA"
  Revision: "Chip Rev"
  Memory Size: 128 MB
  Memory Range: 0xc0000000-0xc7ffffff (rw)
  Mode 0x0300: 640x400 (+640), 8 bits
  Mode 0x0301: 640x480 (+640), 8 bits
  Mode 0x0303: 800x600 (+800), 8 bits
  Mode 0x0305: 1024x768 (+1024), 8 bits
  Mode 0x0307: 1280x1024 (+1280), 8 bits
  Mode 0x030e: 320x200 (+640), 16 bits
  Mode 0x030f: 320x200 (+1280), 24 bits
  Mode 0x0311: 640x480 (+1280), 16 bits
  Mode 0x0312: 640x480 (+2560), 24 bits
  Mode 0x0314: 800x600 (+1600), 16 bits
  Mode 0x0315: 800x600 (+3200), 24 bits
  Mode 0x0317: 1024x768 (+2048), 16 bits
  Mode 0x0318: 1024x768 (+4096), 24 bits
  Mode 0x031a: 1280x1024 (+2560), 16 bits
  Mode 0x031b: 1280x1024 (+5120), 24 bits
  Mode 0x0330: 320x200 (+320), 8 bits
  Mode 0x0331: 320x400 (+320), 8 bits
  Mode 0x0332: 320x400 (+640), 16 bits
  Mode 0x0333: 320x400 (+1280), 24 bits
  Mode 0x0334: 320x240 (+320), 8 bits
  Mode 0x0335: 320x240 (+640), 16 bits
  Mode 0x0336: 320x240 (+1280), 24 bits
  Mode 0x033d: 640x400 (+1280), 16 bits
  Mode 0x033e: 640x400 (+2560), 24 bits
  Mode 0x0347: 1400x1050 (+1400), 8 bits
  Mode 0x0348: 1400x1050 (+2800), 16 bits
  Config Status: cfg=new, avail=yes, need=no, active=unknown

My current xorg device driver config: This isn't the full config, just the nvidia part:
Section "Device"
    Identifier "Nvidia"
    Driver "nvidia"
    Option "NoLogo" "yes"
    Option "RenderAccel" "on"
##    Option "UseEDIDFreqs" "TRUE"
##    Option "UseEDIDDpi" "TRUE"
##    Option "ModeValidation" "AllowNonEdidModes"
##    Option "ModeValidation" "NoEdidModes"
##    Option "AllowNonEdidModes" "true"
##    Option "ModeValidation" "NoVesaModes, NoXServerModes"
    Option "UseDisplayDevice" "LVDS-0"
    Option "ModeDebug" "true"
    Option "Monitor-LVDS-0" "VX1 Display"
    Option "AcpidSocketPath" "/usr/sbin/acpid"
##    LoadModule "glx"
    Option "NvAGP" "3"
##    Option "ModeValidation" "AllowNonEdidModes, NoMaxPClkCheck"

I think solution might be in these options, but while I have found some documentation, I am missing a clear howto and solution. Anything to heæå resolve it would be good.
I also got this problem on a newer nvidia, but I think that hardware broke. It's an intel-nvidia solution. Had to reinstall an OS to make it work.The supposedly fail happened having run Windows 10 without problems for some time, but then started giving various severe problems. Installed Gentoo and think the nouveau driver worked to some degree, but was slower than on old laptop.

Last ModeValidation option gave me access to more modes, but they are defunc and just gives me plasma like effects (Maybe it was the 24bit.. I'll experiment a bit).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum