Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GPU always on DynPwr unless I manually load nouveau
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
paintchip
n00b
n00b


Joined: 02 Jan 2010
Posts: 16

PostPosted: Wed Nov 21, 2018 5:46 pm    Post subject: GPU always on DynPwr unless I manually load nouveau Reply with quote

So I have an interensting problem with nouveau and Prime. My graphics card will not turn off (Always on DynPwr) unless I log out of X (Plasma), rmmod nouveau, load nouveau again manually, and then start X again. Once I do this, Prime works as expected and I use DRI_Prime=1 to load the GPU when needed and it auto turns off after I close the application. This behavior starts again every time I suspend or restart the computer. I feel like I missed something simple (like a group or permission), but I can't seem to find any errors in the logs to point me in the right direction. Any help would be appreciated. I'm using a Nvidia GeForce 970M.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum