Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SOLVED | modules not loaded automatically after grand update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ayvango
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2012
Posts: 118

PostPosted: Thu Nov 22, 2018 1:00 am    Post subject: SOLVED | modules not loaded automatically after grand update Reply with quote

I doesn't like to update frequently. If something is working, let it keep working. This time I had updated profile entire world with the -e flag. The only thing that remained unchanged is the kernel. I prefer to update kernel and user-space separately to know definitely which one causes troubles.

After rebuilding entire world and rebooting I ran into many troubles with loadable kernel modules. All things that used to work automatically now requires explicit calls to modprobe. I need to load alsa modules to enable sound. I need to modprobe kvm_intel for qemu. acpi and sensors commands doesn't work without manual module loading. What could be the source of all that troubles?

I'm not very familiar with module loading process, but my lead suspect is eudev. I had masked new versions for years since it broke my network devices without any reason. And I was forced to remove that mask to resolve dependencies. How could I check my guess? What could be done to recover old LKM autoload behavior?
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1718
Location: Frankfurt, Germany

PostPosted: Thu Nov 22, 2018 1:31 am    Post subject: Reply with quote

1) Do you use OpenRC? Or Systemd?

2) Did you specify the modules you want to be loaded in the proper configuration file? Please look at: https://wiki.gentoo.org/wiki/Kernel_Modules
Back to top
View user's profile Send private message
ayvango
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2012
Posts: 118

PostPosted: Thu Nov 22, 2018 2:30 am    Post subject: Reply with quote

1) I'm awfully sorry, I forget to mention that I'm using openrc. It is a significant bit of information.

2) I know about /etc/modules-load.d. I'm using it as quick patch-up for the problem.

Note that the system worked without manual module configuration before. And I'd like to restore that automatic behavior. It's really tiresome to google modules name required for the specific programs.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7198

PostPosted: Thu Nov 22, 2018 3:49 am    Post subject: Reply with quote

the dev manager does autoloading of modules for hardware, in your case eudev so.
no idea of the problem, but the culprit should be eudev
Back to top
View user's profile Send private message
ayvango
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2012
Posts: 118

PostPosted: Sun Nov 25, 2018 6:19 am    Post subject: Reply with quote

krinn wrote:
no idea of the problem, but the culprit should be eudev

You had guessed right.

Old eudev had two conflicting use flags: modutils and kmod. At that time I had choosed modutils and disabled kmod. Now the modutils flag has perished and the single survival is kmod. But it was disabled in packages.use. Enabling the kmod flag and rebuild world with newdeps solved the problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum