Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dmesg warning says " ACPI Warning: SystemIO range conflicts"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
whjeon
n00b
n00b


Joined: 20 Nov 2017
Posts: 64
Location: Seoul,Korea(Republic of)

PostPosted: Thu Nov 22, 2018 1:29 pm    Post subject: dmesg warning says " ACPI Warning: SystemIO range confl Reply with quote

Hi, Mentors!!
Thanks for your support every day!

Now, I want to ask you about my dmesg output.
exact warning message is like below.

Code:

[    4.426254] ACPI Warning: SystemIO range 0x0000000000001828-0x000000000000182F conflicts with OpRegion 0x0000000000001800-0x000000000000187F (\PMIO) (20170728/utaddress-247)
[    4.426258] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.426260] ACPI Warning: SystemIO range 0x0000000000001C40-0x0000000000001C4F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR2) (20170728/utaddress-247)
[    4.426263] ACPI Warning: SystemIO range 0x0000000000001C40-0x0000000000001C4F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20170728/utaddress-247)
[    4.426265] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.426265] ACPI Warning: SystemIO range 0x0000000000001C30-0x0000000000001C3F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR2) (20170728/utaddress-247)
[    4.426267] ACPI Warning: SystemIO range 0x0000000000001C30-0x0000000000001C3F conflicts with OpRegion 0x0000000000001C00-0x0000000000001C3F (\GPRL) (20170728/utaddress-247)
[    4.426269] ACPI Warning: SystemIO range 0x0000000000001C30-0x0000000000001C3F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20170728/utaddress-247)
[    4.426271] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.426271] ACPI Warning: SystemIO range 0x0000000000001C00-0x0000000000001C2F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR2) (20170728/utaddress-247)
[    4.426273] ACPI Warning: SystemIO range 0x0000000000001C00-0x0000000000001C2F conflicts with OpRegion 0x0000000000001C00-0x0000000000001C3F (\GPRL) (20170728/utaddress-247)
[    4.426275] ACPI Warning: SystemIO range 0x0000000000001C00-0x0000000000001C2F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20170728/utaddress-247)
[    4.426277] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver


Full dmesg output(at line 708) : https://paste.pound-python.org/show/XWUHPWdgEWbhRsJ3lQDs/

I've installed kernel with genkernel, and then configured several times with
Code:

#make menuconfig
#make -j4
#make modules_install
#make install

#genkernell --microcode --install initramfs

#grub-mkconfig -o /boot/grub/grub.cfg


Below is more information
uname -a output: https://paste.pound-python.org/show/e7IpCRwRoZeqSwyDSnT8/
my .config : https://paste.pound-python.org/show/YT5QJM6PmWCpviPAo2F8/
lspci -k output: https://paste.pound-python.org/show/XxJVVpNOIVQHwUSin6Ap/

Thanks for your help!

[EDIT: 0]

Genkernel compiled linux image was preventing me to boot with custom made kernel.
So, I deleted linux-genkernel image, and grub-mkconfig again.

Now, I have #7 kernel compiled boot. But, error message is same.

[EDIT: 1]
Curious, I've already changed some kernel configs to fix my dmesg erros.
But if I always booted with genkernel compiled kernel, how could I resolved them?

Really awkward.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5768

PostPosted: Thu Nov 22, 2018 3:26 pm    Post subject: Reply with quote

That's normal, unfortunately. The vast majority of BIOS code is garbage and doesn't set up these things right as it should.

You can force the kernel to ignore it by passing acpi_enforce_resources=lax on the boot cmdline (doc: /usr/src/linux/Documentation/admin-guide/kernel-parameters.txt), it might make your hardware sensors work in Linux but it might also reduce stability.
Back to top
View user's profile Send private message
whjeon
n00b
n00b


Joined: 20 Nov 2017
Posts: 64
Location: Seoul,Korea(Republic of)

PostPosted: Thu Nov 22, 2018 10:56 pm    Post subject: Reply with quote

Thanks for your help!
I think I worried too much!
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5848

PostPosted: Thu Nov 22, 2018 11:44 pm    Post subject: Reply with quote

Code:
[    4.426277] lpc_ich: Resource conflict(s) found affecting gpio_ich


Try disabling gpio_ich. :wink:

edit: odd, it is disabled. Maybe try turning it on and disable lpc_ich?
_________________
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.

banned from #gentoo since sept 2017
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5768

PostPosted: Thu Nov 22, 2018 11:54 pm    Post subject: Reply with quote

lpc_ich is a "multifunction device driver", it handles everything not on PCI/USB - keyboard, touchpad, backlight controller, etc. Turning it off to get a gpio working probably isn't worth it.
Back to top
View user's profile Send private message
whjeon
n00b
n00b


Joined: 20 Nov 2017
Posts: 64
Location: Seoul,Korea(Republic of)

PostPosted: Fri Nov 23, 2018 1:51 am    Post subject: Reply with quote

I've learned that Do not touch what I don't know, So I'll keep it as it is.
I'll turn it or off after I read some Wiki articles! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum