Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201811-14 ] Exiv2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Sat Nov 24, 2018 11:26 pm    Post subject: [ GLSA 201811-14 ] Exiv2 Reply with quote

Gentoo Linux Security Advisory

Title: Exiv2: Multiple vulnerabilities (GLSA 201811-14)
Severity: normal
Exploitable: remote
Date: 2018-11-24
Bug(s): #647810, #647812, #647816, #652822, #655842, #655958, #658236
ID: 201811-14

Synopsis

Multiple vulnerabilities have been found in Exiv2, the worst of
which could result in a Denial of Service condition.


Background

Exiv2 is a C++ library and a command line utility to manage image
metadata.


Affected Packages

Package: media-gfx/exiv2
Vulnerable: < 0.26_p20180811-r3
Unaffected: >= 0.26_p20180811-r3
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in Exiv2. Please review
the CVE identifiers referenced below for details.


Impact

A remote attacker could cause a Denial of Service condition or obtain
sensitive information via a specially crafted file.


Workaround

There is no known workaround at this time.

Resolution

All Exiv2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=media-gfx/exiv2-0.26_p20180811-r3"
   


References

CVE-2017-17723
CVE-2017-17724
CVE-2018-10780
CVE-2018-10958
CVE-2018-10998
CVE-2018-10999
CVE-2018-11037
CVE-2018-11531
CVE-2018-12264
CVE-2018-12265
CVE-2018-5772
CVE-2018-8976
CVE-2018-8977
CVE-2018-9144
CVE-2018-9145
CVE-2018-9146
CVE-2018-9303
CVE-2018-9304
CVE-2018-9305
CVE-2018-9306
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum