Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201811-18 ] Tablib
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Tue Nov 27, 2018 3:26 am    Post subject: [ GLSA 201811-18 ] Tablib Reply with quote

Gentoo Linux Security Advisory

Title: Tablib: Arbitrary command execution (GLSA 201811-18)
Severity: normal
Exploitable: remote
Date: 2018-11-27
Bug(s): #621884
ID: 201811-18

Synopsis

A vulnerability in Tablib might allow remote attackers to execute
arbitrary python commands.


Background

Tablib is an MIT Licensed format-agnostic tabular dataset library,
written in Python. It allows you to import, export, and manipulate
tabular data sets.


Affected Packages

Package: dev-python/tablib
Vulnerable: < 0.12.1
Unaffected: >= 0.12.1
Architectures: All supported architectures


Description

A vulnerability was discovered in Tablib’s Databook loading
functionality, due to improper input validation.


Impact

A remote attacker, by enticing the user to process a specially crafted
Databook via YAML, could possibly execute arbitrary python commands with
the privilege of the process.


Workaround

There is no known workaround at this time.

Resolution

All Tablib users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-python/tablib-0.12.1"
   


References

CVE-2017-2810
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum