Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ glsa 201812-01 ] php
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Sun Dec 02, 2018 6:26 pm    Post subject: [ glsa 201812-01 ] php Reply with quote

Gentoo Linux Security Advisory

Title: PHP: Multiple vulnerabilities (GLSA 201812-01)
Severity: normal
Exploitable: local, remote
Date: 2018-12-02
Bug(s): #658092, #666256
ID: 201812-01

Synopsis

Multiple vulnerabilities have been found in PHP, the worst of which
could result in a Denial of Service condition.


Background

PHP is an open source general-purpose scripting language that is
especially suited for web development.


Affected Packages

Package: dev-lang/php
Vulnerable: < 5.6.38
Vulnerable: < 7.0.32
Vulnerable: < 7.1.22
Vulnerable: < 7.2.10
Unaffected: >= 5.6.38
Unaffected: >= 7.0.32
Unaffected: >= 7.1.22
Unaffected: >= 7.2.10
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in PHP. Please review the
referenced CVE identifiers for details.


Impact

An attacker could cause a Denial of Service condition or obtain
sensitive information.


Workaround

There is no known workaround at this time.

Resolution

All PHP 5.6.X users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-5.6.38"
   
All PHP 7.0.X users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.0.32"
   
All PHP 7.1.X users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.1.22"
   
All PHP 7.2.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.2.10"
   


References

CVE-2018-10545
CVE-2018-10546
CVE-2018-10548
CVE-2018-10549
CVE-2018-17082


Last edited by GLSA on Tue Dec 04, 2018 4:17 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum