Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel 4.14.83 gets stuck on halt/reboot sequence
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Dwosky
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2018
Posts: 87

PostPosted: Fri Dec 07, 2018 3:38 pm    Post subject: Kernel 4.14.83 gets stuck on halt/reboot sequence Reply with quote

So basically I have one of my PCs that goes without issues over kernel 4.9.140, but its giving me a lot of headaches over 4.14.83 or even 4.18.20.

Right now, the last one that I'm checking is that I cannot fully restart from 4.14.83, as the process gets stuck:
Code:
The system is going down for reboot NOW!
INIT: Switching to runlevel: 6
INIT: Sending processes configured via /etc/inittab the TERM signal
INIT: version 2.91 reloading
 * Stopping local ...                                                                  [ ok ]
 * Saving random seed ...                                                              [ ok ]
 * Unmounting network filesystems ...                                                  [ ok ]
 * Stopping metalog ...                                                                [ ok ]
 * Unmounting loop devices
 * Unmounting filesystems
 *   Unmounting /tmp ...                                                               [ ok ]
 *   Unmounting /boot ...                                                              [ ok ]
 * Deactivating swap devices ...                                                       [ ok ]
 * Stopping udev ...                                                                   [ ok ]
 * Setting hardware clock using the system clock [Local Time] ...                      [ ok ]
 * Terminating remaining processes ...                                                 [ ok ]
 * Killing remaining processes ...                                                     [ ok ]
 * Saving dependency cache ...                                                         [ ok ]
 * Remounting remaining filesystems as read-only ...
 *   Remounting / read only ...                                                        [ ok ]

On "Stopping udev", kernel 4.14.83 takes 10-20 seconds and get stuck on the last line. This process, the whole process, is taken care in less than 10 seconds with kernel 4.9.140. Any idea where could be the issue or why kernel 4.14.83 struggles to shutdown/reboot?

Kernel 4.9.140 config: https://pastebin.pl/view/332084ce
Kernel 4.14.83 config: https://pastebin.pl/view/e3e81a8e
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 564
Location: France

PostPosted: Fri Dec 21, 2018 4:30 pm    Post subject: Reply with quote

On which hardware ?
I was forced to update the BIOS firmware of a HP dc5800 box to run a 4.14 kernel, because of ACPI problems : https://bugzilla.redhat.com/show_bug.cgi?id=1520265
Back to top
View user's profile Send private message
Dwosky
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2018
Posts: 87

PostPosted: Fri Dec 21, 2018 6:58 pm    Post subject: Reply with quote

In the end it seems it was a side effect of the current issue with Nvidia drivers, which doesn't load the modules correctly so upon shutdown it got stuck trying to unload the module.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum