Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
AMDGPU Causing occasional X crash
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
zBrain
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 147

PostPosted: Sun Dec 09, 2018 5:23 am    Post subject: AMDGPU Causing occasional X crash Reply with quote

I unfortunately can't pinpoint when this started, but it was recent. It happens when I go away from the computer. I don't suspend or anything, just have KDE set to sleep my monitors.

This seems similar, and is marked solved, but I can't find a 'kfd' module in the kernel that is mentioned. It's also the radeon driver. https://bbs.archlinux.org/viewtopic.php?id=232672


-- Moderator Edit --

The Xorg error is

[240190.030] (WW) AMDGPU(0): flip queue failed: Device or resource busy
[240190.030] (WW) AMDGPU(0): Page flip failed: Device or resource busy
[240190.030] (EE) AMDGPU(0): present flip failed

with the full log at pastebin: for readability

--The Doctor
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2586

PostPosted: Sun Dec 09, 2018 6:11 am    Post subject: Reply with quote

Not what you want to here, but that arch error is unrelated as it deals with radon, not amdgpu, so kfd is most likely a wild goose chase.

However, it does appear that this is a known bug. link. Reading through, it appears it might be opengl and/or kwin related. I have experienced no such thing with i3, however I also disabled screen blanking. I have only turned my displays off once or twice but never with any issues.

For an experiment I would disable the kde power savings and see what X does if you let it decide what to do instead of some other black box. To set the time directly create a file /etc/X11/xorg.conf.d/40-monitor.conf and put
Code:
section "ServerFlags"
Option "blank time" "0"
Option "standby time" "0"
Option "suspend time" "0"
Option "off time" "0"
EndSection
replace the zero with the time in minutes you want, zero being off.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum