Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Unable to boot
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Thu Dec 27, 2018 10:15 pm    Post subject: Reply with quote

So we have narrowed this down to my nvidia being faulty. Not the nvidia driver version. Not the configuration (since the configuration only matters once the module has loaded).
Would a fresh installation help? What would I be doing differently then?
_________________
[19:18] <@NeddySeagoon> Gentoo has an installer. Just like other distros. Go to the bathroom, look in the mirror. You will see the Gentoo installer :)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43178
Location: 56N 3W

PostPosted: Thu Dec 27, 2018 10:19 pm    Post subject: Reply with quote

reikdas,

Your nvidia may be fine. Its your kernel that's faulty.
You need it to provide the missing symbols.

BACKLIGHT_CLASS_DEVICE [=y] is a menu.
What do you have selected in that menu?

Probably anything will do. You won't use the driver but it will pull in the symbols you need for nvidia.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Muso
l33t
l33t


Joined: 22 Oct 2002
Posts: 979
Location: The Holy city of Honolulu

PostPosted: Thu Dec 27, 2018 10:20 pm    Post subject: Reply with quote

Don't reinstall, just try to get X working before using something like GDM, LiteDM, etc. A simple startx by a normal user is an easier way to figure out X problems.

Be sure not to have any nvidia or nouveu frambuffer devices in your kernel, and also make sure to not include nvidia i2c.
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Thu Dec 27, 2018 11:02 pm    Post subject: Reply with quote

I fixed it by enabling everything under BACKLIGHT_CLASS_DEVICE. Even nouveau.
Now nvidia loads and everything works.
Thanks NeddySeagoon! and everyone else who helped!
_________________
[19:18] <@NeddySeagoon> Gentoo has an installer. Just like other distros. Go to the bathroom, look in the mirror. You will see the Gentoo installer :)
Back to top
View user's profile Send private message
Vucius
n00b
n00b


Joined: 13 Jun 2019
Posts: 1
Location: China

PostPosted: Thu Jun 13, 2019 6:18 pm    Post subject: Reply with quote

reikdas wrote:
I fixed it by enabling everything under BACKLIGHT_CLASS_DEVICE. Even nouveau.
Now nvidia loads and everything works.
Thanks NeddySeagoon! and everyone else who helped!


I‘m a noob on Linux,and met the same problem.I want to know how to set CONFIG_DRM = y and BACKLIGHT_CLASS_DEVICE = y.But I can not open the links above.
So...Could you tell me about the relevant kernel options~~
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum