Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] dev-Version: emerge -avuDN world scheitert
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ManfredB
Apprentice
Apprentice


Joined: 27 Dec 2007
Posts: 288

PostPosted: Wed Jan 09, 2019 8:06 am    Post subject: [gelöst] dev-Version: emerge -avuDN world scheitert Reply with quote

Hallo zusammen,

ich versuche in der dev-Version (Profil 17.1) von gentoo, ein Update durchzuführen,
doch es scheitert einfach an einem Konflikt zwischen verschiedenen Paketen.

Hier die Übersicht:

Code:

emerge -avuDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  rR    ] dev-libs/openssl-1.0.2q::gentoo  USE="asm sslv3 tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs -test -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 0 KiB
[ebuild  r  U #] dev-libs/openssl-1.1.1a-r1:0/1.1::gentoo [1.0.2q:0/0::gentoo] USE="asm zlib -bindist -rfc3779 -sctp -sslv3* -static-libs -test -tls-heartbeat* -vanilla (-gmp%) (-kerberos%) (-sslv2%)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 8.155 KiB
[ebuild  rR    ] dev-perl/Net-SSLeay-1.820.0::gentoo  USE="-examples -libressl -minimal -test" 390 KiB
[ebuild  rR    ] net-misc/iputils-20180629::gentoo  USE="arping filecaps ipv6 ssl -SECURITY_HAZARD -caps -clockdiff -doc -gcrypt -idn -libressl -nettle -rarpd -rdisc -static -tftpd -tracepath -traceroute" 220 KiB
[ebuild  rR    ] dev-libs/libevent-2.1.8:0/2.1-6::gentoo  USE="ssl threads -debug -libressl -static-libs -test" ABI_X86="(64) -32 (-x32)" 1.003 KiB
[ebuild  rR    ] net-misc/socat-1.7.3.2::gentoo  USE="ipv6 readline ssl tcpd -bindist -libressl" 482 KiB
[ebuild  rR    ] net-libs/libvncserver-0.9.11-r1::gentoo  USE="24bpp ipv6 jpeg png ssl threads zlib -gcrypt -gnutls -libressl -static-libs -systemd -test" ABI_X86="(64) -32 (-x32)" 1.381 KiB
[ebuild  rR    ] dev-lang/ruby-2.4.5-r1:2.4::gentoo  USE="berkdb gdbm ipv6 rdoc ssl -debug -doc -examples -jemalloc -libressl -rubytests -socks5 -static-libs -tk -xemacs" 9.829 KiB
[ebuild  rR    ] www-client/w3m-0.5.3_p20180125::gentoo  USE="X gpm nls ssl unicode -fbcon -gdk-pixbuf -imlib -libressl -lynxkeymap -nntp -xface" L10N="de -ja" 2.131 KiB
[ebuild  rR    ] dev-qt/qtnetwork-5.11.3:5/5.11::gentoo  USE="ssl -bindist -connman -debug -libproxy -networkmanager -test" 0 KiB
[ebuild  rR    ] net-misc/wget-1.20.1::gentoo  USE="ipv6 nls pcre ssl zlib -debug -gnutls -idn -libressl -ntlm -static -test -uuid" 4.290 KiB
[ebuild  rR    ] app-crypt/rhash-1.3.6-r1::gentoo  USE="nls ssl -debug -libressl -static-libs" ABI_X86="(64) -32 (-x32)" 321 KiB
[ebuild  rR    ] net-nds/openldap-2.4.45::gentoo  USE="berkdb crypt ipv6 minimal ssl syslog tcpd -cxx -debug -experimental -gnutls -iodbc -kerberos -kinit -libressl -odbc -overlays -pbkdf2 -perl -samba -sasl (-selinux) -sha2 -slp -smbkrb5passwd -static-libs" ABI_X86="(64) -32 (-x32)" 5.552 KiB
[ebuild  rR    ] net-misc/curl-7.63.0-r1::gentoo  USE="ipv6 ldap ssl -adns -brotli -http2 -idn -kerberos -metalink -rtmp -samba -ssh -static-libs -test -threads" ABI_X86="(64) -32 (-x32)" CURL_SSL="openssl -gnutls -libressl -mbedtls -nss (-winssl)" 2.932 KiB
[ebuild  rR    ] net-misc/dhcp-4.4.1::gentoo  USE="client ipv6 ldap server ssl -libressl (-selinux) -vim-syntax" 10.903 KiB
[ebuild  rR    ] net-wireless/wpa_supplicant-2.7::gentoo  USE="dbus hs2-0 qt5 readline ssl -ap -bindist -eap-sim -eapol_test -fasteap -gnutls -libressl -p2p -privsep (-ps3) (-selinux) -smartcard -suiteb -tdls -uncommon-eap-types (-wimax) -wps" 3.022 KiB
[ebuild  rR    ] dev-lang/python-3.6.6:3.6/3.6m::gentoo  USE="bluetooth gdbm ipv6 ncurses readline ssl (threads) xml -build -examples -hardened -libressl -sqlite -test -tk -wininst" 16.769 KiB
[ebuild  rR    ] dev-lang/python-2.7.15:2.7::gentoo  USE="bluetooth gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -libressl -tk -wininst" 12.362 KiB
[ebuild  rR    ] dev-lang/python-3.5.5-r1:3.5/3.5m::gentoo  USE="bluetooth gdbm ipv6 ncurses readline ssl (threads) xml -build -examples -hardened -libressl -sqlite -test -tk -wininst" 15.004 KiB
[ebuild  rR    ] app-arch/libarchive-3.3.3:0/13::gentoo  USE="acl bzip2 e2fsprogs iconv lzma threads xattr zlib -expat -libressl -lz4 -lzo -nettle -static-libs" ABI_X86="(64) -32 (-x32)" 6.383 KiB
[ebuild  rR    ] dev-db/mysql-connector-c-6.1.11-r1:0/18::gentoo  USE="-libressl -static-libs" ABI_X86="(64) -32 (-x32)" 3.408 KiB
[ebuild  rR    ] net-libs/libssh-0.8.6:0/4::gentoo  USE="sftp zlib -debug -doc -examples -gcrypt -gssapi -libressl -mbedtls -pcap -server -static-libs -test" ABI_X86="(64) -32 (-x32)" 424 KiB
[ebuild  rR    ] net-misc/freerdp-2.0.0_rc4:0/2::gentoo  USE="X alsa client cups jpeg usb xv -debug -doc -ffmpeg -gstreamer -libav -libressl (-neon) -openh264 -pulseaudio -server -smartcard -systemd -test -wayland -xinerama" 6.506 KiB
[ebuild  rR    ] sys-fs/encfs-1.9.5::gentoo  USE="nls -libressl" 2.734 KiB
[ebuild  rR    ] app-crypt/qca-2.2.0_pre20180606:2::gentoo  USE="ssl -botan -debug -doc -examples -gcrypt -gpg -libressl -logger -nss -pkcs11 -sasl -softstore -test" 685 KiB
[ebuild  rR    ] app-text/mupdf-1.14.0-r2:0/1.14.0::gentoo  USE="X javascript opengl openssl vanilla -curl -libressl -static-libs" 40.628 KiB
[ebuild  rR    ] x11-base/xorg-server-1.20.3:0/1.20.3::gentoo  USE="glamor ipv6 suid udev xorg -debug -dmx -doc -kdrive -libressl -minimal (-selinux) -static-libs -systemd -unwind -wayland -xcsecurity -xephyr -xnest -xvfb" 6.060 KiB
[ebuild  rR    ] dev-python/m2crypto-0.31.0::gentoo  PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5 -python3_7" 1.262 KiB
[ebuild  rR    ] dev-python/cryptography-2.4.2::gentoo  USE="-libressl -test" PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7" 458 KiB
[ebuild  rR    ] app-admin/gkrellm-2.3.10-r2:2::gentoo  USE="X nls ssl -gnutls -hddtemp -libressl -lm_sensors -ntlm" 0 KiB
[ebuild  rR    ] net-dialup/ppp-2.4.7-r7:0/2.4.7::gentoo  USE="gtk ipv6 pam -activefilter -atm -dhcp -eap-tls -libressl -radius" 745 KiB
[ebuild  rR    ] net-voip/telepathy-gabble-0.18.4-r1::gentoo  USE="jingle -gnutls -libressl -plugins -test" 2.524 KiB
[ebuild  rR    ] media-sound/pulseaudio-12.2::gentoo  USE="X alsa alsa-plugin asyncns bluetooth caps dbus gdbm glib gtk ipv6 orc qt5 ssl tcpd udev webrtc-aec -doc -equalizer -gconf -jack -libressl -libsamplerate -lirc -native-headset (-neon) -ofono-headset (-oss) -realtime (-selinux) -sox (-system-wide) -systemd -test -zeroconf" ABI_X86="(64) -32 (-x32)" 1.627 KiB
[ebuild  rR    ] dev-db/mariadb-10.3.11:0/18::gentoo  USE="backup pam perl server xml -bindist (-client-libs) -cracklib -debug -extraengine -galera -innodb-lz4 -innodb-lzo -innodb-snappy -jdbc -jemalloc -kerberos -latin1 -libressl -mroonga -numa -odbc -oqgraph -profiling -rocksdb (-selinux) -sphinx -sst-mariabackup -sst-rsync -sst-xtrabackup -static -systemd -systemtap -tcmalloc -test -tokudb -yassl" 69.337 KiB
[ebuild  rR    ] www-client/falkon-3.0.1-r1::gentoo  USE="X dbus kwallet -debug -gnome-keyring -libressl -test" 2.168 KiB

Total: 35 packages (1 upgrade, 34 reinstalls), Size of downloads: 239.680 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.1.1a-r1:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.1.0g:0[bindist=] required by (net-misc/openssh-7.9_p1-r1:0/0::gentoo, installed)
    ^^                 ^^^^^^^^                                                                                                                                                   

  (dev-libs/openssl-1.0.2q:0/0::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/openssl-1.1:0/0= required by (dev-lang/ruby-2.3.8-r1:2.3/2.3::gentoo, installed)
    ^                 ^^^^^^^^                                                                                                                                         
    dev-libs/openssl:0/0= required by (net-misc/openssh-7.9_p1-r1:0/0::gentoo, installed)
                    ^^^^^                                                                                                   
    (and 1 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following packages are causing rebuilds:

  (dev-libs/openssl-1.1.1a-r1:0/1.1::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-lang/ruby-2.4.5-r1:2.4/2.4::gentoo, ebuild scheduled for merge)


Ich weiss nun nicht mehr weiter.

Hat jemand eine Idee, wie dieses Hindernis zu überwinden ist?

Oder muss ich eher noch 2 Wochen warten und dann einen neuen Update-Versuch durchführen?

Danke im voraus für Tipps.

Gruß
Manfred


Last edited by ManfredB on Wed Jan 09, 2019 9:54 am; edited 1 time in total
Back to top
View user's profile Send private message
grumblebear
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2008
Posts: 141

PostPosted: Wed Jan 09, 2019 8:55 am    Post subject: Reply with quote

Das hat nichts mit dem Profil zu tun. Ich würde mich zuerst einmal der alten 2.3 Version von Ruby entledigen, weil die noch openssl-1.0 zu verlangen scheint.
In make.conf eintragen: RUBY_TARGETS="ruby24"
Dann das world update durchführen, anschließend ein emerge --depclean. Könnte auch sein, dass ruby-2.3 zuerst deinstalliert werden muss.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Jan 09, 2019 8:58 am    Post subject: Reply with quote

Das Problem wirst du auch noch in 2 Wochen haben.

2 Ansätze:
Code:
emerge -avuDN world --backtrack=1000


Und wenn das nicht klappt:
Code:
emerge --unmerge ruby
emerge -avuDN world


Ruby sollte dann wieder mitinstalliert werden, sofern es als Abhängigkeit installiert wurde bzw. benötigt wird.

Falls das Problem dadurch nicht gelöst werden kann, musst du halt mal einen Blick ins Ebuild der installierten Ruby-Version werfen, ob dort die OpenSSL-Version auf die installierte ältere Version begrenzt ist.
Back to top
View user's profile Send private message
ManfredB
Apprentice
Apprentice


Joined: 27 Dec 2007
Posts: 288

PostPosted: Wed Jan 09, 2019 9:03 am    Post subject: Reply with quote

Zunächst erst einmal vielen Dank, daß ihr euch zu diesem Thema geäußert habt.

Alle Vorschläge werde ich sobald als möglich ausprobieren.
Dann melde ich mich wieder.

Seid herzlich gegrüßt von
Manfred
Back to top
View user's profile Send private message
ManfredB
Apprentice
Apprentice


Joined: 27 Dec 2007
Posts: 288

PostPosted: Wed Jan 09, 2019 9:23 am    Post subject: Reply with quote

Kurzer Zwischenbericht:

47 Pakete werden reinstalliert, dabei dev-ruby-2.4.5-r1, aber nicht mehr 2.3.8-r1.

Vielleicht ist damit das Problem schon gelöst.

Diese Pakete sind es:

Code:

Installing (1 of 47) dev-libs/openssl-1.1.1a-r1::gentoo
Installing (2 of 47) dev-perl/Net-SSLeay-1.820.0::gentoo
Installing (3 of 47) net-misc/iputils-20180629::gentoo
Installing (4 of 47) dev-libs/libevent-2.1.8::gentoo
Installing (5 of 47) net-libs/libvncserver-0.9.11-r1::gentoo
Installing (6 of 47) net-misc/socat-1.7.3.2::gentoo
Installing (7 of 47) dev-lang/ruby-2.4.5-r1::gentoo
Installing (8 of 47) www-client/w3m-0.5.3_p20180125::gentoo
Installing (9 of 47) dev-qt/qtnetwork-5.11.3::gentoo
Installing (10 of 47) dev-ruby/rubygems-3.0.1::gentoo
Installing (11 of 47) net-misc/wget-1.20.1::gentoo
Installing (12 of 47) app-crypt/rhash-1.3.6-r1::gentoo
Installing (13 of 47) virtual/rubygems-15::gentoo
Installing (14 of 47) net-nds/openldap-2.4.45::gentoo
Installing (15 of 47) dev-ruby/rake-12.3.2::gentoo
Installing (16 of 47) net-misc/curl-7.63.0-r1::gentoo
Installing (17 of 47) dev-ruby/power_assert-1.1.3::gentoo
Installing (18 of 47) net-misc/dhcp-4.4.1::gentoo
Installing (19 of 47) net-wireless/wpa_supplicant-2.7::gentoo
Installing (20 of 47) dev-lang/python-3.6.6::gentoo
Installing (21 of 47) dev-ruby/minitest-5.11.3::gentoo
Installing (22 of 47) dev-lang/python-2.7.15::gentoo
Installing (23 of 47) dev-ruby/net-telnet-0.2.0::gentoo
Installing (24 of 47) dev-lang/python-3.5.5-r1::gentoo
Installing (25 of 47) app-arch/libarchive-3.3.3::gentoo
Installing (26 of 47) dev-ruby/xmlrpc-0.3.0::gentoo
Installing (27 of 47) dev-db/mysql-connector-c-6.1.11-r1::gentoo
Installing (28 of 47) net-libs/libssh-0.8.6::gentoo
Installing (29 of 47) net-misc/freerdp-2.0.0_rc4::gentoo
Installing (30 of 47) sys-fs/encfs-1.9.5::gentoo
Installing (31 of 47) app-crypt/qca-2.2.0_pre20180606::gentoo
Installing (32 of 47) dev-ruby/kpeg-1.1.0-r1::gentoo
Installing (33 of 47) app-text/mupdf-1.14.0-r2::gentoo
Installing (34 of 47) dev-ruby/test-unit-3.2.9::gentoo
Installing (35 of 47) x11-base/xorg-server-1.20.3::gentoo
Installing (36 of 47) dev-python/m2crypto-0.31.0::gentoo
Installing (37 of 47) dev-python/cryptography-2.4.2::gentoo
Installing (38 of 47) app-admin/gkrellm-2.3.10-r2::gentoo
Installing (39 of 47) net-dialup/ppp-2.4.7-r7::gentoo
Installing (40 of 47) net-voip/telepathy-gabble-0.18.4-r1::gentoo
Installing (41 of 47) dev-ruby/json-2.1.0-r1::gentoo
Installing (42 of 47) media-sound/pulseaudio-12.2::gentoo
Installing (43 of 47) dev-db/mariadb-10.3.11::gentoo
Installing (44 of 47) net-misc/openssh-7.9_p1-r1::gentoo
Installing (45 of 47) dev-ruby/racc-1.4.14::gentoo
Installing (46 of 47) dev-ruby/rdoc-6.1.1::gentoo
Installing (47 of 47) www-client/falkon-3.0.1-r1::gentoo


Noch ein rebuild: net-wireless/crda-3.18-r2::gentoo
folgte, damit ist das erst einmal zu Ende.

Gruß
Manfred
Back to top
View user's profile Send private message
ManfredB
Apprentice
Apprentice


Joined: 27 Dec 2007
Posts: 288

PostPosted: Wed Jan 09, 2019 9:53 am    Post subject: Reply with quote

Ein erneutes emerge -avuDN world hat nichts mehr zu installieren gehabt.

Daraus schließe ich, daß das Problem gelöst ist.

Noch einmal vielen Dank für eure Hilfe.

Gruß
Manfred
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Wed Jan 09, 2019 7:19 pm    Post subject: Reply with quote

Quote:
Code:
emerge --unmerge ruby
Huh nein, bitte nicht. Das Kommando ist nicht nur falsch, sondern auch noch gefährlich.
Nutzt dafür doch besser --verbose --depclean (in kurz -vc)
das listet einem dann auch noch die ggf vorhandenen reverse deps mit auf, und man bricht sich damit nicht den dep tree :)
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Jan 09, 2019 10:03 pm    Post subject: Reply with quote

Josef.95 wrote:
Quote:
Code:
emerge --unmerge ruby
Huh nein, bitte nicht. Das Kommando ist nicht nur falsch, sondern auch noch gefährlich.
Nutzt dafür doch besser --verbose --depclean (in kurz -vc)
das listet einem dann auch noch die ggf vorhandenen reverse deps mit auf, und man bricht sich damit nicht den dep tree :)


Ja, doch, unmerge. Depclean wird Dir in dem Fall vermutlich gar nichts deinstallieren, da Ruby ja offensichtlich für irgendein Paket benötigt wird.

Depclean setze ich immer am Ende der Updates ein, um überflüssige Pakete zu entfernen.

Für gebrochene Abhängigkeiten gibt's revdev-rebuild. Das lass ich in Kombination mit emerge --depclean sowieso am Ende des Update-Vorgangs laufen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Thu Jan 10, 2019 2:48 pm    Post subject: Reply with quote

musv wrote:
Ja, doch, unmerge. Depclean wird Dir in dem Fall vermutlich gar nichts deinstallieren, da Ruby ja offensichtlich für irgendein Paket benötigt wird. [...]

Ja schon richtig, aber "da Ruby ja offensichtlich für irgendein Paket benötigt wird" sollte man dessen dep tree nicht mit --unmerge brechen.
Bedenke, wenn der anschliessende rebuild (aus was für Gründen auch immer) nicht klappt, dann steht man mit einem defekten System da - das tut nicht nötig.
Beachte bitte auch das ruby idR in mehreren Slots installiert ist (wenn man die default RUBY_TARGETS vom Profil nutzt),
und man dann mit einem ungeprüften `emerge --unmerge ruby` wahrscheinlich den höchsten installierten Slot deinstalliert, welcher in diesm Fall nicht der richtige ist.

Wie auch immer - der Tipp von grumblebear sollte funktionieren :)
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Thu Jan 10, 2019 10:07 pm    Post subject: Reply with quote

Da ich mein System aus Zeitgründen nur alle paar Monate mal aktualisier und noch dazu grundsätzlich unstable nutze, tritt der o.g. Fall eigentlich regelmäßig bei mir auf.

Es gibt auch grundsätzlich die Circular Dependencies, dass racc, rake und rdoc mit Useflag "doc" nicht gebaut werden können. Mittlerweile bin ich da an dem Punkt, dass ich die ganzen Pakete reihenweise runterschmeiß und durch die Abhängigkeitsprüfung wieder installieren lasse. Ist halt der Gentoo-Way, wenn man unstable fährt. Und das mit dem defekten System darf man nicht so eng sehen. Meistens hab ich irgendwo schon einen Bugreport mit Patch gefunden. In anderen Fällen hab ich halt den Bugreport erstellt.

Die Ruby-Slots sind auch so 'ne Sache. Bei mir ist derzeit nur Ruby24 installiert. Ich hab schon irgendwie darauf geachtet, dass ich keine anderen Ruby-Versionen benötige. Ruby macht bei mir seit Jahren Ärger bei Updates. Ich wär froh, wenn ich den Mist ganz aus dem System verbannen könnte.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum