Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing webmin on gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
quillo
n00b
n00b


Joined: 14 Jan 2019
Posts: 2

PostPosted: Mon Jan 14, 2019 1:12 pm    Post subject: Installing webmin on gentoo Reply with quote

Hello, I am new to the "gentoo world". I trying to install Webmin on my virtual machine, but I have, a problem. When I install webmin I get this information.

Code:
emerge -av webmin

 * IMPORTANT: 20 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: config file '/etc/portage/package.accept_keywords' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] sys-libs/ncurses-6.1-r2:0/6::gentoo [5.9-r2:5::gentoo] USE="-ada -cxx -debug -doc -gpm -minimal (-profile) -static-libs -test -threads -tinfo -trace -unicode" ABI_X86="(64) -32 (-x32)" 3287 KiB
[ebuild     U  ] app-arch/bzip2-1.0.6-r10:0/1::gentoo [1.0.6-r3:0/0::gentoo] USE="-static -static-libs" ABI_X86="(64%*) -32% (-x32)" 764 KiB
[ebuild     U  ] virtual/libiconv-0-r2::gentoo [0::gentoo] ABI_X86="(64%*) -32% (-x32)" 0 KiB
[ebuild     U  ] virtual/libintl-0-r2::gentoo [0::gentoo] ABI_X86="(64%*) -32% (-x32)" 0 KiB
[ebuild  N     ] sys-apps/gentoo-functions-0.12::gentoo  12 KiB
[ebuild  N     ] media-fonts/liberation-fonts-2.00.1-r3::gentoo  USE="-X -fontforge" 2233 KiB
[ebuild  N     ] virtual/ttf-fonts-1-r1::gentoo  0 KiB
[ebuild  N     ] app-portage/elt-patches-20170815::gentoo  28 KiB
[ebuild  N     ] dev-libs/libltdl-2.4.6::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 951 KiB
[ebuild     U  ] media-libs/libpng-1.6.35-r1:0/16::gentoo [1.6.8:0/16::gentoo] USE="-apng (-neon) -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="-sse%" 991 KiB
[ebuild  N     ] net-dns/libidn-1.35:0/12::gentoo  USE="-doc -emacs -java -mono -nls -static-libs" ABI_X86="(64) -32 (-x32)" 4072 KiB
[ebuild  N     ] dev-perl/LWP-MediaTypes-6.20.0-r1::gentoo  19 KiB
[ebuild  N     ] dev-perl/IO-Tty-1.120.0::gentoo  24 KiB
[ebuild  N     ] dev-perl/XML-Generator-1.40.0-r1::gentoo  25 KiB
[ebuild  N     ] dev-perl/Sys-Hostname-Long-1.500.0-r1::gentoo  6 KiB
[ebuild  N     ] dev-perl/Socket6-0.280.0::gentoo  65 KiB
[ebuild  N     ] dev-perl/HTML-Tagset-3.200.0-r1::gentoo  8 KiB
[ebuild  N     ] dev-perl/Digest-BubbleBabble-0.20.0-r1::gentoo  45 KiB
[ebuild  N     ] dev-perl/Net-LibIDN-0.120.0-r1::gentoo  14 KiB
[ebuild  N     ] dev-perl/TimeDate-2.300.0::gentoo  31 KiB
[ebuild  N     ] perl-core/File-Temp-0.230.400-r1::gentoo  59 KiB
[ebuild     U  ] virtual/perl-File-Temp-0.230.400-r5::gentoo [0.220.0-r2::gentoo] 0 KiB
[ebuild     U  ] dev-lang/perl-5.26.2:0/5.26::gentoo [5.16.3:0/5.16::gentoo] USE="-berkdb* -debug -doc -gdbm* -ithreads" 11770 KiB
[ebuild  N     ] virtual/perl-Data-Dumper-2.167.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Encode-2.880.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Carp-1.420.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-MIME-Base64-3.150.0-r4::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Exporter-5.720.0-r3::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Digest-MD5-2.550.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Time-Local-1.250.0-r1::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Getopt-Long-2.490.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-parent-0.236.0-r1::gentoo  0 KiB
[ebuild  N     ] virtual/perl-libnet-3.100.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Digest-SHA-5.960.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-XSLoader-0.270.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Storable-2.620.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Time-HiRes-1.974.100-r2::gentoo  0 KiB
[ebuild  N     ] virtual/perl-if-0.60.600-r2::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Digest-1.170.100_rc-r7::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Text-Balanced-2.30.0-r4::gentoo  0 KiB
[ebuild  N     ] virtual/perl-IO-Socket-IP-0.380.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-podlators-4.90.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Text-ParseWords-3.300.0-r4::gentoo  0 KiB
[ebuild     U  ] virtual/perl-Test-Harness-3.380.0::gentoo [3.260.0::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Parse-CPAN-Meta-2.150.10-r1::gentoo [1.440.400::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-YAML-0.18.0-r3::gentoo [0.8.0::gentoo] 0 KiB
[ebuild  N     ] virtual/perl-Sys-Syslog-0.350.0-r1::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Socket-2.20.30_rc-r2::gentoo  0 KiB
[ebuild  N     ] dev-perl/HTTP-Date-6.20.0-r1::gentoo  8 KiB
[ebuild  N     ] dev-perl/MD5-2.30.0-r1::gentoo  3 KiB
[ebuild  N    ~] dev-perl/Getopt-GUI-Long-0.930.0-r2::gentoo  USE="-examples" 14 KiB
[ebuild  N     ] dev-perl/Digest-HMAC-1.30.0-r1::gentoo  8 KiB
[ebuild  N     ] dev-perl/File-Listing-6.40.0-r1::gentoo  51 KiB
[ebuild  N     ] dev-perl/Crypt-OpenSSL-Random-0.110.0::gentoo  USE="-libressl" 15 KiB
[ebuild     U  ] dev-util/pkgconfig-0.29.2::gentoo [0.28::gentoo] USE="hardened -internal-glib" ABI_X86="(64%*) -32% (-x32)" 1970 KiB
[ebuild     U  ] virtual/pkgconfig-0-r1::gentoo [0::gentoo] ABI_X86="(64%*) -32% (-x32)" 0 KiB
[ebuild     U  ] media-libs/freetype-2.9.1-r3:2::gentoo [2.4.11:2::gentoo] USE="bzip2 png%* -X -adobe-cff% -bindist -cleartype_hinting% -debug -doc -fontforge -harfbuzz% -infinality -static-libs -utils (-auto-hinter%)" ABI_X86="(64%*) -32% (-x32)" 1882 KiB
[ebuild  N     ] dev-perl/Authen-PAM-0.160.0-r2::gentoo  USE="-examples" 45 KiB
[ebuild  N     ] dev-perl/URI-1.730.0::gentoo  USE="-test" 105 KiB
[ebuild  N     ] dev-perl/XML-NamespaceSupport-1.120.0::gentoo  USE="-test" 18 KiB
[ebuild  N     ] dev-perl/HTML-Parser-3.720.0::gentoo  USE="-test" 89 KiB
[ebuild  N     ] dev-perl/Net-SSLeay-1.820.0::gentoo  USE="-examples -libressl -minimal -test" 390 KiB
[ebuild  N     ] dev-perl/Crypt-OpenSSL-Bignum-0.90.0::gentoo  USE="-libressl" 16 KiB
[ebuild  N     ] dev-perl/XML-XPath-1.420.0::gentoo  USE="-examples -test" 55 KiB
[ebuild  N     ] dev-perl/Encode-Locale-1.50.0::gentoo  USE="-test" 9 KiB
[ebuild  N     ] dev-perl/IO-Socket-SSL-2.52.0::gentoo  USE="-examples -idn" 217 KiB
[ebuild  N     ] dev-perl/CGI-4.400.0::gentoo  USE="-examples -test" 196 KiB
[ebuild  N     ] dev-perl/MailTools-2.190.0::gentoo  USE="-examples -test" 55 KiB
[ebuild  N     ] dev-perl/Crypt-OpenSSL-RSA-0.280.0-r3::gentoo  USE="-libressl" 20 KiB
[ebuild  N     ] dev-perl/XML-SAX-Base-1.90.0::gentoo  USE="-test" 28 KiB
[ebuild  N     ] dev-perl/IPC-Run-0.960.0::gentoo  USE="-test" 119 KiB
[ebuild  N     ] dev-perl/File-Which-1.220.0::gentoo  USE="-pwhich -test" 22 KiB
[ebuild  N     ] dev-perl/WWW-RobotRules-6.20.0-r1::gentoo  9 KiB
[ebuild  N     ] dev-perl/IO-HTML-1.1.0::gentoo  USE="-test" 19 KiB
[ebuild  N     ] dev-perl/HTTP-Message-6.130.0::gentoo  USE="-test" 73 KiB
[ebuild  N     ] dev-perl/HTTP-Cookies-6.40.0::gentoo  USE="-test" 39 KiB
[ebuild  N     ] dev-perl/HTTP-Daemon-6.10.0-r2::gentoo  19 KiB
[ebuild  N     ] dev-perl/HTTP-Negotiate-6.10.0-r1::gentoo  9 KiB
[ebuild  N     ] dev-perl/Digest-GOST-0.60.0-r1::gentoo  USE="-test" 39 KiB
[ebuild  N     ] dev-perl/Sub-Name-0.210.0::gentoo  USE="-suggested -test" 80 KiB
[ebuild  N     ] dev-perl/Try-Tiny-0.300.0::gentoo  USE="-minimal -test" 34 KiB
[ebuild  N     ] dev-perl/Net-DNS-1.100.0::gentoo  USE="-examples -ipv6 -minimal -test" 256 KiB
[ebuild  N     ] dev-perl/Net-DNS-SEC-1.30.0::gentoo  USE="-test" 35 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-2.150.10-r1::gentoo [2.120.921::gentoo] 0 KiB
[uninstall     ] perl-core/CPAN-Meta-2.120.921::gentoo
[blocks b      ] <perl-core/CPAN-Meta-2.150.10 ("<perl-core/CPAN-Meta-2.150.10" is blocking virtual/perl-CPAN-Meta-2.150.10-r1)
[ebuild     U  ] dev-perl/Module-Build-0.422.400::gentoo [0.400.300::gentoo] USE="-test" 298 KiB
[ebuild  N    ~] dev-perl/Authen-Libwrap-0.230.0::gentoo  USE="-examples -test" 20 KiB
[ebuild  N     ] dev-perl/Parse-RecDescent-1.967.15::gentoo  USE="-examples -test" 173 KiB
[ebuild  N     ] dev-perl/IO-Socket-INET6-2.720.0-r1::gentoo  27 KiB
[ebuild  N     ] dev-perl/Tie-IxHash-1.230.0::gentoo  USE="-test" 10 KiB
[ebuild  N     ] dev-perl/Net-HTTP-6.170.0::gentoo  USE="-minimal -test" 38 KiB
[ebuild  N     ] dev-perl/libwww-perl-6.270.0::gentoo  USE="ssl -test" 160 KiB
[ebuild  N     ] dev-perl/LWP-Protocol-https-6.70.0::gentoo  USE="-test" 9 KiB
[ebuild  N     ] dev-perl/XML-Twig-3.520.0::gentoo  USE="-nls -test" 399 KiB
[ebuild     U  ] sys-devel/automake-1.15.1-r2:1.15::gentoo [1.15:1.15::gentoo] USE="-test%" 1475 KiB
[ebuild     U  ] dev-libs/libxml2-2.9.8:2::gentoo [2.9.1-r1:2::gentoo] USE="readline -debug -examples -icu -ipv6* -lzma -python -static-libs -test" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7 -python3_4% -python3_5% -python3_6% (-python3_7) (-python2_6%) (-python3_2%) (-python3_3%*)" 5341 KiB
[ebuild     U  ] media-libs/libjpeg-turbo-1.5.3-r2::gentoo [1.3.0::gentoo] USE="-java -static-libs" ABI_X86="(64%*) -32% (-x32)" 1635 KiB
[ebuild     U  ] sys-devel/gettext-0.19.8.1::gentoo [0.18.2::gentoo] USE="acl ncurses -cvs -cxx* -doc -emacs -git -java -nls* -openmp* -static-libs" ABI_X86="(64%*) -32% (-x32)" 19243 KiB
[ebuild  N     ] dev-perl/XML-SAX-1.0.0::gentoo  46 KiB
[ebuild     U  ] virtual/jpeg-0-r2::gentoo [0::gentoo] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[ebuild  N     ] dev-perl/XML-SAX-Expat-0.510.0::gentoo  USE="-test" 7 KiB
[ebuild  N     ] dev-perl/XML-Simple-2.250.0::gentoo  USE="-test" 77 KiB
[ebuild  N     ] media-libs/fontconfig-2.13.0-r4:1.0::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 1661 KiB
[ebuild  N     ] app-eselect/eselect-fontconfig-1.1::gentoo  2 KiB
[ebuild  N     ] media-libs/gd-2.2.5-r1:2/3::gentoo  USE="fontconfig jpeg png truetype zlib -static-libs -tiff -webp -xpm" ABI_X86="(64) -32 (-x32)" 2534 KiB
[ebuild  N     ] media-gfx/graphviz-2.40.1-r1::gentoo  USE="-X -cairo -devil -doc -examples -gdk-pixbuf -gtk -gts -guile -java -lasi -nls -pdf -perl -postscript -python -qt5 -ruby -static-libs -svg -tcl" PYTHON_TARGETS="python2_7" 25033 KiB
[ebuild  N     ] dev-perl/GraphViz-2.240.0::gentoo  USE="-examples -test" 94 KiB
[ebuild  N    ~] net-dns/dnssec-tools-2.2.3::gentoo  USE="-static-libs" 41935 KiB
[ebuild  N    ~] app-admin/webmin-1.881::gentoo  USE="ssl -ldap -minimal -mysql -postgres" 28227 KiB
[blocks B      ] <sys-devel/libtool-2.4.3-r2:2 ("<sys-devel/libtool-2.4.3-r2:2" is blocking dev-libs/libltdl-2.4.6)
[blocks B      ] <=sys-libs/ncurses-5.9-r4:5 ("<=sys-libs/ncurses-5.9-r4:5" is blocking sys-libs/ncurses-6.1-r2)

Total: 108 packages (19 upgrades, 88 new, 1 in new slot, 1 uninstall), Size of downloads: 158758 KiB
Conflict: 3 blocks (2 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3:0/5.16::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Scalar-List-Utils-1.270.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/File-Spec-3.400.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-CoreList-2.840.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Load-Conditional-0.540.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Compress-Raw-Zlib-2.60.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Compress-Raw-Bzip2-2.60.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-Compress-2.60.0:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.16* required by (virtual/perl-IO-Zlib-1.100.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Test-Harness-3.260.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Load-0.240.0:0/0::gentoo, installed)
                 ^^^^^^^^
    (and 5 more with the same problems)

  (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.26* required by (virtual/perl-Text-Balanced-2.30.0-r4:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    (and 25 more with the same problem)

virtual/libintl:0

  (virtual/libintl-0:0/0::gentoo, installed) pulled in by
    =virtual/libintl-0 required by (dev-util/pkgconfig-0.29.2:0/0::gentoo, ebuild scheduled for merge)
    ^                ^

  (virtual/libintl-0-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/libintl-0-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/gettext-0.19.8.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                ^^^^
    =virtual/libintl-0-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/gettext-0.19.8.1:0/0::gentoo, ebuild scheduled for merge)
    ^                ^^^^

virtual/perl-Test-Harness:0

  (virtual/perl-Test-Harness-3.260.0:0/0::gentoo, installed) pulled in by
    =virtual/perl-Test-Harness-3.260.0 required by (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge)
    ^                          ^^^^^^^

  (virtual/perl-Test-Harness-3.380.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-Test-Harness-3.380.0 required by (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    ^                          ^^^^^^^
    >=virtual/perl-Test-Harness-3.290.0 required by (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    ^^                          ^^^^^^^

virtual/perl-Parse-CPAN-Meta:0

  (virtual/perl-Parse-CPAN-Meta-1.440.400:0/0::gentoo, installed) pulled in by
    =virtual/perl-Parse-CPAN-Meta-1.440.400 required by (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    ^                             ^^^^^^^^^

  (virtual/perl-Parse-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-Parse-CPAN-Meta-2.150.10-r1 required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    ^                             ^^^^^^^^^^^
    >=virtual/perl-Parse-CPAN-Meta-1.441.400 required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^                             ^^^^^^^^^

virtual/perl-CPAN-Meta-YAML:0

  (virtual/perl-CPAN-Meta-YAML-0.8.0:0/0::gentoo, installed) pulled in by
    =virtual/perl-CPAN-Meta-YAML-0.8.0 required by (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    ^                            ^^^^^

  (virtual/perl-CPAN-Meta-YAML-0.18.0-r3:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-CPAN-Meta-YAML-0.18.0-r3 required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    ^                            ^^^^^^^^^
    >=virtual/perl-CPAN-Meta-YAML-0.11.0 required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^                            ^^^^^^

dev-perl/Module-Build:0

  (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-perl/Module-Build-0.420.0 required by (dev-perl/Authen-Libwrap-0.230.0:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^^

  (dev-perl/Module-Build-0.400.300:0/0::gentoo, installed) pulled in by
    ~dev-perl/Module-Build-0.400.300 required by (virtual/perl-Module-Build-0.400.300:0/0::gentoo, installed)
    ^                      ^^^^^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (perl-core/Test-Harness-3.260.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Compress-Raw-Bzip2-2.60.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Scalar-List-Utils-1.270.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Compress-Raw-Zlib-2.60.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Module-Load-0.240.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Module-Load-Conditional-0.540.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Module-CoreList-2.840.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/File-Spec-3.400.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/IO-Compress-2.60.0:0/0::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/libltdl-2.4.6:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libltdl:0 required by (media-gfx/graphviz-2.40.1-r1:0/0::gentoo, ebuild scheduled for merge)

  (sys-libs/ncurses-6.1-r2:0/6::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.2 required by (dev-lang/python-2.7.5-r3:2.7/2.7::gentoo, installed)
    sys-libs/ncurses required by (app-misc/tmux-1.8:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (sys-libs/readline-6.2_p1:0/0::gentoo, installed)
    sys-libs/ncurses required by (sys-process/htop-1.0.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-shells/bash-4.2_p45:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-editors/vim-7.3.762:0/0::gentoo, installed)
    sys-libs/ncurses required by @selected
    sys-libs/ncurses required by (net-ftp/proftpd-1.3.4d:0/0::gentoo, installed)
    sys-libs/ncurses required by (sys-apps/openrc-0.12.4:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (sys-devel/gettext-0.19.8.1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2-r2 required by (sys-apps/util-linux-2.22.2:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-admin/eselect-1.3.8:0/0::gentoo, installed)
    sys-libs/ncurses required by (net-analyzer/iftop-1.0_pre2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by (sys-process/psmisc-22.20:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-misc/mc-4.8.9:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (sys-apps/texinfo-4.13-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-editors/vim-core-7.3.762:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-apps/less-457:0/0::gentoo, installed)

  (sys-devel/libtool-2.4.2:2/2::gentoo, installed) pulled in by
    sys-devel/libtool required by (dev-libs/oniguruma-5.9.2-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (net-analyzer/iftop-1.0_pre2:0/0::gentoo, installed)
    sys-devel/libtool required by (app-text/htmltidy-20090325-r1:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (net-dns/bind-tools-9.10.3_p2:0/0::gentoo, installed)
    sys-devel/libtool required by (sys-libs/db-4.8.30:4.8/4.8::gentoo, installed)
    sys-devel/libtool required by (net-libs/libpcap-1.3.0-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (sys-fs/udev-208:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (media-libs/libjpeg-turbo-1.5.3-r2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-devel/libtool-1.5.18 required by (dev-lang/php-5.5.7:5.5/5.5::gentoo, installed)
    sys-devel/libtool required by (media-gfx/graphviz-2.40.1-r1:0/0::gentoo, ebuild scheduled for merge)
    sys-devel/libtool required by (dev-libs/libmcrypt-2.5.8-r2:0/0::gentoo, installed)
    sys-devel/libtool required by (dev-lang/php-5.5.7:5.5/5.5::gentoo, installed)
    sys-devel/libtool required by (dev-libs/libgcrypt-1.5.3:0/11::gentoo, installed)
    sys-devel/libtool required by (net-misc/wget-1.14:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (sys-apps/groff-1.22.2:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (dev-libs/iniparser-3.1:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (media-gfx/graphviz-2.40.1-r1:0/0::gentoo, ebuild scheduled for merge)
    sys-devel/libtool required by (app-misc/tmux-1.8:0/0::gentoo, installed)
    sys-devel/libtool required by (dev-libs/libxslt-1.1.28-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (net-misc/openssh-6.4_p1-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (net-misc/curl-7.34.0-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (dev-db/postgresql-9.3.2:9.3/9.3::gentoo, installed)
    sys-devel/libtool required by (sys-apps/kmod-15-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (dev-libs/iniparser-3.1:0/0::gentoo, installed)
    >=sys-devel/libtool-2.2.6b required by (sys-process/psmisc-22.20:0/0::gentoo, installed)
    sys-devel/libtool required by (app-admin/syslog-ng-3.4.2:0/0::gentoo, installed)
    sys-devel/libtool required by (sys-apps/the_silver_searcher-0.14:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (dev-libs/libxml2-2.9.8:2/2::gentoo, ebuild scheduled for merge)
    sys-devel/libtool required by (sys-process/htop-1.0.2:0/0::gentoo, installed)
    >=sys-devel/libtool-2 required by (sys-libs/pam-1.1.6-r2:0/0::gentoo, installed)
    sys-devel/libtool required by (sys-libs/pam-1.1.6-r2:0/0::gentoo, installed)
    sys-devel/libtool required by (dev-libs/glib-2.36.4-r1:2/2::gentoo, installed)
    sys-devel/libtool required by (sys-fs/ncdu-1.9:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (media-libs/fontconfig-2.13.0-r4:1.0/1.0::gentoo, ebuild scheduled for merge)

  (sys-libs/ncurses-5.9-r2:5/5::gentoo, installed) pulled in by
    >=sys-libs/ncurses-5.7-r7[unicode] required by (sys-process/procps-3.3.8-r2:0/0::gentoo, installed)
    sys-libs/ncurses[unicode] required by (sys-fs/ncdu-1.9:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by webmin (argument)
=app-admin/webmin-1.881 ~amd64
# required by net-dns/dnssec-tools-2.2.3::gentoo
# required by app-admin/webmin-1.881::gentoo
# required by webmin (argument)
=dev-perl/Getopt-GUI-Long-0.930.0-r2 ~amd64
# required by app-admin/webmin-1.881::gentoo
# required by webmin (argument)
=dev-perl/Authen-Libwrap-0.230.0 ~amd64
# required by app-admin/webmin-1.881::gentoo
# required by webmin (argument)
=net-dns/dnssec-tools-2.2.3 ~amd64

Would you like to add these changes to your config files? [Yes/No] yes

Autounmask changes successfully written.

 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! The following installed packages are masked:
- sys-devel/binutils-2.23.2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-devel/gcc-4.7.3-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/releases/17.0/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (27 May 2017)
# In the 17.0 profiles we assume that our system compiler uses C++14
# or later as default language setting. This means it has to be at
# least GCC 6. If you need an older compiler for specific purposes,
# feel free to unmask it, however, using it for normal emerging of
# packages is neither recommended nor supported in any way.

- sys-libs/glibc-2.17::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Please help me what I should do. I put emerge --info on the bottom.

Code:
emerge --info
Portage 2.3.51 (python 2.7.5-final-0, default/linux/amd64/17.0/hardened, gcc-4.7.3, glibc-2.17, 3.8.13-gentoo-kvm-romke-r2 x86_64)
=================================================================
System uname: Linux-3.8.13-gentoo-kvm-romke-r2-x86_64-QEMU_Virtual_CPU_version_1.7.0-with-gentoo-2.2
KiB Mem:     1014300 total,     39116 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 14 Jan 2019 11:30:01 +0000
Head commit of repository gentoo: 3279df74dabfb5d35fb179c28c15b9744ab30c59
sh bash 4.2_p45
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45::gentoo
dev-lang/perl:            5.16.3::gentoo
dev-lang/python:          2.7.5-r3::gentoo, 3.3.3::gentoo
dev-util/pkgconfig:       0.28::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.12.4::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.13.4::gentoo, 1.15::gentoo
sys-devel/binutils:       2.23.2::gentoo
sys-devel/gcc:            4.7.3-r1::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.2::gentoo
sys-devel/make:           3.82-r4::gentoo
sys-kernel/linux-headers: 3.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.17::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: no
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fforce-addr -mno-tls-direct-seg-refs"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -fforce-addr -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news nodoc noinfo parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirrors.evowise.com/gentoo/"
LANG="pl_PL.UTF-8"
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 bzip2 chroot crypt extensions fontconfig hardened jpeg loop-aes memlimit mmap mmx ncurses nptl nptlonly openssl pie png posix readline sockets sse sse2 ssl ssp symlink sysvipc truetype xml zlib" ABI_X86="64" CURL_SSL="openssl" ELIBC="glibc" KERNEL="linux" NGINX_MODULES_HTTP="access autoindex charset empty_gif fastcgi gzip gzip_static limit_req proxy rewrite stub_status" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby18" USERLAND="GNU"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


It is, a /etc/portage/ directory

Code:
drwxr-xr-x  6 root root 4,0K 01-14 14:09 .
drwxr-xr-x 47 root root 4,0K 01-14 12:45 ..
drwxr-xr-x  2 root root   22 2014-01-23  bin
-rw-r--r--  1 root root  462 01-14 13:28 ._cfg0000_package.accept_keywords
-rw-r--r--  1 root root  462 01-14 14:09 ._cfg0001_package.accept_keywords
-rw-r--r--  1 root root  734 01-14 13:21 make.conf
-rw-r--r--  1 root root  709 12-31 13:54 make.conf.bak
-rw-r--r--  1 root root  630 2014-01-23  make.conf.catalyst
-rw-r--r--  1 root root  505 2014-01-25  make.confe
lrwxrwxrwx  1 root root   60 12-31 14:45 make.profile -> ../../usr/portage/profiles/default/linux/amd64/17.0/hardened
-rw-r--r--  1 root root   21 12-31 14:34 package.unmask
-rw-r--r--  1 root root  432 12-31 14:02 package.use
-rw-r--r--  1 root root  432 12-31 14:38 package.use.bak
drwxr-xr-x  2 root root   27 2014-01-23  postsync.d
drwxr-xr-x  2 root root   20 01-14 12:44 repo.postsync.d
drwxr-xr-x  3 root root   21 2014-01-23  savedconfig


And file ._cfg0000_package.accept_keywords, ._cfg0001_package.accept_keywords files have the same content.

Code:
# required by webmin (argument)
=app-admin/webmin-1.881 ~amd64
# required by net-dns/dnssec-tools-2.2.3::gentoo
# required by app-admin/webmin-1.881::gentoo
# required by webmin (argument)
=dev-perl/Getopt-GUI-Long-0.930.0-r2 ~amd64
# required by app-admin/webmin-1.881::gentoo
# required by webmin (argument)
=dev-perl/Authen-Libwrap-0.230.0 ~amd64
# required by app-admin/webmin-1.881::gentoo
# required by webmin (argument)
=net-dns/dnssec-tools-2.2.3 ~amd64


When I use etc-update

Code:
Scanning configuration files ...
Below is a list of files that need updating, each
after the configuration file there is a list of possible substitute files.
1) /etc/portage/package.accept_keywords (1)
Select the file to be edited by entering the appropriate number.
(do not use -3, -5, -7 or -9 if you are not sure what to do)
(-1 to exit) (-3 to automatically combine all files)
(-5, to automatically merge and not use "mv -i")
(-7 to reject all updates)
(-9 to discard all updates and do not use 'rm -i'): -3
Replacing /etc/portage/package.accept_keywords with /etc/portage/._cfg0000_package.accept_keywords
Exiting: Nothing has to be done; leaving. :)


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
quillo
n00b
n00b


Joined: 14 Jan 2019
Posts: 2

PostPosted: Mon Jan 14, 2019 2:32 pm    Post subject: Installing webmin on gentoo Reply with quote

Now I have:

Code:
emerge -av webmin

 * IMPORTANT: 20 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] sys-libs/ncurses-6.1-r2:0/6::gentoo [5.9-r2:5::gentoo] USE="-ada -cxx -debug -doc -gpm -minimal (-profile) -static-libs -test -threads -tinfo -trace -unicode" ABI_X86="(64) -32 (-x32)" 3287 KiB
[ebuild     U  ] app-arch/bzip2-1.0.6-r10:0/1::gentoo [1.0.6-r3:0/0::gentoo] USE="-static -static-libs" ABI_X86="(64%*) -32% (-x32)" 764 KiB
[ebuild     U  ] virtual/libiconv-0-r2::gentoo [0::gentoo] ABI_X86="(64%*) -32% (-x32)" 0 KiB
[ebuild     U  ] virtual/libintl-0-r2::gentoo [0::gentoo] ABI_X86="(64%*) -32% (-x32)" 0 KiB
[ebuild  N     ] sys-apps/gentoo-functions-0.12::gentoo  12 KiB
[ebuild  N     ] media-fonts/liberation-fonts-2.00.1-r3::gentoo  USE="-X -fontforge" 2233 KiB
[ebuild  N     ] virtual/ttf-fonts-1-r1::gentoo  0 KiB
[ebuild  N     ] app-portage/elt-patches-20170815::gentoo  28 KiB
[ebuild  N     ] dev-libs/libltdl-2.4.6::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 951 KiB
[ebuild     U  ] media-libs/libpng-1.6.35-r1:0/16::gentoo [1.6.8:0/16::gentoo] USE="-apng (-neon) -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="-sse%" 991 KiB
[ebuild  N     ] net-dns/libidn-1.35:0/12::gentoo  USE="-doc -emacs -java -mono -nls -static-libs" ABI_X86="(64) -32 (-x32)" 4072 KiB
[ebuild  N     ] dev-perl/LWP-MediaTypes-6.20.0-r1::gentoo  19 KiB
[ebuild  N     ] dev-perl/IO-Tty-1.120.0::gentoo  24 KiB
[ebuild  N     ] dev-perl/XML-Generator-1.40.0-r1::gentoo  25 KiB
[ebuild  N     ] dev-perl/Sys-Hostname-Long-1.500.0-r1::gentoo  6 KiB
[ebuild  N     ] dev-perl/Socket6-0.280.0::gentoo  65 KiB
[ebuild  N     ] dev-perl/HTML-Tagset-3.200.0-r1::gentoo  8 KiB
[ebuild  N     ] dev-perl/Digest-BubbleBabble-0.20.0-r1::gentoo  45 KiB
[ebuild  N     ] dev-perl/Net-LibIDN-0.120.0-r1::gentoo  14 KiB
[ebuild  N     ] dev-perl/TimeDate-2.300.0::gentoo  31 KiB
[ebuild  N     ] perl-core/File-Temp-0.230.400-r1::gentoo  59 KiB
[ebuild     U  ] virtual/perl-File-Temp-0.230.400-r5::gentoo [0.220.0-r2::gentoo] 0 KiB
[ebuild     U  ] dev-lang/perl-5.26.2:0/5.26::gentoo [5.16.3:0/5.16::gentoo] USE="-berkdb* -debug -doc -gdbm* -ithreads" 11770 KiB
[ebuild  N     ] virtual/perl-Data-Dumper-2.167.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Encode-2.880.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Carp-1.420.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-MIME-Base64-3.150.0-r4::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Exporter-5.720.0-r3::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Digest-MD5-2.550.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Time-Local-1.250.0-r1::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Getopt-Long-2.490.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-parent-0.236.0-r1::gentoo  0 KiB
[ebuild  N     ] virtual/perl-libnet-3.100.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Digest-SHA-5.960.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-XSLoader-0.270.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Storable-2.620.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Time-HiRes-1.974.100-r2::gentoo  0 KiB
[ebuild  N     ] virtual/perl-if-0.60.600-r2::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Digest-1.170.100_rc-r7::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Text-Balanced-2.30.0-r4::gentoo  0 KiB
[ebuild  N     ] virtual/perl-IO-Socket-IP-0.380.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-podlators-4.90.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Text-ParseWords-3.300.0-r4::gentoo  0 KiB
[ebuild     U  ] virtual/perl-Test-Harness-3.380.0::gentoo [3.260.0::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Parse-CPAN-Meta-2.150.10-r1::gentoo [1.440.400::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-YAML-0.18.0-r3::gentoo [0.8.0::gentoo] 0 KiB
[ebuild  N     ] virtual/perl-Sys-Syslog-0.350.0-r1::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Socket-2.20.30_rc-r2::gentoo  0 KiB
[ebuild  N     ] dev-perl/HTTP-Date-6.20.0-r1::gentoo  8 KiB
[ebuild  N     ] dev-perl/MD5-2.30.0-r1::gentoo  3 KiB
[ebuild  N    ~] dev-perl/Getopt-GUI-Long-0.930.0-r2::gentoo  USE="-examples" 14 KiB
[ebuild  N     ] dev-perl/Digest-HMAC-1.30.0-r1::gentoo  8 KiB
[ebuild  N     ] dev-perl/File-Listing-6.40.0-r1::gentoo  51 KiB
[ebuild  N     ] dev-perl/Crypt-OpenSSL-Random-0.110.0::gentoo  USE="-libressl" 15 KiB
[ebuild     U  ] dev-util/pkgconfig-0.29.2::gentoo [0.28::gentoo] USE="hardened -internal-glib" ABI_X86="(64%*) -32% (-x32)" 1970 KiB
[ebuild     U  ] virtual/pkgconfig-0-r1::gentoo [0::gentoo] ABI_X86="(64%*) -32% (-x32)" 0 KiB
[ebuild     U  ] media-libs/freetype-2.9.1-r3:2::gentoo [2.4.11:2::gentoo] USE="bzip2 png%* -X -adobe-cff% -bindist -cleartype_hinting% -debug -doc -fontforge -harfbuzz% -infinality -static-libs -utils (-auto-hinter%)" ABI_X86="(64%*) -32% (-x32)" 1882 KiB
[ebuild  N     ] dev-perl/Authen-PAM-0.160.0-r2::gentoo  USE="-examples" 45 KiB
[ebuild  N     ] dev-perl/URI-1.730.0::gentoo  USE="-test" 105 KiB
[ebuild  N     ] dev-perl/XML-NamespaceSupport-1.120.0::gentoo  USE="-test" 18 KiB
[ebuild  N     ] dev-perl/HTML-Parser-3.720.0::gentoo  USE="-test" 89 KiB
[ebuild  N     ] dev-perl/Net-SSLeay-1.820.0::gentoo  USE="-examples -libressl -minimal -test" 390 KiB
[ebuild  N     ] dev-perl/Crypt-OpenSSL-Bignum-0.90.0::gentoo  USE="-libressl" 16 KiB
[ebuild  N     ] dev-perl/XML-XPath-1.420.0::gentoo  USE="-examples -test" 55 KiB
[ebuild  N     ] dev-perl/Encode-Locale-1.50.0::gentoo  USE="-test" 9 KiB
[ebuild  N     ] dev-perl/IO-Socket-SSL-2.52.0::gentoo  USE="-examples -idn" 217 KiB
[ebuild  N     ] dev-perl/CGI-4.400.0::gentoo  USE="-examples -test" 196 KiB
[ebuild  N     ] dev-perl/MailTools-2.190.0::gentoo  USE="-examples -test" 55 KiB
[ebuild  N     ] dev-perl/Crypt-OpenSSL-RSA-0.280.0-r3::gentoo  USE="-libressl" 20 KiB
[ebuild  N     ] dev-perl/XML-SAX-Base-1.90.0::gentoo  USE="-test" 28 KiB
[ebuild  N     ] dev-perl/IPC-Run-0.960.0::gentoo  USE="-test" 119 KiB
[ebuild  N     ] dev-perl/File-Which-1.220.0::gentoo  USE="-pwhich -test" 22 KiB
[ebuild  N     ] dev-perl/WWW-RobotRules-6.20.0-r1::gentoo  9 KiB
[ebuild  N     ] dev-perl/IO-HTML-1.1.0::gentoo  USE="-test" 19 KiB
[ebuild  N     ] dev-perl/HTTP-Message-6.130.0::gentoo  USE="-test" 73 KiB
[ebuild  N     ] dev-perl/HTTP-Cookies-6.40.0::gentoo  USE="-test" 39 KiB
[ebuild  N     ] dev-perl/HTTP-Daemon-6.10.0-r2::gentoo  19 KiB
[ebuild  N     ] dev-perl/HTTP-Negotiate-6.10.0-r1::gentoo  9 KiB
[ebuild  N     ] dev-perl/Digest-GOST-0.60.0-r1::gentoo  USE="-test" 39 KiB
[ebuild  N     ] dev-perl/Sub-Name-0.210.0::gentoo  USE="-suggested -test" 80 KiB
[ebuild  N     ] dev-perl/Try-Tiny-0.300.0::gentoo  USE="-minimal -test" 34 KiB
[ebuild  N     ] dev-perl/Net-DNS-1.100.0::gentoo  USE="-examples -ipv6 -minimal -test" 256 KiB
[ebuild  N     ] dev-perl/Net-DNS-SEC-1.30.0::gentoo  USE="-test" 35 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-2.150.10-r1::gentoo [2.120.921::gentoo] 0 KiB
[uninstall     ] perl-core/CPAN-Meta-2.120.921::gentoo
[blocks b      ] <perl-core/CPAN-Meta-2.150.10 ("<perl-core/CPAN-Meta-2.150.10" is blocking virtual/perl-CPAN-Meta-2.150.10-r1)
[ebuild     U  ] dev-perl/Module-Build-0.422.400::gentoo [0.400.300::gentoo] USE="-test" 298 KiB
[ebuild  N    ~] dev-perl/Authen-Libwrap-0.230.0::gentoo  USE="-examples -test" 20 KiB
[ebuild  N     ] dev-perl/Parse-RecDescent-1.967.15::gentoo  USE="-examples -test" 173 KiB
[ebuild  N     ] dev-perl/IO-Socket-INET6-2.720.0-r1::gentoo  27 KiB
[ebuild  N     ] dev-perl/Tie-IxHash-1.230.0::gentoo  USE="-test" 10 KiB
[ebuild  N     ] dev-perl/Net-HTTP-6.170.0::gentoo  USE="-minimal -test" 38 KiB
[ebuild  N     ] dev-perl/libwww-perl-6.270.0::gentoo  USE="ssl -test" 160 KiB
[ebuild  N     ] dev-perl/LWP-Protocol-https-6.70.0::gentoo  USE="-test" 9 KiB
[ebuild  N     ] dev-perl/XML-Twig-3.520.0::gentoo  USE="-nls -test" 399 KiB
[ebuild     U  ] sys-devel/automake-1.15.1-r2:1.15::gentoo [1.15:1.15::gentoo] USE="-test%" 1475 KiB
[ebuild     U  ] dev-libs/libxml2-2.9.8:2::gentoo [2.9.1-r1:2::gentoo] USE="readline -debug -examples -icu -ipv6* -lzma -python -static-libs -test" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7 -python3_4% -python3_5% -python3_6% (-python3_7) (-python2_6%) (-python3_2%) (-python3_3%*)" 5341 KiB
[ebuild     U  ] media-libs/libjpeg-turbo-1.5.3-r2::gentoo [1.3.0::gentoo] USE="-java -static-libs" ABI_X86="(64%*) -32% (-x32)" 1635 KiB
[ebuild     U  ] sys-devel/gettext-0.19.8.1::gentoo [0.18.2::gentoo] USE="acl ncurses -cvs -cxx* -doc -emacs -git -java -nls* -openmp* -static-libs" ABI_X86="(64%*) -32% (-x32)" 19243 KiB
[ebuild  N     ] dev-perl/XML-SAX-1.0.0::gentoo  46 KiB
[ebuild     U  ] virtual/jpeg-0-r2::gentoo [0::gentoo] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[ebuild  N     ] dev-perl/XML-SAX-Expat-0.510.0::gentoo  USE="-test" 7 KiB
[ebuild  N     ] dev-perl/XML-Simple-2.250.0::gentoo  USE="-test" 77 KiB
[ebuild  N     ] media-libs/fontconfig-2.13.0-r4:1.0::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 1661 KiB
[ebuild  N     ] app-eselect/eselect-fontconfig-1.1::gentoo  2 KiB
[ebuild  N     ] media-libs/gd-2.2.5-r1:2/3::gentoo  USE="fontconfig jpeg png truetype zlib -static-libs -tiff -webp -xpm" ABI_X86="(64) -32 (-x32)" 2534 KiB
[ebuild  N     ] media-gfx/graphviz-2.40.1-r1::gentoo  USE="-X -cairo -devil -doc -examples -gdk-pixbuf -gtk -gts -guile -java -lasi -nls -pdf -perl -postscript -python -qt5 -ruby -static-libs -svg -tcl" PYTHON_TARGETS="python2_7" 25033 KiB
[ebuild  N     ] dev-perl/GraphViz-2.240.0::gentoo  USE="-examples -test" 94 KiB
[ebuild  N    ~] net-dns/dnssec-tools-2.2.3::gentoo  USE="-static-libs" 41935 KiB
[ebuild  N    ~] app-admin/webmin-1.881::gentoo  USE="ssl -ldap -minimal -mysql -postgres" 28227 KiB
[blocks B      ] <sys-devel/libtool-2.4.3-r2:2 ("<sys-devel/libtool-2.4.3-r2:2" is blocking dev-libs/libltdl-2.4.6)
[blocks B      ] <=sys-libs/ncurses-5.9-r4:5 ("<=sys-libs/ncurses-5.9-r4:5" is blocking sys-libs/ncurses-6.1-r2)

Total: 108 packages (19 upgrades, 88 new, 1 in new slot, 1 uninstall), Size of downloads: 158758 KiB
Conflict: 3 blocks (2 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3:0/5.16::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Scalar-List-Utils-1.270.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/File-Spec-3.400.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-CoreList-2.840.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Load-Conditional-0.540.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Compress-Raw-Zlib-2.60.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Compress-Raw-Bzip2-2.60.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-Compress-2.60.0:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.16* required by (virtual/perl-IO-Zlib-1.100.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Test-Harness-3.260.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Load-0.240.0:0/0::gentoo, installed)
                 ^^^^^^^^
    (and 5 more with the same problems)

  (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.26* required by (virtual/perl-Text-Balanced-2.30.0-r4:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    (and 25 more with the same problem)

virtual/libintl:0

  (virtual/libintl-0:0/0::gentoo, installed) pulled in by
    =virtual/libintl-0 required by (dev-util/pkgconfig-0.29.2:0/0::gentoo, ebuild scheduled for merge)
    ^                ^

  (virtual/libintl-0-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/libintl-0-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/gettext-0.19.8.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                ^^^^
    =virtual/libintl-0-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/gettext-0.19.8.1:0/0::gentoo, ebuild scheduled for merge)
    ^                ^^^^

virtual/perl-Test-Harness:0

  (virtual/perl-Test-Harness-3.260.0:0/0::gentoo, installed) pulled in by
    =virtual/perl-Test-Harness-3.260.0 required by (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge)
    ^                          ^^^^^^^

  (virtual/perl-Test-Harness-3.380.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-Test-Harness-3.380.0 required by (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    ^                          ^^^^^^^
    >=virtual/perl-Test-Harness-3.290.0 required by (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    ^^                          ^^^^^^^

virtual/perl-Parse-CPAN-Meta:0

  (virtual/perl-Parse-CPAN-Meta-1.440.400:0/0::gentoo, installed) pulled in by
    =virtual/perl-Parse-CPAN-Meta-1.440.400 required by (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    ^                             ^^^^^^^^^

  (virtual/perl-Parse-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-Parse-CPAN-Meta-2.150.10-r1 required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    ^                             ^^^^^^^^^^^
    >=virtual/perl-Parse-CPAN-Meta-1.441.400 required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^                             ^^^^^^^^^

virtual/perl-CPAN-Meta-YAML:0

  (virtual/perl-CPAN-Meta-YAML-0.8.0:0/0::gentoo, installed) pulled in by
    =virtual/perl-CPAN-Meta-YAML-0.8.0 required by (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    ^                            ^^^^^

  (virtual/perl-CPAN-Meta-YAML-0.18.0-r3:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-CPAN-Meta-YAML-0.18.0-r3 required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    ^                            ^^^^^^^^^
    >=virtual/perl-CPAN-Meta-YAML-0.11.0 required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^                            ^^^^^^

dev-perl/Module-Build:0

  (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-perl/Module-Build-0.420.0 required by (dev-perl/Authen-Libwrap-0.230.0:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^^^

  (dev-perl/Module-Build-0.400.300:0/0::gentoo, installed) pulled in by
    ~dev-perl/Module-Build-0.400.300 required by (virtual/perl-Module-Build-0.400.300:0/0::gentoo, installed)
    ^                      ^^^^^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (perl-core/Test-Harness-3.260.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Compress-Raw-Bzip2-2.60.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Scalar-List-Utils-1.270.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Compress-Raw-Zlib-2.60.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Module-Load-0.240.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Module-Load-Conditional-0.540.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/Module-CoreList-2.840.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/File-Spec-3.400.0:0/0::gentoo, installed): ebuild is masked or unavailable
  (perl-core/IO-Compress-2.60.0:0/0::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/libltdl-2.4.6:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libltdl:0 required by (media-gfx/graphviz-2.40.1-r1:0/0::gentoo, ebuild scheduled for merge)

  (sys-libs/ncurses-6.1-r2:0/6::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.2 required by (dev-lang/python-2.7.5-r3:2.7/2.7::gentoo, installed)
    sys-libs/ncurses required by (app-misc/tmux-1.8:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (sys-libs/readline-6.2_p1:0/0::gentoo, installed)
    sys-libs/ncurses required by (sys-process/htop-1.0.2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-shells/bash-4.2_p45:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-editors/vim-7.3.762:0/0::gentoo, installed)
    sys-libs/ncurses required by @selected
    sys-libs/ncurses required by (net-ftp/proftpd-1.3.4d:0/0::gentoo, installed)
    sys-libs/ncurses required by (sys-apps/openrc-0.12.4:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (sys-devel/gettext-0.19.8.1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.2-r2 required by (sys-apps/util-linux-2.22.2:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-admin/eselect-1.3.8:0/0::gentoo, installed)
    sys-libs/ncurses required by (net-analyzer/iftop-1.0_pre2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by (sys-process/psmisc-22.20:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-misc/mc-4.8.9:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (sys-apps/texinfo-4.13-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-editors/vim-core-7.3.762:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-apps/less-457:0/0::gentoo, installed)

  (sys-devel/libtool-2.4.2:2/2::gentoo, installed) pulled in by
    sys-devel/libtool required by (dev-libs/oniguruma-5.9.2-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (net-analyzer/iftop-1.0_pre2:0/0::gentoo, installed)
    sys-devel/libtool required by (app-text/htmltidy-20090325-r1:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (net-dns/bind-tools-9.10.3_p2:0/0::gentoo, installed)
    sys-devel/libtool required by (sys-libs/db-4.8.30:4.8/4.8::gentoo, installed)
    sys-devel/libtool required by (net-libs/libpcap-1.3.0-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (sys-fs/udev-208:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (media-libs/libjpeg-turbo-1.5.3-r2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-devel/libtool-1.5.18 required by (dev-lang/php-5.5.7:5.5/5.5::gentoo, installed)
    sys-devel/libtool required by (media-gfx/graphviz-2.40.1-r1:0/0::gentoo, ebuild scheduled for merge)
    sys-devel/libtool required by (dev-libs/libmcrypt-2.5.8-r2:0/0::gentoo, installed)
    sys-devel/libtool required by (dev-lang/php-5.5.7:5.5/5.5::gentoo, installed)
    sys-devel/libtool required by (dev-libs/libgcrypt-1.5.3:0/11::gentoo, installed)
    sys-devel/libtool required by (net-misc/wget-1.14:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (sys-apps/groff-1.22.2:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (dev-libs/iniparser-3.1:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (media-gfx/graphviz-2.40.1-r1:0/0::gentoo, ebuild scheduled for merge)
    sys-devel/libtool required by (app-misc/tmux-1.8:0/0::gentoo, installed)
    sys-devel/libtool required by (dev-libs/libxslt-1.1.28-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (net-misc/openssh-6.4_p1-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (net-misc/curl-7.34.0-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (dev-db/postgresql-9.3.2:9.3/9.3::gentoo, installed)
    sys-devel/libtool required by (sys-apps/kmod-15-r1:0/0::gentoo, installed)
    sys-devel/libtool required by (dev-libs/iniparser-3.1:0/0::gentoo, installed)
    >=sys-devel/libtool-2.2.6b required by (sys-process/psmisc-22.20:0/0::gentoo, installed)
    sys-devel/libtool required by (app-admin/syslog-ng-3.4.2:0/0::gentoo, installed)
    sys-devel/libtool required by (sys-apps/the_silver_searcher-0.14:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (dev-libs/libxml2-2.9.8:2/2::gentoo, ebuild scheduled for merge)
    sys-devel/libtool required by (sys-process/htop-1.0.2:0/0::gentoo, installed)
    >=sys-devel/libtool-2 required by (sys-libs/pam-1.1.6-r2:0/0::gentoo, installed)
    sys-devel/libtool required by (sys-libs/pam-1.1.6-r2:0/0::gentoo, installed)
    sys-devel/libtool required by (dev-libs/glib-2.36.4-r1:2/2::gentoo, installed)
    sys-devel/libtool required by (sys-fs/ncdu-1.9:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (media-libs/fontconfig-2.13.0-r4:1.0/1.0::gentoo, ebuild scheduled for merge)

  (sys-libs/ncurses-5.9-r2:5/5::gentoo, installed) pulled in by
    >=sys-libs/ncurses-5.7-r7[unicode] required by (sys-process/procps-3.3.8-r2:0/0::gentoo, installed)
    sys-libs/ncurses[unicode] required by (sys-fs/ncdu-1.9:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


!!! The following installed packages are masked:
- sys-devel/binutils-2.23.2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-devel/gcc-4.7.3-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/releases/17.0/package.mask:
# Andreas K. Huettel <dilfridge@gentoo.org> (27 May 2017)
# In the 17.0 profiles we assume that our system compiler uses C++14
# or later as default language setting. This means it has to be at
# least GCC 6. If you need an older compiler for specific purposes,
# feel free to unmask it, however, using it for normal emerging of
# packages is neither recommended nor supported in any way.

- sys-libs/glibc-2.17::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


OK. I install Webmin like this:

Code:
[root@yourhost /]# cd /tmp
[root@yourhost /tmp]# wget http://prdownloads.sourceforge.net/webadmin/webmin-1.900.tar.gz

When unpacked, the distribution creates a subdirectory called webmin-1.900 under the current directory. Since recent versions of Webmin support installation into a directory of your choice, you can pick a destination directory such as /usr/local/webmin. Then run the following commands in the directory containing the webmin-1.900.tar.gz file :
Code:
[root@yourhost /tmp]# gunzip webmin-1.900.tar.gz
[root@yourhost /tmp]# tar xf webmin-1.900.tar
[root@yourhost /tmp]# cd webmin-1.900
[root@yourhost /tmp/webmin-1.900]# ./setup.sh /usr/local/webmin


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21782
Location: here

PostPosted: Mon Jan 14, 2019 3:38 pm    Post subject: Reply with quote

Code:
sh bash 4.2_p45
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash: 4.2_p45::gentoo
dev-lang/perl: 5.16.3::gentoo
dev-lang/python: 2.7.5-r3::gentoo, 3.3.3::gentoo
dev-util/pkgconfig: 0.28::gentoo
sys-apps/baselayout: 2.2::gentoo
sys-apps/openrc: 0.12.4::gentoo
sys-apps/sandbox: 2.6-r1::gentoo
sys-devel/autoconf: 2.69::gentoo
sys-devel/automake: 1.13.4::gentoo, 1.15::gentoo
sys-devel/binutils: 2.23.2::gentoo
sys-devel/gcc: 4.7.3-r1::gentoo
sys-devel/gcc-config: 1.7.3::gentoo
sys-devel/libtool: 2.4.2::gentoo
sys-devel/make: 3.82-r4::gentoo
sys-kernel/linux-headers: 3.9::gentoo (virtual/os-headers)
sys-libs/glibc: 2.17::gentoo

It's time to update your gentoo box
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13848

PostPosted: Tue Jan 15, 2019 3:13 am    Post subject: Re: Installing webmin on gentoo Reply with quote

quillo wrote:
OK. I install Webmin like this:
Code:
[root@yourhost /]# cd /tmp
[root@yourhost /tmp]# wget http://prdownloads.sourceforge.net/webadmin/webmin-1.900.tar.gz

When unpacked, the distribution creates a subdirectory called webmin-1.900 under the current directory. Since recent versions of Webmin support installation into a directory of your choice, you can pick a destination directory such as /usr/local/webmin. Then run the following commands in the directory containing the webmin-1.900.tar.gz file :
Code:
[root@yourhost /tmp]# gunzip webmin-1.900.tar.gz
[root@yourhost /tmp]# tar xf webmin-1.900.tar
[root@yourhost /tmp]# cd webmin-1.900
[root@yourhost /tmp/webmin-1.900]# ./setup.sh /usr/local/webmin
Please never do this. Installing packages outside of Portage is at best a mess for you to clean up later, and at worst will overwrite files owned by a Portage-managed package. In this case, you probably avoided trouble by sending it to a dedicated directory, assuming it actually respects that directory. In general, you should not run arbitrary installers as root. You should especially avoid this pattern of downloading an unsigned blob and running code from it as root.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum