Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] libtbb / UPBGE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
statikregimen
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jul 2011
Posts: 131
Location: USA/Michigan

PostPosted: Thu Jan 31, 2019 3:05 pm    Post subject: [SOLVED] libtbb / UPBGE Reply with quote

Not really sure where to start - if this is a me/Gentoo issue or an UPBGE issue.

I get the following error when trying to run UPBGE:

Code:
./blender: error while loading shared libraries: libtbb.so.2: cannot open shared object file: No such file or directory


I cannot seem to find any package for Gentoo that provides libtbb...only some vague mentions of it that have lead me nowhere. Actually, so far, I can't even find the source for it. Just packages for other distributions. Steam provides at least 1 copy, which I tried putting in /usr/lib64/ but UPBGE then said wrong ELF class, which I assume to mean either wrong version or it's a 32-bit version.

So if anybody can shed some light on this elusive library, I thank you in advance!

Fun fact: usually I find the answer shortly after I give up and post something....I wonder if I just jinxed that?

EDIT: Nope! Works almost every time! https://github.com/01org/tbb/
_________________
Links of me:
https://bitbucket.org/experimentfailed/
https://experimentfailed.bandcamp.com/


Last edited by statikregimen on Thu Jan 31, 2019 3:22 pm; edited 2 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21688
Location: here

PostPosted: Thu Jan 31, 2019 3:13 pm    Post subject: Reply with quote

A good tool to find which package provides a file is http://www.portagefilelist.de/site/query, the result seems dev-cpp/tbb
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
statikregimen
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jul 2011
Posts: 131
Location: USA/Michigan

PostPosted: Thu Jan 31, 2019 3:24 pm    Post subject: Reply with quote

fedeliallalinea - thanks! I run into this sometimes and it can be frustrating - very good tip.

So now I have two solutions:

1- Compile from the source linked in the original post (that actually worked...often times, compiling from source outside of Portage ends in tears for me)
2- Install dev-cpp/tbb via Portage like someone who's not completely noob (and to be sure, I also tested this and it worked w/ UPBGE)
_________________
Links of me:
https://bitbucket.org/experimentfailed/
https://experimentfailed.bandcamp.com/
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13739

PostPosted: Fri Feb 01, 2019 2:56 am    Post subject: Reply with quote

What is UPBGE? Where did you get it? Does its maintainer need to be notified to add this package as a dependency (either in the documentation or preferably in an ebuild)?
Back to top
View user's profile Send private message
statikregimen
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jul 2011
Posts: 131
Location: USA/Michigan

PostPosted: Fri Feb 01, 2019 3:04 am    Post subject: Reply with quote

UPBGE is an unsupported program (a fork of the Blender project) obtained from the UPBGE home page. I assumed anybody who could help would know what it is or would know what TBB is or how to install it (I was kinda right!). I will likely submit a bug report to UPBGE so that hopefully they can update their installation documentation or include a binary of TBB in the future.

Thanks!

Edit: https://github.com/UPBGE/blender/issues/1007
_________________
Links of me:
https://bitbucket.org/experimentfailed/
https://experimentfailed.bandcamp.com/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum