Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]QT qvideowidget MultimediaWidgeds
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ON7AMI
n00b
n00b


Joined: 26 Feb 2019
Posts: 11
Location: Belgium

PostPosted: Tue Feb 26, 2019 4:04 pm    Post subject: [Solved]QT qvideowidget MultimediaWidgeds Reply with quote

Hello,

I'm using a QVideoWidget in Qt on a raspberry Pi running Gentoo and qmake gives an error that MultimediaWidgets are not found.
Quote:
[Project ERROR: Unknown module(s) in QT: multimediawidgets]


Is there someone who can tell me in what emerge package I can find this lib?

I have dev-qt/qmultimedia installed but this does not contain the multimedia widgets

P.S. on Windows and on Debian on a intel 64bit machine the program compiles (and works fine)

tnx in advance
Jean Paul


Last edited by ON7AMI on Thu Feb 28, 2019 1:45 pm; edited 2 times in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Tue Feb 26, 2019 5:12 pm    Post subject: Reply with quote

Did you build qtmultimedia with USE=widgets?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ON7AMI
n00b
n00b


Joined: 26 Feb 2019
Posts: 11
Location: Belgium

PostPosted: Wed Feb 27, 2019 8:37 am    Post subject: Reply with quote

asturm wrote:
Did you build qtmultimedia with USE=widgets?


Help, what did I miss? I just entered
Code:
emerge --ask dev-qt/qtmultimedia

As I understand from the handbook that was all I had to do

If I have to build things, can you tell me where the sources are and how to build them, I'm new to Gentoo (I'm a Debian user)

tnx
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22153
Location: here

PostPosted: Wed Feb 27, 2019 8:41 am    Post subject: Reply with quote

You should check if package dev-qt/qtmultimedia has activated widgets use flag, you can see it with
Code:
$ emerge -pv dev-qt/qtmultimedia

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-qt/qtmultimedia-5.11.3:5/5.11::gentoo  USE="alsa gstreamer pulseaudio qml widgets -debug (-gles2) -openal -test" 0 KiB

In my case widgets use flag is set, if in your case isn't set use package.use for enable it
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ON7AMI
n00b
n00b


Joined: 26 Feb 2019
Posts: 11
Location: Belgium

PostPosted: Wed Feb 27, 2019 9:17 am    Post subject: Reply with quote

fedeliallalinea wrote:
You should check if package dev-qt/qtmultimedia has activated widgets use flag, you can see it with
[code]$ emerge -pv dev-qt/qtmultimedia


Two new problems, i feel like a first swim...

1) /etc/portage/package.use is a directory, as I understand I can make a file per packet but how do I have to name the file and do I have to make a subdir dev-qt?

2) Overnight there is a new version 5.11.3 and there seems to be a conflict with my other qtqui modules who are still 5.11.2 and a emerge --sync did'nt solve this
can I force the use of 5.11.2 or upgrade all the other libs to 5.11.3

tnx a lot.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22153
Location: here

PostPosted: Wed Feb 27, 2019 9:53 am    Post subject: Reply with quote

ON7AMI wrote:
1) /etc/portage/package.use is a directory, as I understand I can make a file per packet but how do I have to name the file and do I have to make a subdir dev-qt?

you can choose the name you want (without subdir).

ON7AMI wrote:
2) Overnight there is a new version 5.11.3 and there seems to be a conflict with my other qtqui modules who are still 5.11.2 and a emerge --sync did'nt solve this
can I force the use of 5.11.2 or upgrade all the other libs to 5.11.3

You can use version that you want but all installed qt packages must have same version (you cannot mix qt version).
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ON7AMI
n00b
n00b


Joined: 26 Feb 2019
Posts: 11
Location: Belgium

PostPosted: Wed Feb 27, 2019 10:12 am    Post subject: Reply with quote

fedeliallalinea wrote:

you can choose the name you want (without subdir).

OK, this worked fine

fedeliallalinea wrote:

You can use version that you want but all installed qt packages must have same version (you cannot mix qt version).


If I ask for version 5.11.2 I get this error:
Code:
demouser@pi64 ~/MediaPlayer $ sudo emerge =dev-qt/qtmultimedia-5.11.2

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!

!!! All ebuilds that could satisfy "=dev-qt/qtmultimedia-5.11.2" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-qt/qtmultimedia-5.11.2::gentoo (masked by: )

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


If I give no version, I get this error(s):
Code:
demouser@pi64 ~/MediaPlayer $ sudo emerge --ask dev-qt/qtmultimedia

Local copy of remote index is up-to-date and will be used.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[binary     U  ] dev-libs/double-conversion-3.0.3 [3.0.0-r1]
[binary     U  ] dev-qt/qtcore-5.11.3-r2 [5.11.2-r1]
[binary     U  ] dev-qt/qtnetwork-5.11.3 [5.11.2]
[binary     U  ] dev-qt/qtdbus-5.11.3 [5.11.2]
[binary     U  ] dev-qt/qtgui-5.11.3 [5.11.2-r1]
[binary     U  ] dev-qt/qtwidgets-5.11.3 [5.11.2]
[binary     U  ] dev-qt/qtopengl-5.11.3 [5.11.2]
[ebuild     U  ] dev-qt/qtmultimedia-5.11.3 [5.11.2] USE="widgets*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.3-r2:5/5.11::gentoo, binary scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.11.3 required by (dev-qt/qtgui-5.11.3:5/5.11::gentoo, binary scheduled for merge)
    ^              ^^^^^^                                                                                                           
    (and 5 more with the same problem)

  (dev-qt/qtcore-5.11.2-r1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.11.2 required by (dev-qt/qtdeclarative-5.11.2:5/5.11::gentoo, installed)
    ^              ^^^^^^                                                                                                           
    (and 19 more with the same problem)

dev-libs/double-conversion:0

  (dev-libs/double-conversion-3.0.3:0/2::gentoo, binary scheduled for merge) pulled in by
    dev-libs/double-conversion:0/2= required by (dev-qt/qtcore-5.11.3-r2:5/5.11::gentoo, binary scheduled for merge)
                              ^^^^^                                                                                                 

  (dev-libs/double-conversion-3.0.0-r1:0/1::gentoo, installed) pulled in by
    dev-libs/double-conversion:0/1= required by (dev-qt/qtcore-5.11.2-r1:5/5.11::gentoo, installed)
                              ^^^^^                                                                                                 

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.11.3:5/5.11::gentoo, binary scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.11.3[gles2=] required by (dev-qt/qtmultimedia-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^                                                                                                       
    (and 1 more with the same problem)

  (dev-qt/qtwidgets-5.11.2:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.11.2[-gles2] required by (dev-qt/qtprintsupport-5.11.2:5/5.11::gentoo, installed)
    ^                 ^^^^^^                                                                                                       
    (and 5 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.11.3:5/5.11::gentoo, binary scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.11.3[-gles2] required by (dev-qt/qtopengl-5.11.3:5/5.11::gentoo, binary scheduled for merge)
    ^             ^^^^^^                                                                                                           
    (and 3 more with the same problem)

  (dev-qt/qtgui-5.11.2-r1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.11.2[-gles2,png,xcb] required by (dev-qt/qtwidgets-5.11.2:5/5.11::gentoo, installed)
    ^             ^^^^^^                                                                                                           
    (and 10 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.11.3:5/5.11::gentoo, binary scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.11.3 required by (dev-qt/qtgui-5.11.3:5/5.11::gentoo, binary scheduled for merge)
    ^              ^^^^^^                                                                                                           

  (dev-qt/qtdbus-5.11.2:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.11.2 required by (dev-qt/qtgui-5.11.2-r1:5/5.11::gentoo, installed)
    ^              ^^^^^^                                                                                                           
    (and 1 more with the same problem)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.11.3:5/5.11::gentoo, binary scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.11.3 required by (dev-qt/qtmultimedia-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^                                                                                                       

  (dev-qt/qtnetwork-5.11.2:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtnetwork-5.11.2 required by (dev-qt/qtdeclarative-5.11.2:5/5.11::gentoo, installed)
    ^                 ^^^^^^                                                                                                       
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (dev-qt/qtcore-5.11.2-r1:5/5.11::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Can I still repair those by upgrading the whole system or do I better reinstall a new image?

Or have you other suggestions?

------------
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22153
Location: here

PostPosted: Wed Feb 27, 2019 10:55 am    Post subject: Reply with quote

Try to update to 5.11.3 with
Code:
# emerge -uDa dev-qt/qtmultimedia

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ON7AMI
n00b
n00b


Joined: 26 Feb 2019
Posts: 11
Location: Belgium

PostPosted: Wed Feb 27, 2019 12:02 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Try to update to 5.11.3 with
Code:
# emerge -uDa dev-qt/qtmultimedia


Almost the same kind of errors, only a much longer list:

Code:
demouser@pi64 ~/MediaPlayer $ sudo emerge -uDa dev-qt/qtmultimedia

Local copy of remote index is up-to-date and will be used.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[binary     U  ] dev-qt/qtchooser-66 [0_p20170803]
[binary     U  ] x11-libs/libdrm-2.4.97 [2.4.96]
[binary     U  ] sys-apps/debianutils-4.8.6.1 [4.8.6]
[binary     U  ] sys-devel/llvm-common-7.0.1 [7.0.0]
[binary     U  ] media-gfx/graphite2-1.3.13 [1.3.12-r1]
[binary     U  ] dev-libs/double-conversion-3.0.3 [3.0.0-r1]
[binary     U  ] app-crypt/openpgp-keys-gentoo-release-20190102 [20180706]
[binary     U  ] sys-apps/sandbox-2.15 [2.13]
[binary     U  ] app-misc/pax-utils-1.2.4 [1.2.3-r3]
[binary     U  ] media-libs/alsa-lib-1.1.8 [1.1.7]
[binary     U  ] media-libs/libpng-1.6.36 [1.6.35-r1]
[binary     U  ] app-misc/ca-certificates-20190110.3.42.1 [20180409.3.37]
[binary     U  ] x11-libs/libXau-1.0.9 [1.0.8-r1]
[binary     U  ] net-dns/libidn2-2.1.1a [2.0.5]
[binary     U  ] dev-libs/nettle-3.4.1 [3.4]
[binary     U  ] app-portage/portage-utils-0.74 [0.73]
[binary     U  ] net-libs/gnutls-3.6.6 [3.5.19-r1]
[binary     U  ] sys-libs/binutils-libs-2.31.1-r3 [2.31.1-r1]
[binary     U  ] sys-devel/binutils-2.31.1-r4 [2.31.1-r1] USE="gold%* plugins%* -default-gold%"
[binary     U  ] app-text/qpdf-8.4.0 [8.2.1]
[binary     U  ] net-nds/openldap-2.4.45-r1 [2.4.45]
[binary     U  ] sys-apps/sed-4.7 [4.5]
[binary     U  ] x11-libs/libxkbcommon-0.8.3 [0.8.2]
[binary     U  ] app-arch/tar-1.30-r1 [1.30]
[binary     U  ] net-misc/curl-7.64.0 [7.62.0]
[binary     U  ] app-admin/eselect-1.4.14 [1.4.13]
[binary     U  ] sys-libs/readline-8.0 [7.0_p5]
[binary     U  ] dev-db/sqlite-3.26.0 [3.25.3] USE="secure-delete*"
[binary     U  ] app-shells/bash-5.0_p2 [4.4_p23]
[binary     U  ] dev-libs/libxml2-2.9.9 [2.9.8] PYTHON_TARGETS="(-python3_7)"
[binary     U  ] dev-util/glib-utils-2.58.3 [2.56.2]
[binary     U  ] dev-python/certifi-2018.11.29 [2018.8.24]
[binary     U  ] dev-python/setuptools-40.6.3 [40.6.2]
[binary     U  ] dev-lang/perl-5.28.0 [5.26.2]
[binary     U  ] virtual/perl-Test-Harness-3.420.0 [3.380.0]
[binary     U  ] virtual/perl-Data-Dumper-2.170.0 [2.167.0]
[binary     U  ] virtual/perl-Carp-1.500.0 [1.420.0]
[binary     U  ] virtual/perl-Exporter-5.730.0 [5.720.0-r3]
[binary     U  ] virtual/perl-Encode-2.970.0 [2.880.0]
[binary     U  ] virtual/perl-Scalar-List-Utils-1.500.0 [1.460.200_rc]
[binary     U  ] virtual/perl-File-Spec-3.740.0 [3.670.0]
[binary     U  ] virtual/perl-IO-1.390.0 [1.380.0]
[binary     U  ] virtual/perl-Compress-Raw-Zlib-2.76.0 [2.74.0]
[binary     U  ] virtual/perl-XSLoader-0.300.0 [0.270.0]
[binary     U  ] virtual/perl-libnet-3.110.0 [3.100.0]
[binary     U  ] virtual/perl-Storable-3.80.0 [2.620.0]
[binary     U  ] virtual/perl-IO-Socket-IP-0.390.0 [0.380.0]
[binary     U  ] virtual/perl-Time-HiRes-1.975.900 [1.974.100-r2]
[binary     U  ] dev-perl/Net-SSLeay-1.850.0 [1.820.0]
[binary     U  ] media-libs/mesa-19.0.0_rc4 [18.3.0_rc4]
[binary     U  ] virtual/perl-File-Path-2.150.0 [2.130.0]
[uninstall     ] perl-core/File-Path-2.130.0
[blocks b      ] <perl-core/File-Path-2.150.0 ("<perl-core/File-Path-2.150.0" is blocking virtual/perl-File-Path-2.150.0)
[binary     U  ] sys-fs/eudev-3.2.7-r1 [3.2.7]
[binary     U  ] sys-apps/util-linux-2.33.1 [2.33]
[binary     U  ] dev-libs/glib-2.58.3 [2.56.2] USE="-gtk-doc%"
[binary     U  ] virtual/pkgconfig-1 [0-r1]
[uninstall     ] dev-util/gdbus-codegen-2.56.2-r1
[blocks b      ] <dev-util/gdbus-codegen-2.58.3 ("<dev-util/gdbus-codegen-2.58.3" is blocking dev-libs/glib-2.58.3)
[binary     U  ] dev-qt/qtcore-5.11.3-r2 [5.11.2-r1]
[binary     U  ] dev-libs/atk-2.30.0 [2.28.1] USE="-gtk-doc%"
[binary     U  ] dev-util/gtk-update-icon-cache-3.24.3 [3.24.0]
[binary     U  ] dev-libs/libinput-1.12.6 [1.12.1]
[binary     U  ] x11-themes/gnome-themes-standard-3.22.3-r1 [3.22.3]
[binary     U  ] dev-qt/qtnetwork-5.11.3 [5.11.2]
[binary     U  ] sys-apps/dbus-1.12.12 [1.12.10]
[binary     U  ] dev-qt/qtdbus-5.11.3 [5.11.2]
[binary     U  ] app-accessibility/at-spi2-core-2.30.0 [2.26.2] USE="-gtk-doc% -test%"
[binary     U  ] app-accessibility/at-spi2-atk-2.30.0 [2.26.2]
[binary     U  ] media-libs/harfbuzz-2.3.1 [2.1.3]
[binary     U  ] dev-qt/qtgui-5.11.3 [5.11.2-r1]
[binary     U  ] x11-libs/pango-1.42.4-r1 [1.42.4]
[binary     U  ] gnome-base/librsvg-2.40.20 [2.40.18] USE="vala*"
[binary     U  ] app-text/poppler-0.74.0 [0.68.0]
[binary     U  ] x11-themes/adwaita-icon-theme-3.30.1 [3.26.1]
[binary     U  ] net-print/cups-2.2.10 [2.2.9]
[binary     U  ] x11-libs/gtk+-3.24.5 [3.24.1] USE="-gtk-doc%"
[binary     U  ] dev-qt/qtwidgets-5.11.3 [5.11.2]
[binary     U  ] app-crypt/gcr-3.28.1 [3.28.0]
[binary     U  ] net-print/cups-filters-1.22.1 [1.21.4]
[binary     U  ] dev-qt/qtopengl-5.11.3 [5.11.2]
[ebuild     U  ] dev-qt/qtmultimedia-5.11.3 [5.11.2] USE="widgets*"
[binary     U  ] x11-themes/gtk-engines-adwaita-3.28 [3.22.3]
[binary     U  ] app-crypt/libsecret-0.18.7 [0.18.6-r1]
[binary     U  ] app-crypt/gnupg-2.2.12 [2.2.11]
[binary     U  ] sys-apps/portage-2.3.61 [2.3.52-r1]
[binary     U  ] app-admin/perl-cleaner-2.27 [2.26-r1]
[binary     U  ] sys-auth/polkit-0.115-r2 [0.115-r1]
[binary     U  ] net-misc/openssh-7.9_p1-r2 [7.9_p1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

  (sys-libs/readline-8.0:0/8::gentoo, binary scheduled for merge) pulled in by
    sys-libs/readline:0/8= required by (dev-db/sqlite-3.26.0:3/3::gentoo, binary scheduled for merge)
                     ^^^^^                                                                                                         
    >=sys-libs/readline-8.0:0/8= required by (app-shells/bash-5.0_p2:0/0::gentoo, binary scheduled for merge)
    ^^                  ^^^^^^^^                                                                                                   
    (and 3 more with the same problems)

  (sys-libs/readline-7.0_p5:0/7::gentoo, installed) pulled in by
    sys-libs/readline:0/7= required by (net-fs/samba-4.9.2-r1:0/0::gentoo, installed)
                     ^^^^^
    sys-libs/readline:0/7= required by (sys-fs/lvm2-2.02.181:0/0::gentoo, installed)
                     ^^^^^
    sys-libs/readline:0/7= required by (net-wireless/wpa_supplicant-2.6-r3:0/0::gentoo, installed)
                     ^^^^^                                                                                                         
    >=sys-libs/readline-6.2_p5-r1:0/7= required by (dev-db/unixODBC-2.3.7:0/0::gentoo, installed)
                                 ^^^^^                                                                                             
    (and 17 more with the same problems)

dev-lang/perl:0

  (dev-lang/perl-5.28.0:0/5.28::gentoo, binary scheduled for merge) pulled in by
    dev-lang/perl:0/5.28= required by (virtual/perl-Time-HiRes-1.975.900:0/0::gentoo, binary scheduled for merge)
                 ^^^^^^^^                                                                                                           
    =dev-lang/perl-5.28* required by (virtual/perl-Digest-MD5-2.550.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                           
    (and 35 more with the same problems)

  (dev-lang/perl-5.26.2:0/5.26::gentoo, installed) pulled in by
    dev-lang/perl:0/5.26= required by (net-irc/irssi-1.1.1-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.26= required by (net-fs/samba-4.9.2-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.26* required by (virtual/perl-Digest-SHA-5.960.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                           
    dev-lang/perl:0/5.26= required by (dev-perl/HTTP-Negotiate-6.10.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    (and 52 more with the same problems)

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.3-r2:5/5.11::gentoo, binary scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.11.3 required by (dev-qt/qtwidgets-5.11.3:5/5.11::gentoo, binary scheduled for merge)
    ^              ^^^^^^                                                                                                           
    (and 5 more with the same problem)

  (dev-qt/qtcore-5.11.2-r1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.11.2 required by (dev-qt/qtprintsupport-5.11.2:5/5.11::gentoo, installed)
    ^              ^^^^^^                                                                                                           
    (and 19 more with the same problem)

dev-libs/double-conversion:0

  (dev-libs/double-conversion-3.0.3:0/2::gentoo, binary scheduled for merge) pulled in by
    dev-libs/double-conversion:0/2= required by (dev-qt/qtcore-5.11.3-r2:5/5.11::gentoo, binary scheduled for merge)
                              ^^^^^                                                                                                 

  (dev-libs/double-conversion-3.0.0-r1:0/1::gentoo, installed) pulled in by
    dev-libs/double-conversion:0/1= required by (dev-qt/qtcore-5.11.2-r1:5/5.11::gentoo, installed)
                              ^^^^^                                                                                                 

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.11.3:5/5.11::gentoo, binary scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.11.3[gles2=] required by (dev-qt/qtmultimedia-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^                                                                                                       
    (and 1 more with the same problem)

  (dev-qt/qtwidgets-5.11.2:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.11.2[-gles2] required by (dev-qt/qtprintsupport-5.11.2:5/5.11::gentoo, installed)
    ^                 ^^^^^^                                                                                                       
    (and 5 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.11.3:5/5.11::gentoo, binary scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.11.3[dbus] required by (dev-qt/qtwidgets-5.11.3:5/5.11::gentoo, binary scheduled for merge)
    ^             ^^^^^^                                                                                                           
    (and 3 more with the same problem)

  (dev-qt/qtgui-5.11.2-r1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.11.2[-gles2] required by (dev-qt/qtdeclarative-5.11.2:5/5.11::gentoo, installed)
    ^             ^^^^^^                                                                                                           
    (and 10 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.11.3:5/5.11::gentoo, binary scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.11.3 required by (dev-qt/qtgui-5.11.3:5/5.11::gentoo, binary scheduled for merge)
    ^              ^^^^^^                                                                                                           

  (dev-qt/qtdbus-5.11.2:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.11.2 required by (dev-qt/qtbluetooth-5.11.2:5/5.11::gentoo, installed)
    ^              ^^^^^^                                                                                                           
    (and 1 more with the same problem)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.11.3:5/5.11::gentoo, binary scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.11.3 required by (dev-qt/qtmultimedia-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^                                                                                                       

  (dev-qt/qtnetwork-5.11.2:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtnetwork-5.11.2 required by (dev-qt/qtxmlpatterns-5.11.2:5/5.11::gentoo, installed)
    ^                 ^^^^^^                                                                                                       
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (net-wireless/wpa_supplicant-2.6-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (net-fs/samba-4.9.2-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (sys-fs/lvm2-2.02.181:0/0::gentoo, installed): ebuild is masked or unavailable
  (net-irc/irssi-1.1.1-r2:0/0::gentoo, installed): ebuild is masked or unavailable
  (dev-qt/qtcore-5.11.2-r1:5/5.11::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


I tried the suggestion --backtrack=30 to but no solvation.

-------
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22153
Location: here

PostPosted: Wed Feb 27, 2019 12:59 pm    Post subject: Reply with quote

You have many packages not updated, first probably is better update whole system.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ON7AMI
n00b
n00b


Joined: 26 Feb 2019
Posts: 11
Location: Belgium

PostPosted: Wed Feb 27, 2019 1:24 pm    Post subject: Reply with quote

fedeliallalinea wrote:
You have many packages not updated, first probably is better update whole system.


I did an new
Code:
# emerge --sync

followed by
Code:
# emerge -avuDN --with-bdeps y --keep-going world


I will see if I then can build the lib. It seems that the RPi distro is not compleet up to date
The later emerge seems to take a while, I keep you informed.

Thanks for the patience.
JP
Back to top
View user's profile Send private message
ON7AMI
n00b
n00b


Joined: 26 Feb 2019
Posts: 11
Location: Belgium

PostPosted: Thu Feb 28, 2019 11:49 am    Post subject: Reply with quote

fedeliallalinea wrote:
You have many packages not updated, first probably is better update whole system.


The full update did solve the problem. So thanks a lot for your accompaniment, I learned a lot and I start to love this distribution on Raspberry Pi

I could build now with FLAG= gles2 qstreamer qml widgets

My program works fine now, but when I play a video with SMPlayer in full screen it runs smooth but when I play the same video in a QT MultimediaWidget I miss a lot of frames. Perhaps you have some ideas? If not I launch a new topic.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22153
Location: here

PostPosted: Thu Feb 28, 2019 12:21 pm    Post subject: Reply with quote

ON7AMI wrote:
My program works fine now, but when I play a video with SMPlayer in full screen it runs smooth but when I play the same video in a QT MultimediaWidget I miss a lot of frames. Perhaps you have some ideas? If not I launch a new topic.

This is too specific question for me, I'd have no idea what to advise you.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ON7AMI
n00b
n00b


Joined: 26 Feb 2019
Posts: 11
Location: Belgium

PostPosted: Thu Feb 28, 2019 12:27 pm    Post subject: Reply with quote

fedeliallalinea wrote:
This is too specific question for me, I'd have no idea what to advise you.


Never the mind, I go to stalk the QT guru's :-) to ask if I can force the widged to use an accelerated driver.

I want to thank you for your kindly help, without it, it would have taken days of manual reading and searching.

Greets
JP
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum