Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Difficulty installing VPNSecure - "libgconf-2.so.4"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
walterbyrd
n00b
n00b


Joined: 26 Apr 2017
Posts: 48

PostPosted: Sat Mar 09, 2019 11:12 pm    Post subject: Difficulty installing VPNSecure - "libgconf-2.so.4&quo Reply with quote

Code:

# uname -a
Linux fir 4.19.24-calculate #1 SMP PREEMPT Thu Feb 21 14:59:17 UTC 2019 x86_64 AMD Athlon(tm) II X4 640 Processor AuthenticAMD GNU/Linux



Note: this is Calculate Linux. It is supposed to be Gentoo under the hood. I find these forums more active than the Calculate forums. Next time, I will use straight up Gentoo.


These are the instructions:
https://support.vpnsecure.me/articles/getting-started/linux-vpnsecure-client-install

Other than this library, the install seemed to work. I thought I would be able to install the library with emerge, but that did not seem to work.

Code:


# ./etc/vpnsecure/vpnsecure
./vpnsecure: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory

# emerge libgconf-2.so.4

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "libgconf-2.so.4".

emerge: searching for similar names... nothing similar found.


Can I just download libgconf-2.so.4 directly into the /lib directory?

Should I emerge gnome-base/gconf ?

I am use MATE desktop.
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 487
Location: Estonia

PostPosted: Sat Mar 09, 2019 11:22 pm    Post subject: Reply with quote

Yes, gnome-base/gconf is what provides that deprecated library (GSettings in dev-libs/glib itself is the modern replacement, with gnome-base/dconf providing the non-volatile settings storage commonly). Unfortunately that VPN thing of yours still needs it.
Do you really need to use that apparently closed source VPN thing instead of an open source option?
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
walterbyrd
n00b
n00b


Joined: 26 Apr 2017
Posts: 48

PostPosted: Tue Mar 12, 2019 7:44 pm    Post subject: Reply with quote

Thanks for the help, VPNSecure installed.

As to why I bought VPNSecure: sometime ago I bought a course from Slashdot deals, for $29. I did not like the course right away, so I asked for a refund. They absolutely refused. They said all I could do is use the $29 towards something else they sell. I was, and still am, very unhappy with that. But, rather than throw the money away, I found a lifetime subscription to VPNSecure for $35. I threw in another $6 and got it. FWIW: I strongly advise against doing business with Slashdot deals.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum