Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
MacBook cant boot up.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
moevot
n00b
n00b


Joined: 15 Mar 2019
Posts: 23

PostPosted: Tue Mar 19, 2019 6:28 pm    Post subject: MacBook cant boot up. Reply with quote

So i was moving from xfce4 to i3 to see what the hype is all about and i accidentally unistalled my session selector(qingy). figured out how to use the rescue cd to reinstall but now my computer just wont boot up. it hangs in the classic macbook blinking folder w/ question mark icon(because it cant find a bootable device). I thought it might be a problem with grub2 so i reinstalled it and just got more problems. i'd run
Code:
grub-install --efi-directory=/boot/efi/


while specifying the path for boot/efi/gentoo and still got errors saying it couldn't find the files even though they are all there. I said screw and rebooted thinking it must be some reee error that doesnt matter. Still cant boot. Anyone know a thing about the cancer that is a macbook?
Back to top
View user's profile Send private message
Muso
l33t
l33t


Joined: 22 Oct 2002
Posts: 981
Location: The Holy city of Honolulu

PostPosted: Tue Mar 19, 2019 8:40 pm    Post subject: Reply with quote

Did you mount boot?
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Back to top
View user's profile Send private message
moevot
n00b
n00b


Joined: 15 Mar 2019
Posts: 23

PostPosted: Thu Mar 21, 2019 1:58 am    Post subject: Reply with quote

yes i have mounted all necessary file-systems. I may have figured it out. I was talking to a friend and he told me that the SystemRescueCd cant load efivars for some reason so i will try to us an actual gentoo install disk.
Back to top
View user's profile Send private message
Rockford The Roe
n00b
n00b


Joined: 21 Mar 2019
Posts: 15
Location: Illinois

PostPosted: Tue Apr 16, 2019 2:48 pm    Post subject: Reply with quote

moevot wrote:
yes i have mounted all necessary file-systems. I may have figured it out. I was talking to a friend and he told me that the SystemRescueCd cant load efivars for some reason so i will try to us an actual gentoo install disk.


Are you sure you are using the latest version of sysrescuecd? Because when I installed it, I had no problems installing grub with
Code:
grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=GRUB
.
_________________
"UNIX is very simple, it just needs a genius to understand its simplicity." -Dennis Ritchie
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum