Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Touchpad not recognized (ASUS GL702ZC) [New issue]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
silverbluep
n00b
n00b


Joined: 28 Jan 2019
Posts: 3
Location: USA

PostPosted: Sun Mar 24, 2019 11:33 pm    Post subject: Touchpad not recognized (ASUS GL702ZC) [New issue] Reply with quote

EDIT: As per usual, I was trying a couple config options, and the problem decides to fix itself, great! (I don't know exactly which config option did it, but might try to find out through process of elimination) But now, my onscreen keyboard is not recognized during boot, which is bad cause I need to decrypt my drive (and I don't usually have a keyboard at hand) Once my login managel (sddm) loads all is well though. How should I diagnose this problem?

also, my libinput configuration seems not to work on gentoo; I dropped the following config at /etc/X11/xorg.conf.d, but the configuration options are not recognived

Code:

Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "TappingButtonMap" "lrm"
    Option "TappingDrag" "true"
    Option "AccelProfile" "adaptive"
    Option "DisableWhileTyping" "true"
    Option "NaturalScrolling" "true"
    Option "ScrollMethod" "twofinger"
EndSection


Hello. I have been trying to get Gentoo dual booting on my laptop; which is an Asus laptop with AMD CPU and GPU.

I had a few hiccups (mostly kernel driver issues) but I got almost everything working. Except my touchpad. My touchpad is not recognized by the kernel. Similar problem to this post. I am dual booting with arch linux.

On Arch Linux, my touchpad is usually recognized. Here are the output of dmesg

Code:

dmesg | grep -i elan
[   10.788383] i2c_hid i2c-ELAN1200:00: i2c-ELAN1200:00 supply vdd not found, using dummy regulator
[   10.788412] i2c_hid i2c-ELAN1200:00: Linked as a consumer to regulator.0
[   10.788415] i2c_hid i2c-ELAN1200:00: i2c-ELAN1200:00 supply vddl not found, using dummy regulator
[   10.816395] input: ELAN1200:00 04F3:3066 Mouse as /devices/platform/AMDI0010:03/i2c-0/i2c-ELAN1200:00/0018:04F3:3066.0004/input/input9
[   10.816466] input: ELAN1200:00 04F3:3066 Touchpad as /devices/platform/AMDI0010:03/i2c-0/i2c-ELAN1200:00/0018:04F3:3066.0004/input/input10
[   10.816523] hid-generic 0018:04F3:3066.0004: input,hidraw3: I2C HID v1.00 Mouse [ELAN1200:00 04F3:3066] on i2c-ELAN1200:00
[   11.003267] input: ELAN1200:00 04F3:3066 Touchpad as /devices/platform/AMDI0010:03/i2c-0/i2c-ELAN1200:00/0018:04F3:3066.0004/input/input13
[   11.003378] hid-multitouch 0018:04F3:3066.0004: input,hidraw3: I2C HID v1.00 Mouse [ELAN1200:00 04F3:3066] on i2c-ELAN1200:00


And when it does not recognize my touchpad, this is what it says (Usually a reboot fixes the problem)

Code:

dmesg | grep -i elan
[   10.725507] i2c_hid i2c-ELAN1200:00: HID over i2c has not been provided an Int IRQ
[   10.731428] i2c_hid: probe of i2c-ELAN1200:00 failed with error -22


And here is the corresponding part of /proc/bus/input/devices

Code:

I: Bus=0018 Vendor=04f3 Product=3066 Version=0100
N: Name="ELAN1200:00 04F3:3066 Touchpad"
P: Phys=i2c-ELAN1200:00
S: Sysfs=/devices/platform/AMDI0010:03/i2c-0/i2c-ELAN1200:00/0018:04F3:3066.0004/input/input13
U: Uniq=
H: Handlers=event9 mouse1
B: PROP=5
B: EV=1b
B: KEY=e520 10000 0 0 0 0
B: ABS=2e0800000000003
B: MSC=20


On gentoo, I can boot, but can't use the mouse. The commands I run produce no output

So far I have tried

Adding various parameters to my boot loader; i8042.reset i8042.nomux i8042.nopnp i8042.noloop as suggested here
Adding kernel config options from the first post of the first thread linked, along with many other options.

Here is my kernel config; I would appreciate if anyone could help out.

As long as we are talking kernel issues; I also have this short question. Is there any way to have genkernel output bzImage-genkernel-blabla or vmlinuz-genkernel-blabla instead of kernel-genkernel-blabla? I find this naming odd, and my boot loader (refind) plays much better (in terms of boot parameters) when linux kernels have vmlinuz or bzImage as the first string in their name.
Back to top
View user's profile Send private message
yorune
n00b
n00b


Joined: 17 Mar 2019
Posts: 3
Location: Poznan, Polska

PostPosted: Thu Mar 28, 2019 8:21 am    Post subject: Reply with quote

Hi!
I had the same problem ;) I my case I must enable CONFIG_I2C_DESIGNWARE and wrote INPUT_DEVICES="mouse keyboard synaptics libinput".
Also I have not got nothing in my XOrg (to my touchpad).

Best Wishes,
Yorune (Marcin)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum