Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Strange new error during bootup process
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 944

PostPosted: Wed Mar 27, 2019 2:41 am    Post subject: Strange new error during bootup process Reply with quote

Hi All:

Since March 22, I'm getting this at bootup:
* Executing: /lib/rc/sh/openrc-run.sh /lib/rc/sh/openrc-run.sh /etc/init.d/opentmpfiles-setup start
* Setting up tmpfiles.d entries ...
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
No such file or directory
[ !! ]
* ERROR: opentmpfiles-setup failed to start

There is information about this issue here:
https://wiki.archlinux.org/index.php/OpenRC#opentmpfiles-setup_failed_to_start

and more detailed info here:
https://github.com/OpenRC/opentmpfiles/issues/2

Now, the solution suggested was to do this:
"A workaround is to create an empty /etc/tmpfiles.d/journal-nocow.conf to override the settings."
Which I did:
jserinki7 /home/jserink # ls -l /etc/tmpfiles.d
total 4
-rw-r--r-- 1 root root 0 Mar 27 10:13 journal-nocow.conf
-rw-r--r-- 1 root root 29 Mar 25 21:40 screen.conf

That didn't fix it.

Anyone have some insite on why this is happening?

Cheers,
john
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 944

PostPosted: Mon Apr 15, 2019 12:26 am    Post subject: More info Reply with quote

Hi All:

Ok, here is something interesting....
the last entry in my /var/log/rc/log is this:
* Stopping local ...
[ ok ]
* Saving random seed ...
[ ok ]
* Stopping sshd ...
[ ok ]
* samba -> stop: smbd ...
[ ok ]
* samba -> stop: nmbd ...
[ ok ]
* Unmounting network filesystems ...
[ ok ]
* Stopping hddtemp daemon ...
[ ok ]
* Stopping gpm ...
[ ok ]
* Stopping cupsd ...
[ ok ]
* Stopping cronie ...
[ ok ]
* Stopping consolekit ...
[ ok ]
* Stopping metalog ...
[ ok ]
* Stopping bluetooth ...
[ ok ]
* Stopping dbus ...
[ ok ]
* Storing ALSA Mixer Levels ...
[ ok ]
* Unmounting loop devices
* Unmounting filesystems
* Unmounting /boot ...
[ ok ]
* Unmounting /var/tmp/portage ...
[ ok ]
* Deactivating swap devices ...
[ ok ]
* Setting hardware clock using the system clock [Local Time] ...
[ ok ]
* Stopping udev ...
[ ok ]

rc shutdown logging stopped at Thu Feb 15 10:24:06 2018

So, it must be whatever was installed just before that restart.

From genlop -l I have:
Fri Feb 15 08:08:57 2019 >>> sys-apps/kmod-25
Fri Feb 15 08:14:32 2019 >>> dev-util/glib-utils-666
Fri Feb 15 08:14:39 2019 >>> dev-util/gdbus-codegen-666
Fri Feb 15 08:20:24 2019 >>> dev-libs/glib-2.59.2
Fri Feb 15 08:21:12 2019 >>> gnome-base/gnome-keyring-3.31.90
Fri Feb 15 08:28:50 2019 >>> app-dicts/aspell-en-2018.04.16.0

Would it be something to do with the modules?

Cheers,
john
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum