Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] ]Gentoo as Guest in Virtualbox
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
danyo2008
n00b
n00b


Joined: 31 Mar 2019
Posts: 3

PostPosted: Sun Mar 31, 2019 7:08 pm    Post subject: [SOLVED] ]Gentoo as Guest in Virtualbox Reply with quote

Hi all,

i have a question for installing Gentoo as a Guest in Virtualbox. The Xserver will not start.

What have i done:

1. Configuring the Kernel with all necessary options (as described in the Wiki)

2. in Make.conf i have set

Code:
VIDEO_CARDS="virtualbox" 
INPUT_DEVICES="evdev libinput keyboard mouse"


3. I have installed the guest additions and put the guest additions to the defaul runlevel so it will start during boot time

4. I have loaded the modules

Code:
vboxguest, vboxvideo, vboxsf (also automatically during boot)


5. I have add my user to group vboxvideo
6. I have copy the example configuration of Virtualbox Guest Additions, as described after the installation of the tools to /etc/X11/xorg.conf.d/10Virtualbox.conf

Code:
Section "Device"
        Identifier  "Device-vboxvideo"
        Driver      "vboxvideo"
EndSection
Section "Screen"
        Identifier  "Screen-vboxvideo"
        Device      "Device-vboxvideo"
EndSection

Section "ServerLayout"
        Identifier  "Default Layout"
        Screen      "Screen-vboxvideo"
EndSection


7. I have also installed the Xorg driver for virtualbox:

Code:
x11-drivers/xf86-video-virtualbox



But if i start the Xserver with startx, i will get the following error log in /var/log/Xorg.0.log

Code:
[   995.623]
X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
[   995.623] Build Operating System: Linux 4.19.27-gentoo-r1 x86_64 Gentoo
[   995.624] Current Operating System: Linux gentoobox 4.19.27-gentoo-r1 #2 SMP Fri Mar 29 15:20:32 CET 2019 x86_64
[   995.624] Kernel command line: BOOT_IMAGE=/vmlinuz-4.19.27-gentoo-r1 root=UUID=c854abc9-3642-460b-a3d2-ffd99141eb43 ro
[   995.624] Build Date: 30 March 2019  08:23:50AM
[   995.624]
[   995.625] Current version of pixman: 0.36.0
[   995.625]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   995.625] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   995.626] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar 31 20:53:46 2019
[   995.627] (==) Using config file: "/etc/X11/xorg.conf"
[   995.627] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   995.627] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   995.627] (==) ServerLayout "Default Layout"
[   995.627] (**) |-->Screen "Screen-vboxvideo" (0)
[   995.627] (**) |   |-->Monitor "<default monitor>"
[   995.627] (**) |   |-->Device "Device-vboxvideo"
[   995.627] (**) |   |-->GPUDevice "Device-vboxvideo"
[   995.627] (==) No monitor specified for screen "Screen-vboxvideo".
        Using a default monitor configuration.
[   995.627] (==) Automatically adding devices
[   995.627] (==) Automatically enabling devices
[   995.627] (==) Automatically adding GPU devices
[   995.627] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   995.627] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[   995.627]    Entry deleted from font path.
[   995.627] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   995.627]    Entry deleted from font path.
[   995.627] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   995.627]    Entry deleted from font path.
[   995.627] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   995.627]    Entry deleted from font path.
[   995.628]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   995.628] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   995.628]    Entry deleted from font path.
[   995.628]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   995.628] (==) FontPath set to:
        /usr/share/fonts/misc/
[   995.628] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   995.628] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[   995.628] (II) Loader magic: 0x561eb1ce7c40
[   995.628] (II) Module ABI versions:
[   995.628]    X.Org ANSI C Emulation: 0.4
[   995.628]    X.Org Video Driver: 24.0
[   995.628]    X.Org XInput driver : 24.1
[   995.628]    X.Org Server Extension : 10.0
[   995.629] (--) PCI:*(0@0:2:0) 15ad:0405:15ad:0405 rev 0, Mem @ 0xf0000000/134217728, 0xf8000000/2097152, I/O @ 0x0000d010/16, BIOS @ 0x????????/131072
[   995.629] (II) LoadModule: "glx"
[   995.629] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   995.629] (II) Module glx: vendor="X.Org Foundation"
[   995.629]    compiled for 1.20.3, module version = 1.0.0
[   995.629]    ABI class: X.Org Server Extension, version 10.0
[   995.629] (II) LoadModule: "vboxvideo"
[   995.629] (II) Loading /usr/lib64/xorg/modules/drivers/vboxvideo_drv.so
[   995.629] (II) Module vboxvideo: vendor="Oracle Corporation"
[   995.629]    compiled for 1.20.3, module version = 1.0.1
[   995.629]    Module class: X.Org Video Driver
[   995.629]    ABI class: X.Org Video Driver, version 24.0
[   995.629] (**) Load address of symbol "VBOXVIDEO" is 0x7f2777c38340
[   995.629] (II) VBoxVideo: guest driver for VirtualBox: vbox
[   995.629] (--) using VT number 7

[   995.632] (EE) No devices detected.
[   995.632] (EE)
Fatal server error:
[   995.632] (EE) no screens found(EE)
[   995.632] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[   995.632] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   995.632] (EE)
[   995.634] (EE) Server terminated with error (1). Closing log file.



And here the output of dmesg

Code:
/var/log # dmesg | grep vbox
[    5.726015] vboxguest: loading out-of-tree module taints kernel.
[    5.726281] vboxguest: module verification failed: signature and/or required key missing - tainting kernel
[    5.737313] vboxguest: misc device minor 55, IRQ 20, I/O port d040, MMIO at 00000000f8400000 (size 0x400000)
[    5.737315] vboxguest: Successfully loaded version 5.2.22 (interface 0x00010004)
[    5.753044] vboxsf: Successfully loaded version 5.2.22 (interface 0x00010004)
[   15.819265] 00:00:00.000328 main     Executable: /usr/sbin/vboxguest-service
[/code]


I have Virtualbox 6.0.4 installed on the Host Maschine. Could this be the reason?

Does somebody has an Idea, what to do? I have no Idea anymore :-(

Thanks and regards
Danyo


Last edited by danyo2008 on Mon Apr 01, 2019 7:35 pm; edited 3 times in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43178
Location: 56N 3W

PostPosted: Sun Mar 31, 2019 7:21 pm    Post subject: Reply with quote

danyo2008,

Welcome to Gentoo.

First of all, I haven't done this but I suspect you need to select the right Graphics Controller in your Virtual Machine settings.
There are four to choose from on the Display tab. The first one, None, is probably not what you want.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
danyo2008
n00b
n00b


Joined: 31 Mar 2019
Posts: 3

PostPosted: Sun Mar 31, 2019 7:40 pm    Post subject: Reply with quote

NeddySeagoon wrote:
danyo2008,

Welcome to Gentoo.

First of all, I haven't done this but I suspect you need to select the right Graphics Controller in your Virtual Machine settings.
There are four to choose from on the Display tab. The first one, None, is probably not what you want.


Hi,

thanks for your answer, i have selected a Video Driver there. But i have tried other settings, too.
But nothing is working :-(

Regards
danyo
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43178
Location: 56N 3W

PostPosted: Sun Mar 31, 2019 8:20 pm    Post subject: Reply with quote

danyo2008,

Try without using
Code:
[   995.627] (==) Using config file: "/etc/X11/xorg.conf"
an xorg.conf file.
The automatics should just work. If it fails there will more useful information in the log.

Please install wgetpaste in the guest and use it to put your guest kernel .config file onto a pastebin site.
Post the link so we can find it. Its far too big to fit a post.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
danyo2008
n00b
n00b


Joined: 31 Mar 2019
Posts: 3

PostPosted: Mon Apr 01, 2019 7:34 pm    Post subject: Reply with quote

NeddySeagoon wrote:
danyo2008,

Try without using
Code:
[   995.627] (==) Using config file: "/etc/X11/xorg.conf"
an xorg.conf file.
The automatics should just work. If it fails there will more useful information in the log.

Please install wgetpaste in the guest and use it to put your guest kernel .config file onto a pastebin site.
Post the link so we can find it. Its far too big to fit a post.


Hi, have deleted all config files for Xorg and now, it is running :-)

Thank you very much....

Regards
danyo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum