Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Dark screen with radeon graphics since kernel 4.19
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
intmain
Apprentice
Apprentice


Joined: 14 Dec 2005
Posts: 179
Location: Austria

PostPosted: Mon Apr 01, 2019 7:41 pm    Post subject: [Solved] Dark screen with radeon graphics since kernel 4.19 Reply with quote

Hi,
since I updated from kernel 4.14 to 4.19 (gentoo-sources-4.19.27-r1) I get a dark screen on my laptop when booting as soon as udev starts.
It seems that the screen does not turn completely black but the backlight is off, when X starts you can spot a _very_ dark password input field, and it is possible to log in.

The interesting thing is, when I wait until the computer suspends and resume after that, the backlight turns on and then it works like usual.

So here's my graphics card:
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6290] [1002:9807]

and my kernel config https://pastebin.com/STg4XBdL and dmesg output https://pastebin.com/UNNmaDwJ

Any ideas?

Thanks

Solved

I solved the problem by passing
Code:
acpi_backlight=vendor
as kernel parameter.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum