Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dantrell's GNOME Without Systemd Project (Part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 11, 12, 13, 14, 15, 16  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jlpoole
Guru
Guru


Joined: 01 Nov 2005
Posts: 351
Location: Salem, OR

PostPosted: Sat Dec 07, 2019 6:20 pm    Post subject: This Topic Page 12 When On Page 11 Reply with quote

When I just posted a reply on this topic while on Page 11, when I clicked the "postreply" button, it took me page saying the page does not exist. I think it was Page 12 and I'll edit this reply with a screenshot when I submit this reply to document the problem.

Is there some sort of limit on the number of pages of a reply for a "Part", e.g. 12, that causes this problem and forces yet another Part to be created to continue this thread?

EDIT: After I submitted this reply, I was properly taken to a Page 12 where this reply seems to be at the very top. There must be some bug in the logic that determines when new pages are created and/or needed and that my prior post which I presume is the last of Page 11 caused the problem to manifest itself. Consequently, I do not have a screenshot to share as I promised above since the problem did not manifest itself.
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 677
Location: Earth

PostPosted: Sat Dec 07, 2019 11:56 pm    Post subject: Re: This Topic Page 12 When On Page 11 Reply with quote

jlpoole wrote:
gnome-extra/gnome-todo-3.28.1/ fails to build.

Sync up and you should be good to go.

jlpoole wrote:
When I just posted a reply on this topic while on Page 11, when I clicked the "postreply" button, it took me page saying the page does not exist. I think it was Page 12 and I'll edit this reply with a screenshot when I submit this reply to document the problem.

Is there some sort of limit on the number of pages of a reply for a "Part", e.g. 12, that causes this problem and forces yet another Part to be created to continue this thread?

EDIT: After I submitted this reply, I was properly taken to a Page 12 where this reply seems to be at the very top. There must be some bug in the logic that determines when new pages are created and/or needed and that my prior post which I presume is the last of Page 11 caused the problem to manifest itself. Consequently, I do not have a screenshot to share as I promised above since the problem did not manifest itself.

It's a bug that seems to happen ~2 replies before a page "closes".

This is probably the third time I have seen it. I'm also not sure what it's related to and whether or not it's limited to just this thread. :o
_________________
Dantrell B.
Back to top
View user's profile Send private message
jlpoole
Guru
Guru


Joined: 01 Nov 2005
Posts: 351
Location: Salem, OR

PostPosted: Sun Dec 08, 2019 2:06 am    Post subject: Reply with quote

I performed an "eix-sync" and then
Code:
emerge --update --newuse -deep @world
and everything successfully was built. All is well.

Thank you!
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 677
Location: Earth

PostPosted: Sun Dec 15, 2019 7:07 am    Post subject: Reply with quote

GNOME 3.34.2 (stable) is now available.

For some reason, it was distributed on a staggered release schedule with the final core packages only being tarballed a few days ago. :?

As before, nothing significant has changed since the initial announcement post (except for a couple regressions that Shibotto helped me correct).

The remaining high-priority issues are:
  • WebKit bug #199094 (restoring the preprocessor guards)
  • End of Life (EOL) for Python 2.
And a few medium-priority ebuild-related issues that cropped up include:
  • Fix trivial cases of MissingTestRestrict. Edit: Done.
  • Remove redundant `|| die` guards. Edit: Done.
  • Port to EAPI 7.

_________________
Dantrell B.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 493

PostPosted: Mon Dec 16, 2019 12:46 pm    Post subject: Reply with quote

Since Python 2.7 will be removed/masked in the future i have got a request:
dev-util/gtk-doc-1 needs python_single_target_python2_7 as use for building, for example in dev-util/boost-build there is a use mask for python, python_targets_python2_7 and for python_single_target_python2_7.

I don't know if it will work with gtk-doc because it looks like it has no python use flag.

I hope this helps a bit. :-)
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 677
Location: Earth

PostPosted: Wed Dec 18, 2019 6:46 pm    Post subject: Reply with quote

Child_of_Sun_24 wrote:
Since Python 2.7 will be removed/masked in the future i have got a request:
dev-util/gtk-doc-1 needs python_single_target_python2_7 as use for building, for example in dev-util/boost-build there is a use mask for python, python_targets_python2_7 and for python_single_target_python2_7.

I don't know if it will work with gtk-doc because it looks like it has no python use flag.

I hope this helps a bit. :-)

I did mention this earlier but:

dantrell wrote:
I reviewed the project overlays and it looks like there are 243 ebuilds related to Python 2.7 of which:
  • 51% (or 123) ebuilds support both Python 2 & 3 and support for Python 2 can just be dropped

  • 49% (or 120) ebuilds only [support] Python 2 which is where things get a bit tricky

  • ~31% (or ~76) ebuilds potentially only use Python 2 for unit testing and I can simply drop support for Python 2 and set RESTRICT="test"

  • ~18% (or ~44) ebuilds potentially need patches or other solutions which is a very reasonable number except it includes packages like GLib & SpiderMonkey :evil:
I will probably starting untangling Python 2.7 and then decide the rest when I hit the last ~18%.

So basically the real issue is dealing with the remaining ~18% but only for GNOME <=3.34.

GNOME >=3.36/3.38 will probably transition to Python 3 entirely.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Veteran
Veteran


Joined: 23 May 2006
Posts: 1033

PostPosted: Mon Dec 23, 2019 9:42 pm    Post subject: Reply with quote

Hey dantrell, does the following have to do with my beloved combined plasma & gnome profile? And if so, can you give me a hand for a fix? Thanks in advance :D
Code:
* Successfully synchronized overlay "dantrell-gnome".
 * Successfully synchronized overlay "dantrell-gnome-3-34".
 *
!!! The following update has been skipped due to unsatisfied dependencies:

kde-plasma/plasma-meta:5

  selected: (kde-plasma/plasma-meta-5.16.5:5/5::gentoo, installed)
  skipped: (kde-plasma/plasma-meta-5.17.4:5/5::gentoo, ebuild scheduled for merge) (see unsatisfied dependency below)

!!! All ebuilds that could satisfy ">=kde-plasma/xdg-desktop-portal-kde-5.17.4:5" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-plasma/xdg-desktop-portal-kde-5.17.4::dantrell-gnome (masked by: missing keyword)
- kde-plasma/xdg-desktop-portal-kde-5.17.4::gentoo (masked by: package.mask)

(dependency required by "kde-plasma/plasma-meta-5.17.4::gentoo[desktop-portal]" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Would you like to merge these packages? [Yes/No]
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 677
Location: Earth

PostPosted: Tue Dec 24, 2019 1:20 am    Post subject: Reply with quote

Elleni wrote:
Hey dantrell, does the following have to do with my beloved combined plasma & gnome profile? And if so, can you give me a hand for a fix? Thanks in advance :D

Looks like the issue was indeed on my end.

Sync up and you should be good to go (probably). :twisted:
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Veteran
Veteran


Joined: 23 May 2006
Posts: 1033

PostPosted: Wed Dec 25, 2019 10:42 am    Post subject: Reply with quote

thanks, all good now. Did not expect anything else though :twisted:
Back to top
View user's profile Send private message
Elleni
Veteran
Veteran


Joined: 23 May 2006
Posts: 1033

PostPosted: Sun Dec 29, 2019 11:33 pm    Post subject: Reply with quote

Hello dantrell,

is this on your end too? Thanks for checking.
Code:
emerge world -uDNav --with-bdeps=y

Calculating dependencies

These are the packages that would be merged, in order:

Calculating dependencies                                i * ERROR: kde-plasma/xdg-desktop-portal-kde-5.15.5-r4::dantrell-gnome failed (depend phase):
 *   CMAKE_REMOVE_MODULES is banned, set CMAKE_REMOVE_MODULES_LIST="" instead
 *
 * Call stack:
 *                                 ebuild.sh, line 616:  Called source '/var/lib/layman/dantrell-gnome/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.15.5-r4.ebuild'
 *   xdg-desktop-portal-kde-5.15.5-r4.ebuild, line   6:  Called inherit 'cmake-utils' 'kde5'
 *                                 ebuild.sh, line 317:  Called __qa_source '/usr/portage/eclass/kde5.eclass'
 *                                 ebuild.sh, line 112:  Called source '/usr/portage/eclass/kde5.eclass'
 *                               kde5.eclass, line 199:  Called inherit 'ecm'
 n *                                 ebuild.sh, line 317:  Called __qa_source '/usr/portage/eclass/ecm.eclass'
 *                                 ebuild.sh, line 112:  Called source '/usr/portage/eclass/ecm.eclass'
 *                                ecm.eclass, line  52:  Called inherit 'cmake' 'flag-o-matic' 'toolchain-funcs' 'virtualx'
 *                                 ebuild.sh, line 317:  Called __qa_source '/usr/portage/eclass/cmake.eclass'
 *                                 ebuild.sh, line 112:  Called source '/usr/portage/eclass/cmake.eclass'
 *                              cmake.eclass, line 107:  Called die
 * The specific snippet of code:
 *   [[ ${CMAKE_REMOVE_MODULES} ]] && die "CMAKE_REMOVE_MODULES is banned, set CMAKE_REMOVE_MODULES_LIST=\"\" instead"
 *
 * If you need support, post the output of `emerge --info '=kde-plasma/xdg-desktop-portal-kde-5.15.5-r4::dantrell-gnome'`,
 * the complete build log and the output of `emerge -pqv '=kde-plasma/xdg-desktop-portal-kde-5.15.5-r4::dantrell-gnome'`.
 * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/var/tmp/portage/kde-plasma/xdg-desktop-portal-kde-5.15.5-r4/work/xdg-desktop-portal-kde-5.15.5'
                      ... done!
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 677
Location: Earth

PostPosted: Mon Dec 30, 2019 3:43 am    Post subject: Reply with quote

Elleni wrote:
is this on your end too? Thanks for checking.

Yes, but for the record when I say things like this are on my end it'd be more accurate to say that something on Gentoo's end changed and I need to sync against it.

After all these years, I still can't find a way to make a "freeze" as seamless as I want without forking the main tree and that's something I want to avoid. :?

Anyway, sync up and you should be good to go.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Veteran
Veteran


Joined: 23 May 2006
Posts: 1033

PostPosted: Mon Dec 30, 2019 6:31 pm    Post subject: Reply with quote

Thanks a lot :D And dantrell, I did not mean at all it was your fault, I just was hoping that you could give me a hand to fix it. :twisted: I am more than happy with your support, so no keep up the good work, and thanks again. And I wont touch, promise :wink:
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 495
Location: Brazil

PostPosted: Fri Jan 03, 2020 2:49 pm    Post subject: Reply with quote

Request to stabilize x11-libs/gtk+-3.24.13 ? It's needed by >=games-util/lutris-0.5.4 since https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3e758a76a1ecef8d224e11a208db33f6f69b9451
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 677
Location: Earth

PostPosted: Sat Jan 04, 2020 2:49 am    Post subject: Reply with quote

Elleni wrote:
Thanks a lot :D And dantrell, I did not mean at all it was your fault, I just was hoping that you could give me a hand to fix it. :twisted: I am more than happy with your support, so no keep up the good work, and thanks again.

No problem. I just thought I'd clarify since it felt like I had been saying that quite a few times. :o

Elleni wrote:
And I wont touch, promise :wink:

Thanks. :)

saboya wrote:
Request to stabilize x11-libs/gtk+-3.24.13 ? It's needed by >=games-util/lutris-0.5.4 since https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3e758a76a1ecef8d224e11a208db33f6f69b9451

If I'm looking at this right games-util/lutris is still slotted in ~ so x11-libs/gtk+ doesn't need to follow suit.

That said, the biggest reason why recent versions of GTK+ are slotted in ~ on my end is because of GTK+ issue #1996.

Although, a quick review shows that I apparently forgot to figure out which versions were affected and adjust things accordingly. :?

Maybe there's patch floating around...

Stay tuned.
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 495
Location: Brazil

PostPosted: Mon Jan 06, 2020 12:58 pm    Post subject: Reply with quote

dantrell wrote:

If I'm looking at this right games-util/lutris is still slotted in ~ so x11-libs/gtk+ doesn't need to follow suit.


You're right, it just took me a while to realize that was the issue (all of a sudden lutris wasn't working for me anymore and the error message is not helpful at all in terms of knowing what the issue is).
Back to top
View user's profile Send private message
Elleni
Veteran
Veteran


Joined: 23 May 2006
Posts: 1033

PostPosted: Fri Jan 10, 2020 5:55 am    Post subject: Reply with quote

Hi dantrell :twisted:

I started on a newly setup system based on sabyoninos lrs which I setup with kde and elogind first. Concerning useflags I found that there was a problem with libreoffice-bin, which has a gnome or kde useflag, that was not working with the combined profile. So I decided to avoid binary version and instead use libreoffice. Then harfbuzz needed graphite useflag in order to stop portage from complaining.

While emerging world I have run into the following error. I skipped it for now by emerging world with --keep-going switch and I will report back, if it will work on a second pass after having emerged everything else or after re-emerge of openssl. Thanks for looking into it, as it might be on your side :wink:

Edit: re-emerge openssl did not help, and I then run into this.
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 677
Location: Earth

PostPosted: Fri Jan 10, 2020 7:20 am    Post subject: Reply with quote

Elleni wrote:
Hi dantrell :twisted:

Pls, no.

Elleni wrote:
I started on a newly setup system based on sabyoninos lrs which I setup with kde and elogind first. Concerning useflags I found that there was a problem with libreoffice-bin, which has a gnome or kde useflag, that was not working with the combined profile. So I decided to avoid binary version and instead use libreoffice. Then harfbuzz needed graphite useflag in order to stop portage from complaining.

This one isn't all that unexpected.

If you can't disable one of the two USE flags and just have things Just Work™ then you do have to avoid the binary version.

Elleni wrote:
While emerging world I have run into the following error. I skipped it for now by emerging world with --keep-going switch and I will report back, if it will work on a second pass after having emerged everything else or after re-emerge of openssl. Thanks for looking into it, as it might be on your side :wink:

I guess you are running stable? If so, looks like what you want is 0.18.4-r1 (which is slotted in ~).

Please test and confirm and I'll stabilize it.

Edit #3a: Stabilized.

Elleni wrote:
Edit: re-emerge openssl did not help, and I then run into this.

As for this one... I--
Please stand by. We are experiencing technical difficulties. :twisted:

Edit #1: This one seems to be because gnome-base/gnome-settings-daemon[wacom] requires x11-libs/gtk+[wayland]. If those two are really entangled, then a dependency adjustment is in order.

Edit #2: Patched. Going live... soon-ish. :wink:

Edit #3b: And... live. See you next time.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Veteran
Veteran


Joined: 23 May 2006
Posts: 1033

PostPosted: Fri Jan 10, 2020 8:27 pm    Post subject: Reply with quote

dantrell wrote:

Pls, no.
Oh, yes

dantrell wrote:

This one isn't all that unexpected.

If you can't disable one of the two USE flags and just have things Just Work™ then you do have to avoid the binary version.

Does it make sense, to add -kde for libreoffice-bin and/or +graphite for harfbuzz in case of libreoffice being used with combined profile? Else I'll be back the next time I hit this, promise! :twisted:
dantrell wrote:
I guess you are running stable? If so, looks like what you want is 0.18.4-r1 (which is slotted in ~).

Please test and confirm and I'll stabilize it.

Edit #3a: Stabilized.
As for this one... I--
Please stand by. We are experiencing technical difficulties. :twisted:

Edit #1: This one seems to be because gnome-base/gnome-settings-daemon[wacom] requires x11-libs/gtk+[wayland]. If those two are really entangled, then a dependency adjustment is in order.

Edit #2: Patched. Going live... soon-ish. :wink:

Edit #3b: And... live. See you next time.

Finally! :lol:

Yes, I am on stable, and sorry I was too slow to test n confirm

I have successfully emerged world -uDNv. Emerging gnome needed some further tinkering. 8) I had to add

Code:
=games-board/crafty-24.1-r1 ~amd64

and

>=x11-misc/colord-1.3.5 vala


After removing gnome-themes-standard, libvirt-glib and libvirt-python because dependent on older version of libvirt, I finally was able to successfully emerge gnome.
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 677
Location: Earth

PostPosted: Sat Jan 11, 2020 2:08 am    Post subject: Reply with quote

Elleni wrote:
I have successfully emerged world -uDNv. Emerging gnome needed some further tinkering. 8) I had to add [...]

I spun up a stage 3 tarball, targetted the combined profile for a stable system and got clean emerge output for @world gnome plasma-meta.

games-board/crafty is pulled in correctly so I'm not sure what went wrong (on your end).

x11-misc/colord indeed doesn't have the vala USE flag enabled but nothing on my end complains about that. Remember, I don't check any configuration for the combined profile except: @world gnome plasma-meta.

Elleni wrote:
After removing gnome-themes-standard, libvirt-glib and libvirt-python because dependent on older version of libvirt, I finally was able to successfully emerge gnome.

Nothing on my end complained about this either since nothing pulls in libvirt by default (anything that does is probably best installed after @world gnome plasma-meta).

I'll be spinning up a fresher stage 3 tarball to triple check but... :twisted:

Edit: Triple checked, no libvirt issues came up (although there was a circular dependency that can be prevented by building @world gnome plasma-meta before making USE changes).
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Veteran
Veteran


Joined: 23 May 2006
Posts: 1033

PostPosted: Sat Jan 11, 2020 4:50 pm    Post subject: Reply with quote

All good dantrell, thanks for your continued and much appreciated support! :) It must be because of some other packages or useflags, my pendrive system has then. After removing both mentioned packages, dependencies could be sorted up by portage, so it did not complain anymore and everything compiled fine.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 495
Location: Brazil

PostPosted: Tue Jan 28, 2020 3:04 am    Post subject: Reply with quote

media-gfx/gimp-2.10.14 is now stable on the main tree, which requires >=media-libs/gegl-0.4.18 and >=media-libs/babl-0.1.72, but those are masked / missing keyword on your overlay. Would it be ok to bump those to stable?

Bug: https://bugs.gentoo.org/706368
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 677
Location: Earth

PostPosted: Tue Jan 28, 2020 5:22 am    Post subject: Reply with quote

saboya wrote:
Would it be ok to bump those to stable?

Stabilized. :wink:

And then some.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Ultimator
n00b
n00b


Joined: 23 Jun 2018
Posts: 20

PostPosted: Wed Jan 29, 2020 7:33 pm    Post subject: Reply with quote

sys-apps/bubblewrap-0.3.1-r2 fails to build with +selinux
The issue is the same as in bug #674312
This patch worked for me. It's taken from comment #3 of this bug.
Code:
--- a/configure.ac
+++ b/configure.ac
@@ -14,6 +14,7 @@ AC_SYS_LARGEFILE
 
 AC_PROG_CC
 AM_PROG_CC_C_O
+PKG_PROG_PKG_CONFIG([])
 
 AC_CHECK_HEADERS([sys/capability.h], [], [AC_MSG_ERROR([*** POSIX caps headers not found])])
 
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 677
Location: Earth

PostPosted: Thu Jan 30, 2020 12:25 am    Post subject: Reply with quote

Ultimator wrote:
sys-apps/bubblewrap-0.3.1-r2 fails to build with +selinux

Thanks for the heads up.

Ultimator wrote:
The issue is the same as in bug #674312
This patch worked for me. It's taken from comment #3 of this bug.

Applied.
_________________
Dantrell B.
Back to top
View user's profile Send private message
shazeal
Apprentice
Apprentice


Joined: 03 May 2006
Posts: 200
Location: New Zealand

PostPosted: Fri Jan 31, 2020 9:35 pm    Post subject: Reply with quote

Just installed dantrell-gnome-3-34 and have found a few issues.

Building
  • dev-lang/rust must have abi_x86_32 set or libsvrg fails to build
  • I had to create a custom ebuild for pygtk and apply a patch to get it to build with pango, the default ebuild does not pickup /etc/portage/patches for whatever reason. This may have been caused by me being on ~


Code:
diff --git a/pango.defs b/pango.defs
index 6935c96483e9480e576e0cdc8dda9f2216a2f276..da968f5825c3d9751a3c324870c899326804d366 100644
--- a/pango.defs
+++ b/pango.defs
@@ -1391,15 +1391,6 @@
   )
 )
 
-(define-virtual find_shaper
-  (of-object "PangoFont")
-  (return-type "PangoEngineShape*")
-  (parameters
-    '("PangoLanguage*" "lang")
-    '("guint32" "ch")
-  )
-)
-
 (define-virtual get_glyph_extents
   (of-object "PangoFont")
   (return-type "none")




Run time issues.
  • Changing the Settings -> Power -> Blank screen only runs a screen saver rather than turning off the screen, I have had to create a script to run on gnome startup that runs 'xset dpms 300 300 300' which fixes the actual screen blanking issue. By default it will set all dpms values to 0 no matter what setting is used for Blank screen in settings.
  • The lock screen using SystemD will allow you to just start typing to unlock, without SystemD you must drag the mouse up to begin typing your password.

_________________
CFLAGS="-OmgWTFR1CE --fun-lol-loops --march=asmx86go"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 11, 12, 13, 14, 15, 16  Next
Page 12 of 16

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum