Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]PacketTracer
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
papas
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2014
Posts: 111
Location: Athens

PostPosted: Sat Mar 28, 2020 11:14 am    Post subject: [SOLVED]PacketTracer Reply with quote

Helllo guys,
I am facing a strange problem with cisco's PacketTracer, I am getting this error:
Code:

master@gentoo /opt/pt $ bin/PacketTracer7
bin/PacketTracer7: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

but the packet itself already have libcrypto.so.1.0.0
Code:

master@gentoo /opt/pt $ ls -la bin/
σύνολο 326520
drwxr-xr-x.  9 root root      4096 Mar 28 12:48 .
drwxr-xr-x. 13 root root      4096 Mar 28 12:48 ..
drwxr-xr-x.  2 root root      4096 Mar 28 12:48 audio
-rw-r--r--.  1 root root       218 Mar 28 12:48 Cisco-PacketTracer.desktop
-rw-r--r--.  1 root root       242 Mar 28 12:48 Cisco-pka.xml
-rw-r--r--.  1 root root       241 Mar 28 12:48 Cisco-pkt.xml
-rw-r--r--.  1 root root       243 Mar 28 12:48 Cisco-pkz.xml
-rw-r--r--.  1 root root  10218000 Mar 28 12:48 icudtl.dat
drwxr-xr-x.  2 root root      4096 Mar 28 12:48 imageformats
-rw-r--r--.  1 root root   2398784 Mar 28 12:48 libcrypto.so.1.0.0
-rw-r--r--.  1 root root  23516256 Mar 28 12:48 libicudata.so.52
-rwxr-xr-x.  1 root root  26904264 Mar 28 12:48 libicudata.so.60
-rw-r--r--.  1 root root   2421592 Mar 28 12:48 libicui18n.so.52
-rwxr-xr-x.  1 root root   2754872 Mar 28 12:48 libicui18n.so.60
-rw-r--r--.  1 root root   1646064 Mar 28 12:48 libicuuc.so.52
-rwxr-xr-x.  1 root root   1792008 Mar 28 12:48 libicuuc.so.60
-rwxr-xr-x.  1 root root   5942000 Mar 28 12:48 libQt5Core.so.5
-rwxr-xr-x.  1 root root    587448 Mar 28 12:48 libQt5DBus.so.5
-rwxr-xr-x.  1 root root   6104776 Mar 28 12:48 libQt5Gui.so.5
-rwxr-xr-x.  1 root root   1164656 Mar 28 12:48 libQt5Multimedia.so.5
-rwxr-xr-x.  1 root root    127440 Mar 28 12:48 libQt5MultimediaWidgets.so.5
-rwxr-xr-x.  1 root root   1732920 Mar 28 12:48 libQt5Network.so.5
-rwxr-xr-x.  1 root root    358656 Mar 28 12:48 libQt5OpenGL.so.5
-rwxr-xr-x.  1 root root    577888 Mar 28 12:48 libQt5Positioning.so.5
-rwxr-xr-x.  1 root root    479840 Mar 28 12:48 libQt5PrintSupport.so.5
-rwxr-xr-x.  1 root root   4881136 Mar 28 12:48 libQt5Qml.so.5
-rwxr-xr-x.  1 root root   4939688 Mar 28 12:48 libQt5Quick.so.5
-rwxr-xr-x.  1 root root     82200 Mar 28 12:48 libQt5QuickWidgets.so.5
-rwxr-xr-x.  1 root root   2541176 Mar 28 12:48 libQt5Script.so.5
-rwxr-xr-x.  1 root root    894008 Mar 28 12:48 libQt5ScriptTools.so.5
-rwxr-xr-x.  1 root root    265520 Mar 28 12:48 libQt5Sensors.so.5
-rwxr-xr-x.  1 root root    302936 Mar 28 12:48 libQt5Sql.so.5
-rwxr-xr-x.  1 root root    359152 Mar 28 12:48 libQt5Svg.so.5
-rwxr-xr-x.  1 root root    130984 Mar 28 12:48 libQt5WebChannel.so.5
-rwxr-xr-x.  1 root root 120789224 Mar 28 12:48 libQt5WebEngineCore.so.5
-rwxr-xr-x.  1 root root    277416 Mar 28 12:48 libQt5WebEngineWidgets.so.5
-rwxr-xr-x.  1 root root    184416 Mar 28 12:48 libQt5WebSockets.so.5
-rwxr-xr-x.  1 root root   6755304 Mar 28 12:48 libQt5Widgets.so.5
-rwxr-xr-x.  1 root root   1521208 Mar 28 12:48 libQt5XcbQpa.so.5
-rwxr-xr-x.  1 root root    244928 Mar 28 12:48 libQt5Xml.so.5
-r-xr-xr-x.  1 root root    521936 Mar 28 12:48 libssl.so.1.0.0
-rw-r--r--.  1 root root     10296 Mar 28 12:48 libxcb-xinerama.so.0
-rw-r--r--.  1 root root    133224 Mar 28 12:48 libxcb-xinput.so.0
-rwxr-xr-x.  1 root root   1382912 Mar 28 12:48 linguist
drwxr-xr-x.  2 root root      4096 Mar 28 12:48 Linux
drwxr-xr-x.  2 root root      4096 Mar 28 12:48 mediaservice
-rwxr-xr-x.  1 root root   3654824 Mar 28 12:48 meta
-rwxr-xr-x.  1 root root  84296952 Mar 28 12:48 PacketTracer7
drwxr-xr-x.  2 root root      4096 Mar 28 12:48 platforms
-rw-r--r--.  1 root root      3329 Mar 28 12:48 PT.conf
-rw-r--r--.  1 root root   8362567 Mar 28 12:48 qtwebengine_devtools_resources.pak
drwxr-xr-x.  2 root root      4096 Mar 28 12:48 qtwebengine_locales
-rwxr-xr-x.  1 root root     10496 Mar 28 12:48 QtWebEngineProcess
-rw-r--r--.  1 root root    626223 Mar 28 12:48 qtwebengine_resources_100p.pak
-rw-r--r--.  1 root root    679892 Mar 28 12:48 qtwebengine_resources_200p.pak
-rw-r--r--.  1 root root   1627219 Mar 28 12:48 qtwebengine_resources.pak
drwxr-xr-x.  2 root root      4096 Mar 28 12:48 sqldrivers
-rw-r--r--.  1 root root      3169 Mar 28 12:48 ZIP_LICENSE

any idea about what is going on?? I have already this topic https://forums.gentoo.org/viewtopic-t-1094584-start-0.html but cant make it work.
Thank you


Last edited by papas on Sat Mar 28, 2020 12:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23458
Location: here

PostPosted: Sat Mar 28, 2020 11:20 am    Post subject: Reply with quote

What return lddtree bin/PacketTracer7 command?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
papas
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2014
Posts: 111
Location: Athens

PostPosted: Sat Mar 28, 2020 11:35 am    Post subject: Reply with quote

Code:

master@gentoo /opt/pt $ lddtree bin/PacketTracer7
PacketTracer7 => bin/PacketTracer7 (interpreter => /lib64/ld-linux-x86-64.so.2)
scanelf: rpath_security_checks(): Security problem with relative DT_RUNPATH '.' in bin/PacketTracer7
    libcrypto.so.1.0.0 => not found
scanelf: rpath_security_checks(): Security problem with relative DT_RUNPATH '.' in bin/PacketTracer7
    libpthread.so.0 => /lib64/libpthread.so.0
        ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2
    libQt5Multimedia.so.5 => /usr/lib64/libQt5Multimedia.so.5
    libQt5WebEngineWidgets.so.5 => not found
scanelf: rpath_security_checks(): Security problem with relative DT_RUNPATH '.' in bin/PacketTracer7
    libQt5PrintSupport.so.5 => /usr/lib64/libQt5PrintSupport.so.5
    libQt5Svg.so.5 => /usr/lib64/libQt5Svg.so.5
        libz.so.1 => /lib64/libz.so.1
scanelf: rpath_security_checks(): Security problem with relative DT_RUNPATH '.' in bin/PacketTracer7
    libQt5Widgets.so.5 => /usr/lib64/libQt5Widgets.so.5
    libQt5WebEngineCore.so.5 => not found
scanelf: rpath_security_checks(): Security problem with relative DT_RUNPATH '.' in bin/PacketTracer7
    libQt5Gui.so.5 => /usr/lib64/libQt5Gui.so.5
        libGL.so.1 => /usr/lib64/libGL.so.1
            libGLdispatch.so.0 => /usr/lib64/libGLdispatch.so.0
                libdl.so.2 => /lib64/libdl.so.2
            libGLX.so.0 => /usr/lib64/libGLX.so.0
                libX11.so.6 => /usr/lib64/libX11.so.6
                    libxcb.so.1 => /usr/lib64/libxcb.so.1
                        libXau.so.6 => /usr/lib64/libXau.so.6
                        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6
                            libbsd.so.0 => /usr/lib64/libbsd.so.0
        libpng16.so.16 => /usr/lib64/libpng16.so.16
        libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0
            libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0
                libpcre.so.1 => /lib64/libpcre.so.1
            libfreetype.so.6 => /usr/lib64/libfreetype.so.6
                libbz2.so.1 => /lib64/libbz2.so.1
            libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3
scanelf: rpath_security_checks(): Security problem with relative DT_RUNPATH '.' in bin/PacketTracer7
    libQt5WebChannel.so.5 => /usr/lib64/libQt5WebChannel.so.5
        libQt5Qml.so.5 => /usr/lib64/libQt5Qml.so.5
scanelf: rpath_security_checks(): Security problem with relative DT_RUNPATH '.' in bin/PacketTracer7
    libQt5Network.so.5 => /usr/lib64/libQt5Network.so.5
        libgssapi_krb5.so.2 => /usr/lib64/libgssapi_krb5.so.2
            libkrb5.so.3 => /usr/lib64/libkrb5.so.3
            libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3
            libcom_err.so.2 => /lib64/libcom_err.so.2
            libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0
            libkeyutils.so.1 => /lib64/libkeyutils.so.1
            libresolv.so.2 => /lib64/libresolv.so.2
        libssl.so.1.1 => /usr/lib64/libssl.so.1.1
        libcrypto.so.1.1 => /usr/lib64/libcrypto.so.1.1
scanelf: rpath_security_checks(): Security problem with relative DT_RUNPATH '.' in bin/PacketTracer7
    libQt5Xml.so.5 => /usr/lib64/libQt5Xml.so.5
    libQt5Script.so.5 => /usr/lib64/libQt5Script.so.5
    libQt5ScriptTools.so.5 => /usr/lib64/libQt5ScriptTools.so.5
    libQt5Sql.so.5 => /usr/lib64/libQt5Sql.so.5
    libQt5Core.so.5 => /usr/lib64/libQt5Core.so.5
        libdouble-conversion.so.3 => /usr/lib64/libdouble-conversion.so.3
        libicui18n.so.65 => /usr/lib64/libicui18n.so.65
        libicuuc.so.65 => /usr/lib64/libicuuc.so.65
            libicudata.so.65 => /usr/lib64/libicudata.so.65
        libpcre2-16.so.0 => /usr/lib64/libpcre2-16.so.0
scanelf: rpath_security_checks(): Security problem with relative DT_RUNPATH '.' in bin/PacketTracer7
    libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/libstdc++.so.6
    libm.so.6 => /lib64/libm.so.6
    libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/libgcc_s.so.1
    libc.so.6 => /lib64/libc.so.6


but when i am running
Code:

master@gentoo /opt/pt $ LD_LIBRARY_PATH=/opt/pt/bin/ /opt/pt/bin/PacketTracer7
/opt/pt/bin/PacketTracer7: error while loading shared libraries: libdouble-conversion.so.1: cannot open shared object file: No such file or directory

i have no qtwebengine in my pc
thank you
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44896
Location: 56N 3W

PostPosted: Sat Mar 28, 2020 12:18 pm    Post subject: Reply with quote

papas,

On my system
Code:
$ ls /usr/lib64/libdouble-conversion.*
/usr/lib64/libdouble-conversion.so  /usr/lib64/libdouble-conversion.so.3  /usr/lib64/libdouble-conversion.so.3.1.5

and
Code:
$ equery b libdouble-conversion.so.3
 * Searching for libdouble-conversion.so.3 ...
dev-libs/double-conversion-3.1.5 (/usr/lib64/libdouble-conversion.so.3 -> libdouble-conversion.so.3.1.5)

so libdouble-conversion.so.1 is old.

The different numbers on the end show that the versions are not compatible.
However, that may not matter to you.

/usr/lib64/libdouble-conversion.so.3 is a symbolic link to libdouble-conversion.so.3.1.5.
What happens if you make /usr/lib64/libdouble-conversion.so.1 a symbolic link to libdouble-conversion.so.3.1.5 too.
The program will find the wrong version of the library but if the bits you need are not changed, it should go.
If not you will get a run time failure of some sort.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
papas
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2014
Posts: 111
Location: Athens

PostPosted: Sat Mar 28, 2020 12:28 pm    Post subject: Reply with quote

thank you now i am getting:
Code:
 
master@gentoo /opt/pt/bin $ LD_LIBRARY_PATH=/opt/pt/bin/ ./PacketTracer7
./PacketTracer7: /opt/pt/bin/libcrypto.so.1.0.0: no version information available (required by ./PacketTracer7)
./PacketTracer7: relocation error: /opt/pt/bin/libQt5WebEngineCore.so.5: symbol jpeg_skip_scanlines version LIBJPEG_8.0 not defined in file libjpeg.so.8 with link time reference

so i think it is not working at all, every step is missing another library..
i think it is easier to convince devs to keep the gns3 in portage tree than run packetTracer.


Last edited by papas on Sat Mar 28, 2020 12:39 pm; edited 2 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23458
Location: here

PostPosted: Sat Mar 28, 2020 12:34 pm    Post subject: Reply with quote

See http://forums.debian.net/viewtopic.php?f=10&t=145363
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
papas
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2014
Posts: 111
Location: Athens

PostPosted: Sat Mar 28, 2020 12:54 pm    Post subject: Reply with quote

@fedeliallalinea thank you for your help, I downloaded the 7.2.2 version and did exactly this https://forums.gentoo.org/viewtopic-t-1094584-start-0.html and now is working.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum