Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Gelöst] Verständnisfrage zum Updateprozess
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
mptaiko
n00b
n00b


Joined: 05 Jan 2019
Posts: 33

PostPosted: Fri Apr 12, 2019 7:52 am    Post subject: [Gelöst] Verständnisfrage zum Updateprozess Reply with quote

Hallo,

heut wollte ich mein wöchendliches Update fahren und bekam nach emerge -avuND @world folgende Meldung
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=dev-ruby/sass-3.5" has unmet requirements.
- dev-ruby/sass-3.5.7::gentoo USE="-doc -test" "

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( ruby_targets_ruby23 ruby_targets_ruby24 ruby_targets_ruby25 ruby_targets_ruby26 )

(dependency required by "x11-themes/numix-gtk-theme-2.6.7::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Ich hatte jetzt
Code:
dev-ruby/sass  -doc -test
eingetragen, mit dem Ergebnis, dass der Updatevorgang nicht startete.
Vermutlich liegt es an den anderen Einträgen
Code:
ABI_X86="(64)" RUBY_TARGETS="(-ruby23) -ruby24 -ruby25 -ruby26.

Wenn dem so ist, wo passe ich das an und warum?

LG Micha


Last edited by mptaiko on Sun Apr 14, 2019 10:26 am; edited 1 time in total
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 202
Location: Switzerland

PostPosted: Fri Apr 12, 2019 9:00 am    Post subject: Reply with quote

hi mptaiko,
die Ruby Targets kannst du in deiner make.conf eintragen. Es kommt darauf an, welche Version(en) du benutzen möchtest (du kannst auch mehrere angeben):

Code:

RUBY_TARGETS="ruby22 ruby24"


Weiteres dazu steht im Wiki: https://wiki.gentoo.org/wiki/Ruby

Grüsse
_________________
For calming down your eyes or clearing your mind: www.patrickwehli.ch
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3631
Location: Germany

PostPosted: Fri Apr 12, 2019 11:11 am    Post subject: Reply with quote

Hi

Hm, scheinbar hast du die original emerge Ausgabe manipuliert, sprich verändert (auseinander gepflückt) - das macht es für die hier helfenden Leute schwierig zu helfen - mache sowas bitte nicht :)

Die Zeile "ABI_X86="(64)" RUBY_TARGETS="(-ruby23) -ruby24 -ruby25 -ruby26"
gehört vermutlich noch mit zu der Originalausgabe.
Wenn dem so ist, dann deutet sie drauf hin dass das Paket dev-ruby/sass-3.5.7
mit allen RUBY_TARGETS deaktiviert gebaut werden würde - und das lassen die deps nicht zu - es muss zumindest ein Target gesetzt sein.

Normal sollte aktuell RUBY_TARGETS="ruby24" schon vom Profi her gesetzt sein,
doch ruby24 ist bei dir deaktiviert. Vermutlich hast du dieses Flag in der make.conf oder/und in der packag.use irgendwo deaktiviert.
Schau zb mal via
Code:
grep -ri ruby_ /etc/portage/


Mein Vorschlag wäre - entferne die selbst gesetzten RUBY_TARGETS (die die defaults vom Profil überschreiben),
und nutze somit die defaults vom Profil - die sollten idR fein funktionieren.
Back to top
View user's profile Send private message
mptaiko
n00b
n00b


Joined: 05 Jan 2019
Posts: 33

PostPosted: Sun Apr 14, 2019 10:25 am    Post subject: Reply with quote

Hallo Mvaterlaus, hallo Joseph,

danke für die schnelle Hilfe.

in meiner /etc/portage/make.config stand
Code:
RUBY_TARGETS="ruby23"


Den Wert habe ich auf 24 gesetzt und schon läuft das Upgrade.

LG Micha
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum