Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot get dropbox to run
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
walterbyrd
n00b
n00b


Joined: 26 Apr 2017
Posts: 48

PostPosted: Fri Apr 12, 2019 7:49 pm    Post subject: Cannot get dropbox to run Reply with quote

It keeps hanging on this

Code:

dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/PyQt5.QtDBus.cpython-36m-x86_64-linux-gnu.so'


This is my system:

Code:

$ uname -a
Linux fir 4.19.29-calculate #1 SMP PREEMPT Thu Mar 14 15:32:35 UTC 2019 x86_64 AMD Athlon(tm) II X4 640 Processor AuthenticAMD GNU/Linux


Here are the full results when I try to run.

Code:

$ dropbox
dropbox: locating interpreter
dropbox: logging to /tmp/dropbox-antifreeze-ViNzsL
dropbox: initializing
dropbox: initializing python 2.7.11
dropbox: setting program path '/opt/dropbox/dropbox'
dropbox: setting home path '/opt/dropbox'
dropbox: setting python path '/opt/dropbox:/opt/dropbox/python-packages-27.zip'
dropbox: python initialized
dropbox: running dropbox
dropbox: setting args
dropbox: applying overrides
dropbox: running main script
dropbox: load fq extension '/opt/dropbox/cryptography.hazmat.bindings._constant_time.so'
dropbox: load fq extension '/opt/dropbox/cryptography.hazmat.bindings._openssl.so'
dropbox: load fq extension '/opt/dropbox/cryptography.hazmat.bindings._padding.so'
dropbox: load fq extension '/opt/dropbox/psutil._psutil_linux.so'
dropbox: load fq extension '/opt/dropbox/psutil._psutil_posix.so'
dropbox: load fq extension '/opt/dropbox/linuxffi.pthread._linuxffi_pthread.so'
dropbox: load fq extension '/opt/dropbox/tornado.speedups.so'
dropbox: load fq extension '/opt/dropbox/cpuid.compiled._cpuid.so'
dropbox: load fq extension '/opt/dropbox/linuxffi.resolv.compiled._linuxffi_resolv.so'
dropbox: load fq extension '/opt/dropbox/linuxffi.sys.compiled._linuxffi_sys.so'
dropbox: load fq extension '/opt/dropbox/posixffi.libc._posixffi_libc.so'
dropbox: load fq extension '/opt/dropbox/librsyncffi.compiled._librsyncffi.so'
dropbox: locating interpreter
dropbox: logging to /tmp/dropbox-antifreeze-kqB2GB
dropbox: initializing
dropbox: initializing python 3.6.7
dropbox: setting program path '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/dropbox'
dropbox: setting home path '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141'
dropbox: setting python path '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141:/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/python-packages-36.zip'
dropbox: python initialized
dropbox: running dropbox
dropbox: setting args
dropbox: applying overrides
dropbox: running main script
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/cryptography.hazmat.bindings._constant_time.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/cryptography.hazmat.bindings._openssl.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/cryptography.hazmat.bindings._padding.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/psutil._psutil_linux.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/psutil._psutil_posix.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/linuxffi.pthread._linuxffi_pthread.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/tornado.speedups.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/cpuid.compiled._cpuid.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/linuxffi.resolv.compiled._linuxffi_resolv.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/linuxffi.gnu.compiled._linuxffi_gnu.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/linuxffi.sys.compiled._linuxffi_sys.cpython-36m-x86_64-linux-gnu.so'
13:43:35.794 INFO UNKNOWN       [dropbox/dbx-thread/src/lib.rs:135] Creating thread, name: PYTHON_LOGGER
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/librsyncffi.compiled._librsyncffi.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/posixffi.libc._posixffi_libc.cpython-36m-x86_64-linux-gnu.so'
Killed
walter@fir ~ $ dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/PyQt5.QtWebKit.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/PyQt5.QtCore.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/PyQt5.QtNetwork.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/PyQt5.QtGui.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/PyQt5.QtWebKitWidgets.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/PyQt5.QtWidgets.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/PyQt5.QtPrintSupport.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/home/walter/.dropbox-dist/dropbox-lnx.x86_64-64.4.141/PyQt5.QtDBus.cpython-36m-x86_64-linux-gnu.so'
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43009
Location: 56N 3W

PostPosted: Fri Apr 12, 2019 7:55 pm    Post subject: Reply with quote

walterbyrd,

dmesg will say what was killed and why.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
walterbyrd
n00b
n00b


Joined: 26 Apr 2017
Posts: 48

PostPosted: Fri Apr 12, 2019 10:01 pm    Post subject: Reply with quote

I am getting a segmentation fault where it hangs.

Code:

$ dmesg

. . .

[33163.824263] PyQt5.QtDBus.cp[27855]: segfault at 1 ip 0000000000000001 sp 00007ffeb4269888 error 14 in PyQt5.QtDBus.cpython-36m-x86_64-linux-gnu.so[7f49911aa000+2c000]
[33163.824277] Code: Bad RIP value.



When I try to run from command line:

Code:

 ~/.dropbox-dist/dropbox-lnx.x86_64-64.4.141 $ ./PyQt5.QtDBus.cpython-36m-x86_64-linux-gnu.so

Segmentation fault


My file system is un encrypted ext4

I found this thread:

Dropbox 48.3.56 stopped syncing
https://forums.gentoo.org/viewtopic-t-1085012.html

Not sure if it will help. Maybe dropbox just won't work?


Last edited by walterbyrd on Fri Apr 12, 2019 10:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43009
Location: 56N 3W

PostPosted: Fri Apr 12, 2019 10:12 pm    Post subject: Reply with quote

walterbyrd,

Code:
equery b <file>
will tell the package that that library belongs to. I don't have it installed.
Rebuild that package.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
walterbyrd
n00b
n00b


Joined: 26 Apr 2017
Posts: 48

PostPosted: Fri Apr 12, 2019 10:23 pm    Post subject: Reply with quote

Did not tell me much.

Code:

$ equery b PyQt5.QtDBus.cpython-36m-x86_64-linux-gnu.so
 * Searching for PyQt5.QtDBus.cpython-36m-x86_64-linux-gnu.so ...
$



It ran for a while then dropped.

FWIW: I think my dropbox client version is: 64.4.14
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13734

PostPosted: Sat Apr 13, 2019 12:44 am    Post subject: Reply with quote

walterbyrd wrote:
Code:
 ~/.dropbox-dist/dropbox-lnx.x86_64-64.4.141 $ ./PyQt5.QtDBus.cpython-36m-x86_64-linux-gnu.so
Segmentation fault
Generally, you cannot run a shared object as a program. It's possible to make that work, but very rare that anyone does so.
walterbyrd wrote:
Did not tell me much.
Code:
$ equery b PyQt5.QtDBus.cpython-36m-x86_64-linux-gnu.so
 * Searching for PyQt5.QtDBus.cpython-36m-x86_64-linux-gnu.so ...
$
According to your prior output, this file was bundled with Dropbox instead of installing it through the system package manager. equery only knows what was installed properly through the package manager.

Since this appears to be provided by Dropbox, problems with it should be directed to them.


Last edited by Hu on Sat Apr 13, 2019 3:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43009
Location: 56N 3W

PostPosted: Sat Apr 13, 2019 9:25 am    Post subject: Reply with quote

... and dropbox is an evil binary blob. I tried to keyword it for ~arm64 :)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
walterbyrd
n00b
n00b


Joined: 26 Apr 2017
Posts: 48

PostPosted: Sat Apr 13, 2019 11:30 am    Post subject: Reply with quote

I should have mentioned: dropbox used to work.

I suppose an update, or something, made it stop working.
Back to top
View user's profile Send private message
walterbyrd
n00b
n00b


Joined: 26 Apr 2017
Posts: 48

PostPosted: Sun Apr 14, 2019 12:33 am    Post subject: Reply with quote

Quote:
According to your prior output, this file was bundled with Dropbox instead of installing it through the system package manager. equery only knows what was installed properly through the package manager.


I thought I installed dropbox with emerge. But to make sure, I uninstalled, and reinstalled - made sure to use emerge. Same thing.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1647
Location: United Kingdom

PostPosted: Sun Apr 14, 2019 1:52 am    Post subject: Reply with quote

The Gentoo ebuild for Dropbox is out-of-date and does not result in a working Dropbox any more, as far as I am aware.

walterbyrd, looking at the output of uname that you posted, are you running Calculate Linux? If you are, I'm not sure if the following instructions will apply in your case, but you could try them: Installing Dropbox in Gentoo Linux following the recent restrictions introduced for Dropbox for Linux.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13734

PostPosted: Sun Apr 14, 2019 4:26 am    Post subject: Reply with quote

walterbyrd wrote:
I thought I installed dropbox with emerge. But to make sure, I uninstalled, and reinstalled - made sure to use emerge. Same thing.
emerge never (or at least, should never) place files in your home directory. You may have used emerge to install some Dropbox programs, but it appears that whatever you installed then downloaded more files to your home directory. One of those files is the immediate source of the fault.
Back to top
View user's profile Send private message
walterbyrd
n00b
n00b


Joined: 26 Apr 2017
Posts: 48

PostPosted: Wed Apr 17, 2019 7:57 pm    Post subject: Reply with quote

Removed dropbox again. Removed /home/walter/.dropbox-dist/ directory.

Reinstalled with emerge. It seems to be the dropbox client that creates the /home/walter/.dropbox-dist/directory.

Also breaks in the same place.


Code:

# emerge net-misc/dropbox

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
>>> Emerging binary (1 of 1) net-misc/dropbox-48.3.56::gentoo
>>> Installing (1 of 1) net-misc/dropbox-48.3.56::gentoo
>>> Recording net-misc/dropbox in "world" favorites file...
>>> Jobs: 1 of 1 complete                           Load avg: 1.35, 0.92, 0.73
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

. . .

$ dropbox start

. . .

3/PyQt5.QtPrintSupport.cpython-36m-x86_64-linux-gnu.so'


And that is where it hangs.


Last edited by walterbyrd on Wed Apr 17, 2019 8:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
walterbyrd
n00b
n00b


Joined: 26 Apr 2017
Posts: 48

PostPosted: Wed Apr 17, 2019 8:06 pm    Post subject: Reply with quote

Fitzcarraldo wrote:
The Gentoo ebuild for Dropbox is out-of-date and does not result in a working Dropbox any more, as far as I am aware.

walterbyrd, looking at the output of uname that you posted, are you running Calculate Linux? If you are, I'm not sure if the following instructions will apply in your case, but you could try them: Installing Dropbox in Gentoo Linux following the recent restrictions introduced for Dropbox for Linux.



Gave it a shot. Got this:

Code:

~ $ ~/.dropbox-dist/dropboxd

. . .

3/PyQt5.QtPrintSupport.cpython-36m-x86_64-linux-gnu.so'
Segmentation fault


I don't even want print support.

Yes, I am using Calculate Linux. But, it's supposed to be Gentoo under the hood.
Back to top
View user's profile Send private message
zsitvaij
n00b
n00b


Joined: 11 Jan 2006
Posts: 72

PostPosted: Sun Apr 21, 2019 4:19 pm    Post subject: Reply with quote

I see you found the previous topic, but did you try the workaround I posted in it?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum