Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOVLED] Cannot compile Budgie
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Rockford The Roe
n00b
n00b


Joined: 21 Mar 2019
Posts: 15
Location: Illinois

PostPosted: Fri Apr 12, 2019 10:41 pm    Post subject: [SOVLED] Cannot compile Budgie Reply with quote

Hello, I am trying to compile the Budgie 10.5 DE via source code. When I run
Code:
meson build --prefix=/usr --sysconfdir=/etc
, I get this error.

Code:

Dependency vapigen found: NO (tried pkgconfig and cmake)

meson.build:44:0: ERROR:  Dependency "vapigen" not found, tried pkgconfig and cmake


I have already tried ln -s'ing vapigen and I know dev-lang/vala is installed. How do I make it detect vapigen so I can compile it?

Thank you.
_________________
"UNIX is very simple, it just needs a genius to understand its simplicity." -Dennis Ritchie


Last edited by Rockford The Roe on Tue Apr 16, 2019 2:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
Rockford The Roe
n00b
n00b


Joined: 21 Mar 2019
Posts: 15
Location: Illinois

PostPosted: Sat Apr 13, 2019 4:22 am    Post subject: Reply with quote

Output of the full log

Code:
Build started at 2019-04-12T23:07:29.080559
Main binary: /usr/bin/python3.6
Python system: Linux
The Meson build system
Version: 0.49.2
Source dir: /home/ethan/Git/budgie-desktop-10.5
Build dir: /home/ethan/Git/budgie-desktop-10.5/build
Build type: native build
Project name: budgie-desktop
Project version: 10.5
Sanity testing C compiler: ccache cc
Is cross compiler: False.
Sanity check compiler command line: ccache cc /home/ethan/Git/budgie-desktop-10.5/build/meson-private/sanitycheckc.c -o /home/ethan/Git/budgie-desktop-10.5/build/meson-private/sanitycheckc.exe
Sanity check compile stdout:

-----
Sanity check compile stderr:

-----
Running test binary command: /home/ethan/Git/budgie-desktop-10.5/build/meson-private/sanitycheckc.exe
Native C compiler: ccache cc (gcc 8.3.0 "cc (Gentoo 8.3.0-r1 p1.1) 8.3.0")
Running compile:
Working directory:  /tmp/tmpq87adqjr
Command line:  valac /tmp/tmpq87adqjr/testfile.vala -C

Code:
 class MesonSanityCheck : Object { }
Compiler stdout:
 
Compiler stderr:
 
Native Vala compiler: valac (valac 0.42.6)
Build machine cpu family: x86_64
Build machine cpu: x86_64
Program git found: YES (/usr/bin/git)
Program meson_post_install.sh found: YES (/home/ethan/Git/budgie-desktop-10.5/meson_post_install.sh)
Found pkg-config: /usr/bin/pkg-config (1.5.4)
Determining dependency 'gtk+-3.0' with pkg-config executable '/usr/bin/pkg-config'
Called `/usr/bin/pkg-config --modversion gtk+-3.0` -> 0
3.24.7
Called `/usr/bin/pkg-config --cflags gtk+-3.0` -> 0
-I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/fribidi -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/uuid -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0/ -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -pthread
Called `/usr/bin/pkg-config gtk+-3.0 --libs` -> 0
-L/usr/lib64 -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
Called `/usr/bin/pkg-config gtk+-3.0 --libs` -> 0
-lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
Running compile:
Working directory:  /tmp/tmpiimf9smg
Command line:  ccache cc /tmp/tmpiimf9smg/testfile.c -pipe -D_FILE_OFFSET_BITS=64 -o /tmp/tmpiimf9smg/output.exe -O0

Code:
 #include<stdio.h>
       
        int main(int argc, char **argv) {
            printf("%ld\n", (long)(sizeof(void *)));
            return 0;
        };
Compiler stdout:
 
Compiler stderr:
 
Program stdout:

8

Program stderr:


Running compile:
Working directory:  /tmp/tmphm4t80lz
Command line:  ccache cc /tmp/tmphm4t80lz/testfile.c -pipe -D_FILE_OFFSET_BITS=64 -c -o /tmp/tmphm4t80lz/output.obj -O0 --print-search-dirs

Code:
 
Compiler stdout:
 install: /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/
programs: =/usr/libexec/gcc/x86_64-pc-linux-gnu/8.3.0/:/usr/libexec/gcc/x86_64-pc-linux-gnu/8.3.0/:/usr/libexec/gcc/x86_64-pc-linux-gnu/:/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/:/usr/lib/gcc/x86_64-pc-linux-gnu/:/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../x86_64-pc-linux-gnu/bin/x86_64-pc-linux-gnu/8.3.0/:/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../x86_64-pc-linux-gnu/bin/
libraries: =/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/:/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../x86_64-pc-linux-gnu/lib/x86_64-pc-linux-gnu/8.3.0/:/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../x86_64-pc-linux-gnu/lib/../lib64/:/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../x86_64-pc-linux-gnu/8.3.0/:/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../lib64/:/lib/x86_64-pc-linux-gnu/8.3.0/:/lib/../lib64/:/usr/lib/x86_64-pc-linux-gnu/8.3.0/:/usr/lib/../lib64/:/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../x86_64-pc-linux-gnu/lib/:/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../:/lib/:/usr/lib/

Compiler stderr:
 
Dependency gtk+-3.0 found: YES 3.24.7
Determining dependency 'glib-2.0' with pkg-config executable '/usr/bin/pkg-config'
Called `/usr/bin/pkg-config --modversion glib-2.0` -> 0
2.58.3
Called `/usr/bin/pkg-config --cflags glib-2.0` -> 0
-I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
Called `/usr/bin/pkg-config glib-2.0 --libs` -> 0
-L/usr/lib64 -lglib-2.0
Called `/usr/bin/pkg-config glib-2.0 --libs` -> 0
-lglib-2.0
Dependency glib-2.0 found: YES 2.58.3
Determining dependency 'gio-unix-2.0' with pkg-config executable '/usr/bin/pkg-config'
Called `/usr/bin/pkg-config --modversion gio-unix-2.0` -> 0
2.58.3
Called `/usr/bin/pkg-config --cflags gio-unix-2.0` -> 0
-I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/uuid
Called `/usr/bin/pkg-config gio-unix-2.0 --libs` -> 0
-L/usr/lib64 -lgio-2.0 -lgobject-2.0 -lglib-2.0
Called `/usr/bin/pkg-config gio-unix-2.0 --libs` -> 0
-lgio-2.0 -lgobject-2.0 -lglib-2.0
Dependency gio-unix-2.0 found: YES 2.58.3
Determining dependency 'libpeas-1.0' with pkg-config executable '/usr/bin/pkg-config'
Called `/usr/bin/pkg-config --modversion libpeas-1.0` -> 0
1.22.0
Called `/usr/bin/pkg-config --cflags libpeas-1.0` -> 0
-I/usr/include/libpeas-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/uuid -I/usr/include/gobject-introspection-1.0 -pthread -I/usr/lib64/libffi-3.3_rc0/include
Called `/usr/bin/pkg-config libpeas-1.0 --libs` -> 0
-L/usr/lib64 -lpeas-1.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0 -lgio-2.0 -lgirepository-1.0 -lgobject-2.0 -lglib-2.0
Called `/usr/bin/pkg-config libpeas-1.0 --libs` -> 0
-lpeas-1.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0 -lgio-2.0 -lgirepository-1.0 -lgobject-2.0 -lglib-2.0
Dependency libpeas-1.0 found: YES 1.22.0
Determining dependency 'gdk-x11-3.0' with pkg-config executable '/usr/bin/pkg-config'
Called `/usr/bin/pkg-config --modversion gdk-x11-3.0` -> 0
3.24.7
Called `/usr/bin/pkg-config --cflags gdk-x11-3.0` -> 0
-I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/fribidi -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/uuid -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0/ -pthread
Called `/usr/bin/pkg-config gdk-x11-3.0 --libs` -> 0
-L/usr/lib64 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgobject-2.0 -lglib-2.0
Called `/usr/bin/pkg-config gdk-x11-3.0 --libs` -> 0
-lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgobject-2.0 -lglib-2.0
Dependency gdk-x11-3.0 found: YES 3.24.7
Determining dependency 'uuid' with pkg-config executable '/usr/bin/pkg-config'
Called `/usr/bin/pkg-config --modversion uuid` -> 0
2.33.1
Called `/usr/bin/pkg-config --cflags uuid` -> 0
-I/usr/include/uuid
Called `/usr/bin/pkg-config uuid --libs` -> 0
-L/usr/lib64 -luuid
Called `/usr/bin/pkg-config uuid --libs` -> 0
-luuid
Dependency uuid found: YES 2.33.1
Determining dependency 'vapigen' with pkg-config executable '/usr/bin/pkg-config'
Called `/usr/bin/pkg-config --modversion vapigen` -> 1

Found CMake: /usr/bin/cmake (3.14.1)

Determining dependency 'vapigen' with CMake executable '/usr/bin/cmake'
Try CMake generator: auto
Called `/usr/bin/cmake --trace-expand -DNAME=vapigen .` in /home/ethan/Git/budgie-desktop-10.5/build/meson-private/cmake_vapigen -> 0
Dependency vapigen found: NO (tried pkgconfig and cmake)

meson.build:44:0: ERROR:  Dependency "vapigen" not found, tried pkgconfig and cmake

_________________
"UNIX is very simple, it just needs a genius to understand its simplicity." -Dennis Ritchie
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21687
Location: here

PostPosted: Sat Apr 13, 2019 9:28 am    Post subject: Reply with quote

Try to export VAPIGEN variable
Code:
# export VAPIGEN=/usr/bin/vapigen-<your_version>
# meson build --prefix=/usr --sysconfdir=/etc

Anyway why not use existing ebuild in reagentoo overlay https://gpo.zugaina.org/gnome-extra/budgie-desktop
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Rockford The Roe
n00b
n00b


Joined: 21 Mar 2019
Posts: 15
Location: Illinois

PostPosted: Sat Apr 13, 2019 7:45 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Try to export VAPIGEN variable
Code:
# export VAPIGEN=/usr/bin/vapigen-<your_version>
# meson build --prefix=/usr --sysconfdir=/etc

Anyway why not use existing ebuild in reagentoo overlay https://gpo.zugaina.org/gnome-extra/budgie-desktop


The overlays depend on gnome-session and gnome-shell but I do not need them.

I have tried to export the VAPIGEN but it didn't work, I got the same error.
_________________
"UNIX is very simple, it just needs a genius to understand its simplicity." -Dennis Ritchie
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21687
Location: here

PostPosted: Sat Apr 13, 2019 8:37 pm    Post subject: Reply with quote

Rockford The Roe wrote:
The overlays depend on gnome-session and gnome-shell but I do not need them.

I have tried to export the VAPIGEN but it didn't work, I got the same error.

Try to create a symbolic link to /usr/lib64/pkgconfig/vapigen-0.40.pc
Code:
# ln -s /usr/lib64/pkgconfig/vapigen-0.40.pc /usr/lib64/pkgconfig/vapigen.pc

when you finish remember to remove link.
You can also create an ebuild for this package and use vala.eclass that set for you the correct environment
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Rockford The Roe
n00b
n00b


Joined: 21 Mar 2019
Posts: 15
Location: Illinois

PostPosted: Sat Apr 13, 2019 9:13 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Rockford The Roe wrote:
The overlays depend on gnome-session and gnome-shell but I do not need them.

I have tried to export the VAPIGEN but it didn't work, I got the same error.

Try to create a symbolic link to /usr/lib64/pkgconfig/vapigen-0.40.pc
Code:
# ln -s /usr/lib64/pkgconfig/vapigen-0.40.pc /usr/lib64/pkgconfig/vapigen.pc

when you finish remember to remove link.
You can also create an ebuild for this package and use vala.eclass that set for you the correct environment


It seems that doing that link worked, but I've got another problem on my hands. I have also linked libmutter-2 to libmutter-3 and now when I compile, it stops at screen.h saying that it is not found.
_________________
"UNIX is very simple, it just needs a genius to understand its simplicity." -Dennis Ritchie
Back to top
View user's profile Send private message
Rockford The Roe
n00b
n00b


Joined: 21 Mar 2019
Posts: 15
Location: Illinois

PostPosted: Sun Apr 14, 2019 2:06 am    Post subject: Reply with quote

Quote:
I have also linked libmutter-2 to libmutter-3 and now when I compile, it stops at screen.h saying that it is not found.


Here's what I was talking about:

Code:

[99/266] Compiling C object 'src/wm/131f9c0@@budgie-wm@exe/meson-generated_background.c.o'.
FAILED: src/wm/131f9c0@@budgie-wm@exe/meson-generated_background.c.o
ccache cc -Isrc/wm/131f9c0@@budgie-wm@exe -Isrc/wm -I../src/wm -I. -I../ -Isrc/config -I../src/config -I/usr/include/mutter -I/usr/include/gsettings-desktop-schemas -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/fribidi -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/uuid -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0/ -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/mutter/clutter-3 -I/usr/include/json-glib-1.0 -I/usr/include/mutter/cogl -I/usr/include/gnome-desktop-3.0 -I/usr/include/ibus-1.0 -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -w -std=c11 -g -fstack-protector -pedantic -Wstrict-prototypes -Wundef -Werror-implicit-function-declaration -Wformat -Wformat-security -Werror=format-security -Wconversion -Wunused-variable -Wunreachable-code -Wall -W '-DGETTEXT_PACKAGE="budgie-desktop"' -pthread -DGNOME_DESKTOP_USE_UNSTABLE_API  -MD -MQ 'src/wm/131f9c0@@budgie-wm@exe/meson-generated_background.c.o' -MF 'src/wm/131f9c0@@budgie-wm@exe/meson-generated_background.c.o.d' -o 'src/wm/131f9c0@@budgie-wm@exe/meson-generated_background.c.o' -c 'src/wm/131f9c0@@budgie-wm@exe/background.c'
src/wm/131f9c0@@budgie-wm@exe/background.c:21:10: fatal error: meta/screen.h: No such file or directory
 #include <meta/screen.h>
          ^~~~~~~~~~~~~~~
compilation terminated.
ninja: build stopped: subcommand failed.

_________________
"UNIX is very simple, it just needs a genius to understand its simplicity." -Dennis Ritchie
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21687
Location: here

PostPosted: Sun Apr 14, 2019 8:37 am    Post subject: Reply with quote

Rockford The Roe wrote:
It seems that doing that link worked, but I've got another problem on my hands. I have also linked libmutter-2 to libmutter-3 and now when I compile, it stops at screen.h saying that it is not found.

What you mean with I have also linked libmutter-2 to libmutter-3? You installed x11-wm/mutter that provide meta/screen.h?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Rockford The Roe
n00b
n00b


Joined: 21 Mar 2019
Posts: 15
Location: Illinois

PostPosted: Sun Apr 14, 2019 4:38 pm    Post subject: Reply with quote

fedeliallalinea wrote:

What you mean with I have also linked libmutter-2 to libmutter-3? You installed x11-wm/mutter that provide meta/screen.h?


Sorry for not clarifying correctly, the compiler didn't see /usr/lib64/pkgconfig/libmutter-3.pc so I crated a link that branches from that to libmutter-2.pc. I am sure that x11-wm/mutter is installed.
_________________
"UNIX is very simple, it just needs a genius to understand its simplicity." -Dennis Ritchie
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 487
Location: Estonia

PostPosted: Sun Apr 14, 2019 4:49 pm    Post subject: Reply with quote

You can't, or at least shouldn't, just symlink things over like that.
mutter-3.28 provides API version 2; mutter 3.30 provides API version 3. 3.26 provides API version 1. Mutter packages subslot signifies that, and something that needs to link to these API specific stuff should subslot dep on the concrete need properly - only main tree example is gnome-shell, budgie relevant WM could be another if it really uses mutter itself like this. All main tree gnome-shell since 3.26 (earlier used external cogl/clutter, not mutter fork) have such a subslot depend as well.
So you need mutter-3.28 for that budgie version, apprently. I've removed it from main tree, as nothing in there needs it anymore, as gnome-shell-3.28 was removed as well.
It can't be co-installed with a different gnome-shell version, either.
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
Rockford The Roe
n00b
n00b


Joined: 21 Mar 2019
Posts: 15
Location: Illinois

PostPosted: Tue Apr 16, 2019 2:14 pm    Post subject: Reply with quote

So I did some digging and I compiled it with Mutter 3.30 support provided by Ubuntu Budgie.

https://github.com/UbuntuBudgie/budgie-desktop/tree/mutter330reduxII

Marking as solved.
_________________
"UNIX is very simple, it just needs a genius to understand its simplicity." -Dennis Ritchie
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum