Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Login OK, startx: Kiste friert ein (aber ssh läuft)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
guru meditation
n00b
n00b


Joined: 18 Mar 2018
Posts: 26
Location: Planet Earth

PostPosted: Sun Apr 14, 2019 5:36 am    Post subject: [gelöst] Login OK, startx: Kiste friert ein (aber ssh läuft) Reply with quote

Ich habe hier eine Kiste mit Ryzen CPU und VEGA10-Karte drin. Als Kernel habe ich 4.19.27-r1 und 5.0.7 probiert.

Gentoo ist so konfiuriert, daß ich mich über Kommandozeile anmelde und dann X/LXDE mit startx aufrufe. Dazu ist die Datei .xinitrc mit "exec startlxde" in ~ (home) abgelegt.

Bereits beim Start lädt der Kernel den amdgpu-Treiber und schaltet auf 4K-Auflösung.

Mit startx friert dann die ganze Kiste ein (Maus, Tastatur, Power-Button), der Desktop mit der Leiste ist aber schon zu sehen (inkl. Meldungen über noch fehlende User-Verzeichnisse. Bei direktem Aufruf von X bleibt der komplette Bildschirm schwarz – ebenso bei Angabe einer mit "X -configure" erzeugten und bearbeiteten Liste).

Ich kann mich aber von einer anderen Kiste im Netz aus über ssh anmelden und die Ryzen-Kiste neustarten.

Das LXDE- sowie MESA-Protokoll in ~/.config/irgendwas geben mit 0 Bytes nichts her. Xorg.log sieht so aus:
Code:
X.Org X Server 1.20.3
X Protocol Version 11, Revision 0

[   125.892] (**) ModulePath set to "/usr/lib64/xorg/modules"
[   125.892] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   125.892] (WW) Disabling Mouse0
[   125.892] (WW) Disabling Keyboard0
[   125.892] (II) Loader magic: 0x55a1c48e1c80
[   125.892] (II) Module ABI versions:
[   125.892]    X.Org ANSI C Emulation: 0.4
[   125.892]    X.Org Video Driver: 24.0
[   125.892]    X.Org XInput driver : 24.1
[   125.892]    X.Org Server Extension : 10.0



Irgendwie kommt mir das komisch vor:
[ 125.892] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 125.892] (WW) Disabling Mouse0
[ 125.892] (WW) Disabling Keyboard0

Weiß jemand Rat?


Last edited by guru meditation on Sun Apr 14, 2019 7:08 pm; edited 2 times in total
Back to top
View user's profile Send private message
grumblebear
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2008
Posts: 141

PostPosted: Sun Apr 14, 2019 8:11 am    Post subject: Reply with quote

Ich sehe hier nirgends, dass der libinput-Treiber geladen wird, der heutzutage für Dinge wie Tastatur und Maus verwendet wird. Also in der make.conf
Code:
INPUT_DEVICES="libinput"
eintragen und emerge -uND @world anwerfen. Mit Treiber sollten Maus und Tastatur auch funktionieren.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3688
Location: Hamburg

PostPosted: Sun Apr 14, 2019 2:46 pm    Post subject: Reply with quote

grumblebear wrote:
Ich sehe hier nirgends, dass der libinput-Treiber geladen wird, der heutzutage für Dinge wie Tastatur und Maus verwendet wird. Also in der make.conf
Code:
INPUT_DEVICES="libinput"
eintragen und emerge -uND @world anwerfen. Mit Treiber sollten Maus und Tastatur auch funktionieren.
Ich habe noch
Code:
INPUT_DEVICES="evdev libinput"
, ist evdev (auch schon wieder) veraltet?
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Sun Apr 14, 2019 3:56 pm    Post subject: Reply with quote

libinput ist der Übergang zu Wayland und damit auch die Ablösung von evdev.

Allerdings hab ich mit libinput diverse Probleme, dass libinput sich manchmal mein Touchpad krallt und der synaptics-Treiber nicht geladen werden kann.

Eine konkreiten Vorteil von libinput hab ich bisher noch nicht entdecken können.
Back to top
View user's profile Send private message
guru meditation
n00b
n00b


Joined: 18 Mar 2018
Posts: 26
Location: Planet Earth

PostPosted: Sun Apr 14, 2019 7:07 pm    Post subject: Reply with quote

Danke!

Aua *klatschgegenStirn*, es lag am INPUT_DEVICES. Da hatte ich alles möglich angegeben, nur kein libinput.

Es sollte ja auch ohne explizite Angaben von INPUT_DEVICES in make.conf funzen, oder? Zumindest habe ich mir darüber in der Vergangenheit keine Sorgen gemacht, und X11 lief auch so.

Nebenbei: Ein emerge -uND brachte nur sinngemäß ein "kein Paket muß neu installiert werden". Das kommt davon, wenn man sämtliche Pakete als oneshot installiert, und die world-Liste leer ist :P
Aber dank ordentlicher Doku habe ich die explizit installierten Pakete mit emerge -nq einfach in world übernommen, ohne sie neu kompilieren zu müssen.

Als LXDE-Nutzer muß ich mir über Wayland noch keine Gedanken machen, oder?
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Tue Apr 16, 2019 6:59 pm    Post subject: Reply with quote

Der Xorg-Server wird wohl noch ein paar Jahre lang am Leben bleiben. Bei den ganzen Enterprise-Distributionen (RHEL, SLES) dürften noch gar keine Waylandkomponenten im Einsatz sein.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum