Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Gelöst] Kein Mount und USB-Platten in PCManFM/LXDE
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
guru meditation
n00b
n00b


Joined: 18 Mar 2018
Posts: 26
Location: Planet Earth

PostPosted: Mon Apr 15, 2019 11:55 pm    Post subject: [Gelöst] Kein Mount und USB-Platten in PCManFM/LXDE Reply with quote

[Lösung: USE-Flag automount bzw. udisks für libfm]

In Ubuntu/Debian/weißderGeier schiebe ich eine SD-Karte rein und das Teil wird automatisch in /media eingebunden.

Ich habe jetzt Skript aus
https://unix.stackexchange.com/questions/78276/automount-usb-sticks-on-gentoo
sowie Installation von autofs, udiskie etc. erfolglos ausprobiert.

Weiß der Geier, wie alt die zugehörigen Dokus sind.

Bevor ich jetzt noch mit mdev/udev/eudev rumspiele – welcher Daemon bzw. welches Programm ist unter X für das "Automount" verantwortlich?

eudev und gvfs sind installiert, ebenso die entsprechenden Dateiformate, das manuelle Einbinden klappt einwandfrei… nur wie geht das unter X11 automatisch?


Last edited by guru meditation on Wed Apr 17, 2019 12:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Tue Apr 16, 2019 7:46 am    Post subject: Reply with quote

Ist abhängig davon was du wünscht, die großen DEs wie Gnome oder KDE haben das out-of-the-box eingebaut, bei den anderen weiß ich das nicht.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
guru meditation
n00b
n00b


Joined: 18 Mar 2018
Posts: 26
Location: Planet Earth

PostPosted: Tue Apr 16, 2019 1:59 pm    Post subject: Reply with quote

Ich hab hier LXDE laufen, da müßte doch was mit gvfs gehen…
Back to top
View user's profile Send private message
guru meditation
n00b
n00b


Joined: 18 Mar 2018
Posts: 26
Location: Planet Earth

PostPosted: Wed Apr 17, 2019 11:59 am    Post subject: Reply with quote

Überschreiben die USE-Flags in package.use eigentlich die Vorgaben des Maintainers komplett oder haben lediglich die in package.use angegebenen Flags eine höhere Priorität?

Warum ich frage: Beim ursprünglichen Erstellen von lxde-meta hat mir Portage aufgetragen, folgende Zeile einzufügen:
Code:
>=x11-libs/libfm-1.2.5 gtk


Klingelt's? Da fehlt die automount-Option. Folglich kann ich noch so lange rumspielen, es wird ohne diese Option nix eingebunden.

Fehler gefunden und behoben.

package.use sieht für die Pakete nun so aus:
Code:
>=x11-libs/libfm-1.2.5 gtk automount
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Wed Apr 17, 2019 12:13 pm    Post subject: Reply with quote

die Priorität vom kleinsten zum höchsten sind die folgenden:

- default ebuild-USE-Flags
- profile USE-Flags
- make.conf USE Flags
- package.use USE-Flags
- Environment USE-Flags

Alle additional.
automount auf libfm z.B. ist im profile nicht gesetzt.

Solange nichts anderes dran steht wird nichts deaktiviert was vorher aktiviert wurde, solange es nicht explizit angegeben wird.

Was ich empfehlen würde, ist ein Program wie ufed. das zeigt dir relativ einfach an welche USE-Flags bis make.conf aktiviert sind und welche per profile gesetzt sind und so. nützliches Tool.

Man kann übrigens "-*" angeben, was alles aus den vorherigen Stufen deaktiviert (in make.conf oder Environment USE wäre es auf alles. in package.use für das Packet für welches es angegeben wird)

Viel Erfolg.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic


Last edited by Max Steel on Thu Apr 18, 2019 11:53 am; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Thu Apr 18, 2019 10:00 am    Post subject: Reply with quote

guru meditation wrote:
Überschreiben die USE-Flags in package.use eigentlich die Vorgaben des Maintainers komplett oder haben lediglich die in package.use angegebenen Flags eine höhere Priorität?

USE (und auch FEATURES) sind inkrementelle Variablen.
Und ja, ein Eintrag in package.use hat eine höhere Priorität als die ggf im Profil gesetzten, oder/und der ggf im ebuild gesetzten default enabled USE (das sind die im IUSE mit einem "+" vorm Flag) gesetzten.
Die Reihenfolge wie dein System USE-Flags nutzt kannst du dir zb via `portageq envvar USE_ORDER`
oder auch in der `emerge --info -v` ausgeben lassen, und einsehen.

Quote:
Warum ich frage: Beim ursprünglichen Erstellen von lxde-meta hat mir Portage aufgetragen, folgende Zeile einzufügen:
Code:
>=x11-libs/libfm-1.2.5 gtk


Klingelt's? Da fehlt die automount-Option. Folglich kann ich noch so lange rumspielen, es wird ohne diese Option nix eingebunden.

Fehler gefunden und behoben.

package.use sieht für die Pakete nun so aus:
Code:
>=x11-libs/libfm-1.2.5 gtk automount

Hier, beim libfm-1.2.5.ebuild ist zb das automount USE-Flag schon im ebuild default enabled
Code:
grep IUSE `equery w x11-libs/libfm-1.2.5`
IUSE="+automount debug doc examples exif gtk udisks vala"
sprich das solltest du normal nicht selbst setzen müssen.
Vermutlich hast du das Flag an anderer Stelle selbst disabled.
Schau zb mal via `grep -r automount /etc/portage/`
wenn da nichts ist, dann hast du vermutlich tatsächlich irgendwo sowas wie "-*" gesetzt. (letzteres tut mal eigentlich nur wenn man auf Schmerzen steht ;))
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum