Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201904-22 ] OpenDKIM
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Tue Apr 23, 2019 2:26 am    Post subject: [ GLSA 201904-22 ] OpenDKIM Reply with quote

Gentoo Linux Security Advisory

Title: OpenDKIM: Root privilege escalation (GLSA 201904-22)
Severity: normal
Exploitable: remote
Date: 2019-04-22
Bug(s): #629914
ID: 201904-22

Synopsis

A vulnerability was discovered in Gentoo's ebuild for OpenDKIM
which could lead to root privilege escalation.


Background

A community effort to develop and maintain a C library for producing
DKIM-aware applications and an open source milter for providing DKIM
service.


Affected Packages

Package: mail-filter/opendkim
Vulnerable: < 2.10.3-r8
Unaffected: >= 2.10.3-r8
Architectures: All supported architectures


Description

It was discovered that Gentoo’s OpenDKIM ebuild does not properly set
permissions or place the pid file in a safe directory.


Impact

A local attacker could escalate privileges.

Workaround

Users should ensure the proper permissions are set as discussed in the
referenced bugs.


Resolution

All OpenDKIM users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=mail-filter/opendkim-2.10.3-r8"
   
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum