Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] [udevd] conflicting device node
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
sdauth
n00b
n00b


Joined: 19 Sep 2018
Posts: 14

PostPosted: Thu Apr 25, 2019 12:50 pm    Post subject: [SOLVED] [udevd] conflicting device node Reply with quote

EDIT -SOLVED- :
Quote:
Sometimes I overcomplicate things :oops:
Since I am not booting on the RAID device (it is pure storage and my / is on another disk, adding lvm & mdadm to initramfs wasn't needed.. I also deleted "dolvm domdadm" from my kernel command line. Now the RAID volume mounts fine, without udevd complaining.

Hello,
I finally finished my Gentoo install, everything works fine except this minor issue for which I can't find any answer.
Gentoo is installed on /dev/sda1 and I use a mdadm RAID6 with 8 disks for file storage. (it uses lvm)

fstab :
Code:
/dev/raid/storage   /mnt/storage   ext4   defaults,x-gvfs-show,x-gvfs-name=storage   0 0


mdadm :
Code:
ARRAY /dev/md/0  metadata=1.2 UUID=xxxxxxx name=localhost:0


genkernel.conf :
Code:
LVM="yes"
MDADM="yes"


With this config, it works fine, the raid is correcttly assembled and mounted at boot and I can access my files without any issue but looking at dmesg, this error is showing up :

Code:
udevd[3380]: conflicting device node '/dev/mapper/raid-storage' found, link to '/dev/dm-0' will not be created


How to solve this ?

Thanks for your help
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum