Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Graphical boot fails after switching to amdgpu
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Jt0
n00b
n00b


Joined: 28 Oct 2018
Posts: 32

PostPosted: Tue Apr 30, 2019 2:41 am    Post subject: [SOLVED] Graphical boot fails after switching to amdgpu Reply with quote

I'm trying to get my desktop upgraded to a 5.x kernel and would like to move from radeon to amdgpu for my graphics card driver. I followed the directions in the wiki and when I rebooted, the boot failed at the handoff from whatever simple graphical driver is used at the beginning of boot to the amdgpu driver.
I rebooted with a working 4.20 kernel and changed the firmware files from the "radeon" variants (listed next to TAHITI in the table of firmware to include) to the "amdgpu" variants. The TAHITI_uvd.bin and TAHITI_vce.bin files are missing from the amdgpu firmware directory, so I left those off completely. Upon rebooting the handoff to amdgpu was successful, but SDDM won't start. Since the problem was caused by a change in kernel configuration, I thought this subforum would be the right place for this question.

I've tried adding in the missing firmware files from the radeon firmware directory but that doesn't change anything. I've also tried adding "radeon" to my VIDEO_CARDS section of make.conf as suggested in the troubleshooting section of the wiki guide, but that didn't help anything. When I try "/etc/init.d/xdm start" I get a message saying xdm was already started. When I try to restart xdm the screen goes blank for a split second then returns to the terminal.
When I try "startx" I get
Code:
Fatal server error:
(EE) AddScreen/ScreenInit failed for driver 0


I'm not sure what else to try. Going back to the radeon driver is certainly an option, but as long as the support is there in amdgpu I'd like to make it work.

Specifically, from the wiki guide, I:
  • Detected the graphics card and made sure it was found
  • Already had linux-firmware installed
  • Set all kernel options listed in the "Kernel" section as built in, except for "Enable amdgpu support for CIK parts" and "Enable Audio CoProcessor IP Support"
  • Built in amdgpu/tahiti_{ce,k_smc,mc,me,pfp,rlc,smc}.bin (each written out completely in the kernel config but abbreviated here)
  • Set VIDEO_CARDS="amdgpu radeonsi" in make.conf
  • Rebuilt @world with --changed-use and --deep


I've found a couple of other threads from people with R9 280X's but they didn't seem to be resolved. What else is there to try?


Last edited by Jt0 on Wed May 01, 2019 12:40 am; edited 1 time in total
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 98
Location: Italy/Taranto

PostPosted: Tue Apr 30, 2019 5:34 am    Post subject: Reply with quote

Code:
echo amdgpu/tahiti_{ce,k_smc,mc,me,mec2,mec,pfp,rlc,sdma1,sdma,smc,uvd,vce}.bin
amdgpu/tahiti_ce.bin amdgpu/tahiti_k_smc.bin amdgpu/tahiti_mc.bin amdgpu/tahiti_me.bin amdgpu/tahiti_mec2.bin amdgpu/tahiti_mec.bin amdgpu/tahiti_pfp.bin amdgpu/tahiti_rlc.bin amdgpu/tahiti_sdma1.bin amdgpu/tahiti_sdma.bin amdgpu/tahiti_smc.bin amdgpu/tahiti_uvd.bin amdgpu/tahiti_vce.bin


https://wiki.gentoo.org/wiki/AMDGPU#AMDGPU.2FRadeonSI_drivers_do_not_work

im use Fglrx :
https://wiki.gentoo.org/wiki/Fglrx#Hardware_support

and following this unofficial guide :
http://wiki.cchtml.com/index.php/Gentoo_Installation_Guide
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44153
Location: 56N 3W

PostPosted: Tue Apr 30, 2019 9:30 am    Post subject: Reply with quote

Jt0,

There will be a lot of useful information in dmesg and maybe /var/log/Xorg.0.log

Please pastebin both from your broken Gentoo.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Jt0
n00b
n00b


Joined: 28 Oct 2018
Posts: 32

PostPosted: Tue Apr 30, 2019 11:42 am    Post subject: Reply with quote

ilnanny,
I'm not sure what to make of the code block you posted. I don't have a lot of those files present with sys-kernel/linux-firmware-20190424 installed, just the ones I listed in my first post. I already tried the troubleshooting section you linked to.

NeddySeagoon,

dmesg

Xorg.0.log

I didn't see anything out of the ordinary in dmesg. The xorg log seems to show that a "Radeon" device is being loaded, which is strange because I deleted the 10-radeon.conf file from /usr/share/X11/xorg.conf.d since I thought it was interfering with the 10-amdgpu.conf file in the same directory (I found a thread on Phoronix where this was the solution to the same problem). lspci shows that amdgpu is being used for the graphics card.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44153
Location: 56N 3W

PostPosted: Tue Apr 30, 2019 1:11 pm    Post subject: Reply with quote

Jt0,

Put updating your microcode on your todo list.
Code:
[    0.252186] [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x3a (or later)

There is a wiki page on updating Intel microcode at boot. Its not relevant to your GPU issue.

On the good news front, there are no errors about amdgpu microcode in dmesg.
So far, so good.

Your Xorg log is missing the auto detected list of video drivers, so somewhere in /etc/X11/xorg.conf.d/ its being told to use the radeon driver because
Code:
[     7.228] (II) RADEON: Driver for ATI/AMD Radeon chipsets:


That no longer works because you should have removed kernel support for Radeon when you replaced it with amdgpu.

Poke about in /etc/X11/xorg.conf.d/ and use the amdgpu driver instead.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Jt0
n00b
n00b


Joined: 28 Oct 2018
Posts: 32

PostPosted: Wed May 01, 2019 12:38 am    Post subject: Reply with quote

Thanks, that was exactly what was wrong!

It looks like there are two directories for X11 configuration files, /etc/X11/xorg.conf.d and /usr/share/X11/xorg.conf.d. I guess the /etc directory has higher priority because there was a 20-radeon.conf file sitting in there. I commented out each line in the file and rebooted, and not only did it boot right into the graphical environment, but I also got a good result when checking for my microcode being updated:
Code:
[    0.000000] microcode: microcode updated early to revision 0x43, date = 2019-03-01


I'm pretty sure the old kernel didn't have microcode loading enabled, because when I rebooted with it after installing the microcode and running grub-mkconfig it still didn't have the microcode loaded. The new kernel loads it without a problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum