Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] buildkernel/genkernel, but won't build
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
raddaqii
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2005
Posts: 102
Location: Berlin, Old Europe

PostPosted: Sat May 04, 2019 7:23 pm    Post subject: [SOLVED] buildkernel/genkernel, but won't build Reply with quote

Running a Sakaki based system that impliocitly uses genkernel to update kernels, today I found it won't anymore:


Code:

$ buildkernel --menuconfig
...
...
* Building linux-4.20.10-gentoo (pass 1 - dummy initramfs)...
scripts/kconfig/conf  --syncconfig Kconfig
  HOSTCC  arch/x86/tools/relocs_32.o
  HOSTCC  arch/x86/tools/relocs_64.o
  HOSTCC  arch/x86/tools/relocs_common.o
  HOSTLD  arch/x86/tools/relocs
  CC      kernel/bounds.s
  CC      arch/x86/kernel/asm-offsets.s
  CALL    scripts/checksyscalls.sh
  DESCEND  objtool
make[4]: *** Keine Regel vorhanden, um das Ziel „/usr/include/bits/byteswap-16.h“,
  benötigt von „/usr/src/linux-4.20.10-gentoo/tools/objtool/fixdep.o“, zu erstellen.  Schluss.
make[3]: *** [Makefile:43: /usr/src/linux-4.20.10-gentoo/tools/objtool/fixdep-in.o] Fehler 2
make[2]: *** [/usr/src/linux-4.20.10-gentoo/tools/build/Makefile.include:4: fixdep] Fehler 2
make[1]: *** [Makefile:64: objtool] Fehler 2
make: *** [Makefile:1687: tools/objtool] Fehler 2


The last major change I did on the system was upgrading vo GCC 8.2. Do you have a clue what is happening?

My guess would be to run buildkernel --clean before I start another run. Following https://github.com/sakaki-/buildkernel, does that sound reasonable?
_________________
--
Gentoo from 2004.3

Oh, took a new home in the fediverse: find me in the stream on pluspora.com: https://pluspora.com/tags/gentoo
Back to top
View user's profile Send private message
raddaqii
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2005
Posts: 102
Location: Berlin, Old Europe

PostPosted: Sun May 05, 2019 10:45 am    Post subject: Reply with quote

So yes, running

Code:
$ buildkernel --clean


does indeed solve the issue. Kernels are building just fine after that.
_________________
--
Gentoo from 2004.3

Oh, took a new home in the fediverse: find me in the stream on pluspora.com: https://pluspora.com/tags/gentoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum