Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Problems getting SD card reader working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
UnclePa
n00b
n00b


Joined: 05 Apr 2019
Posts: 19

PostPosted: Tue May 21, 2019 10:50 pm    Post subject: [SOLVED] Problems getting SD card reader working Reply with quote

New Gentoo install. I've had other distros on this computer without this problem. It doesn't seem to recognize my SD card reader. I think the relevant device is:

lspci -v -nn -->
...
Code:
00:14.7 SD Host controller [0805]: Advanced Micro Devices, Inc. [AMD] FCH SD Fl$
        Subsystem: Dell FCH SD Flash Controller [1028:067e]
        Flags: bus master, 66MHz, medium devsel, latency 39, IRQ 16
        Memory at f0b4c000 (64-bit, non-prefetchable) [size=256]
        Kernel driver in use: sdhci-pci
        Kernel modules: sdhci_pci

...

I ran a program that looks for event activity and something happens when I plug a card in, but I don't see anything in /dev that I could try to mount. I think one distro listed it as a /dev/sd_ and another something like /dev/mmc but I don't remember exactly. I've tried about everything I could find on the web but am out of ideas.

[Moderator edit: added [code] tags to preserve output layout. -Hu]


Last edited by UnclePa on Thu May 23, 2019 1:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
duane
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2002
Posts: 132
Location: Oklahoma City

PostPosted: Wed May 22, 2019 2:14 am    Post subject: Reply with quote

Did you see this thread?

https://forums.gentoo.org/viewtopic-t-944600-start-0.html

The advice that leaped out at me was to compile all the mmc drivers as modules and try them one by one. I also thought it interesting that the device wasn't identified correctly.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3083

PostPosted: Wed May 22, 2019 5:34 am    Post subject: Re: Problems getting SD card reader working Reply with quote

UnclePa wrote:
I ran a program that looks for event activity and something happens when I plug a card in, but I don't see anything in /dev that I could try to mount. I think one distro listed it as a /dev/sd_ and another something like /dev/mmc but I don't remember exactly. I've tried about everything I could find on the web but am out of ideas.

What are blkid and lsblk telling about?
Back to top
View user's profile Send private message
UnclePa
n00b
n00b


Joined: 05 Apr 2019
Posts: 19

PostPosted: Thu May 23, 2019 2:44 am    Post subject: Reply with quote

No, duane, I missed that one. That looks just like my situation as lsusb lists a rts5129 so I'll add that module and see what happens. Thanks!
Back to top
View user's profile Send private message
UnclePa
n00b
n00b


Joined: 05 Apr 2019
Posts: 19

PostPosted: Thu May 23, 2019 1:19 pm    Post subject: Reply with quote

Adding rtsx_usb and rtsx_usb_sdmmc seems to have fixed the problem. Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum