Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
RPCS3 is unable to compile from pinkpiee
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
picarica
n00b
n00b


Joined: 11 Aug 2018
Posts: 70

PostPosted: Thu May 23, 2019 4:00 pm    Post subject: RPCS3 is unable to compile from pinkpiee Reply with quote

it does not work i tired compiling with all flags disable or with all enabled except gdb

here is --info

-pqv is heeeere


and build log is here


i need my vulkan flag enabled i thought that was problem but i was wrong do u know how to fix ?

in the meantime i tired jm-overlay it uses llvm version 4. but i had similar error while compiling rpcs3 but it was related to vulkan this time

build.log from jm's overlay

--info of jm's overlay
and finally -pqv


Last edited by picarica on Thu May 23, 2019 5:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21675
Location: here

PostPosted: Thu May 23, 2019 5:10 pm    Post subject: Reply with quote

Code:
CMake Warning at 3rdparty/llvm.cmake:29 (find_package):
  Could not find a configuration file for package "LLVM" that is compatible
  with requested version "9.0".

It seems that program need llvm-9 (in portage I think is 9999). Try to disable llvm use flag
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
picarica
n00b
n00b


Joined: 11 Aug 2018
Posts: 70

PostPosted: Thu May 23, 2019 5:12 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Code:
CMake Warning at 3rdparty/llvm.cmake:29 (find_package):
  Could not find a configuration file for package "LLVM" that is compatible
  with requested version "9.0".

It seems that program need llvm-9 (in portage I think is 9999). Try to disable llvm use flag


didnt build again here is build.log
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21675
Location: here

PostPosted: Thu May 23, 2019 5:19 pm    Post subject: Reply with quote

picarica wrote:
didnt build again here is build.log

Version 0.0.6 need llvm-8 that is in tree, try with it.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
picarica
n00b
n00b


Joined: 11 Aug 2018
Posts: 70

PostPosted: Thu May 23, 2019 5:47 pm    Post subject: Reply with quote

fedeliallalinea wrote:
picarica wrote:
didnt build again here is build.log

Version 0.0.6 need llvm-8 that is in tree, try with it.


where is verions 0.0.6 ? you mena version of rpcs3 right ? there is only 0.0.5 and then 9999 which is the one i tired , now i am compiling llvm 9999 so i hope it will work with it as i said i tried version 0.0.5 i edited my post with new info and u sent u build.log from 9999 fron pinkipiee (0.0.6i) i hope


you kinda confused me rn
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21675
Location: here

PostPosted: Thu May 23, 2019 6:02 pm    Post subject: Reply with quote

rpcs3-9999 require llvm-9 but this version isn't in tree, not sure if llvm-9999 can be considered version 9.
rpcs3-0.0.6 require llvm-8 that is in portage.

The error in rpcs3-0.0.5 is that the module Vulkan-LoaderAndValidationLayers is a deprecated repository and commit 28d93dfc0f24d65237fd773d74a284bf6e399222 cannot be find.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
picarica
n00b
n00b


Joined: 11 Aug 2018
Posts: 70

PostPosted: Thu May 23, 2019 6:09 pm    Post subject: Reply with quote

fedeliallalinea wrote:
rpcs3-9999 require llvm-9 but this version isn't in tree, not sure if llvm-9999 can be considered version 9.
rpcs3-0.0.6 require llvm-8 that is in portage.

The error in rpcs3-0.0.5 is that the module Vulkan-LoaderAndValidationLayers is a deprecated repository and commit 28d93dfc0f24d65237fd773d74a284bf6e399222 cannot be find.


ye but where is version 0.0.06 i dont see it anywhere but i merged that llvm 9999 the error is different but still unable to compile

you can see it here the build log

and yes version llvm 8 is in portage i have it right now but i dont see 0.0.6 anywhere

so the version 0.0.5 isnt working beacause old repositorys or something i think i understand
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21675
Location: here

PostPosted: Thu May 23, 2019 6:26 pm    Post subject: Reply with quote

picarica wrote:
and yes version llvm 8 is in portage i have it right now but i dont see 0.0.6 anywhere

You can try to simply rename ebuild in rpcs3-0.0.6.ebuild in your local overlay.
Sorry about the confusing.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
picarica
n00b
n00b


Joined: 11 Aug 2018
Posts: 70

PostPosted: Thu May 23, 2019 6:41 pm    Post subject: Reply with quote

fedeliallalinea wrote:
picarica wrote:
and yes version llvm 8 is in portage i have it right now but i dont see 0.0.6 anywhere

You can try to simply rename ebuild in rpcs3-0.0.6.ebuild in your local overlay.
Sorry about the confusing.


so i can just simply
Code:
cd /var/lib/layman/pinkpieea/games-emulation/rpcs3
doas cp rpcs3-9999.ebuild rpcs3-0.0.6.ebuild
// then
doas ebuild rpcs3-0.0.6.ebuild digest
doas ebuild rpcs3-0.0.6.ebuild clean manifest merge

???
because that doesnt work, can you be more specific ?

do i really have to make my own local repository? isnt this easier? but i dont get how make it fetch 0.0.6 version
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21675
Location: here

PostPosted: Thu May 23, 2019 7:04 pm    Post subject: Reply with quote

picarica wrote:
so i can just simply
Code:
cd /var/lib/layman/pinkpieea/games-emulation/rpcs3
doas cp rpcs3-9999.ebuild rpcs3-0.0.6.ebuild
// then
doas ebuild rpcs3-0.0.6.ebuild digest
doas ebuild rpcs3-0.0.6.ebuild clean manifest merge

???
because that doesnt work, can you be more specific ?

This work but next overlay sync you can lost the ebuild (or if you delete overlay)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 17854

PostPosted: Thu May 23, 2019 7:05 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
_________________

Believing I had supernatural powers I slammed into a brick wall.
I said hey, is this my problem? Is this my fault?
Back to top
View user's profile Send private message
picarica
n00b
n00b


Joined: 11 Aug 2018
Posts: 70

PostPosted: Fri May 24, 2019 1:04 pm    Post subject: Reply with quote

fedeliallalinea wrote:
picarica wrote:
so i can just simply
Code:
cd /var/lib/layman/pinkpieea/games-emulation/rpcs3
doas cp rpcs3-9999.ebuild rpcs3-0.0.6.ebuild
// then
doas ebuild rpcs3-0.0.6.ebuild digest
doas ebuild rpcs3-0.0.6.ebuild clean manifest merge

???
because that doesnt work, can you be more specific ?

This work but next overlay sync you can lost the ebuild (or if you delete overlay)


i did that but it didnt worked
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21675
Location: here

PostPosted: Fri May 24, 2019 3:23 pm    Post subject: Reply with quote

picarica wrote:
i did that but it didnt worked

What not work? The creation of new ebuild or the compilation?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
picarica
n00b
n00b


Joined: 11 Aug 2018
Posts: 70

PostPosted: Fri May 24, 2019 5:29 pm    Post subject: Reply with quote

fedeliallalinea wrote:
picarica wrote:
i did that but it didnt worked

What not work? The creation of new ebuild or the compilation?


i have succsefuklly made the new ebuild but the merge procces failed again i am putting the results here:

--info is here

-pqv is here


build.log is here


and this is the .ebuild that i edited by your command the file was called rpcs3-0.0.6.ebuild
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21675
Location: here

PostPosted: Sat May 25, 2019 11:12 am    Post subject: Reply with quote

In function src_configure add CMAKE_BUILD_TYPE="RELEASE"
Code:
src_configure() {
    CMAKE_BUILD_TYPE="RELEASE"

    local mycmakeargs=(
        -DWITHOUT_LLVM="$(usex llvm OFF ON)"
        -DUSE_ALSA="$(usex alsa)"
        -DUSE_PULSE="$(usex pulseaudio)"
        -DUSE_LIBEVDEV="$(usex evdev)"
        -DUSE_VULKAN="$(usex vulkan)"
        -DWITH_GDB="$(usex gdb)"
        -DUSE_SYSTEM_LIBPNG=ON
        -DUSE_SYSTEM_FFMPEG=ON
    )
    cmake-utils_src_configure
}


EDIT: change also llvm dependency from
Code:
llvm? ( sys-devel/llvm:4 )

to
Code:
llvm? ( sys-devel/llvm:8 )

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
picarica
n00b
n00b


Joined: 11 Aug 2018
Posts: 70

PostPosted: Tue May 28, 2019 10:56 pm    Post subject: Reply with quote

fedeliallalinea wrote:
In function src_configure add CMAKE_BUILD_TYPE="RELEASE"
Code:
src_configure() {
    CMAKE_BUILD_TYPE="RELEASE"

    local mycmakeargs=(
        -DWITHOUT_LLVM="$(usex llvm OFF ON)"
        -DUSE_ALSA="$(usex alsa)"
        -DUSE_PULSE="$(usex pulseaudio)"
        -DUSE_LIBEVDEV="$(usex evdev)"
        -DUSE_VULKAN="$(usex vulkan)"
        -DWITH_GDB="$(usex gdb)"
        -DUSE_SYSTEM_LIBPNG=ON
        -DUSE_SYSTEM_FFMPEG=ON
    )
    cmake-utils_src_configure
}


EDIT: change also llvm dependency from
Code:
llvm? ( sys-devel/llvm:4 )

to
Code:
llvm? ( sys-devel/llvm:8 )


it fialed again, i did waht u suggester here is my ebuild file its just like u said, just to make sure i am using stefantalpalaru overlay beacau'se pinkipiee's didnt had llvm:4 dependency but llvm:9 i think

i am putting following logs from the merge

build.log

--info

-pqv
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21675
Location: here

PostPosted: Wed May 29, 2019 5:38 am    Post subject: Reply with quote

I used rpcs3-0.0.5.ebuild from jm-overlay, I renamed it in rpcs3-0.0.6.ebuild and applied my proposed changes and program has compiled fine.
rpcs3-0.0.6.ebuild:
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils git-r3

DESCRIPTION="Open source PlayStation 3 emulator"
HOMEPAGE="https://rpcs3.net/"

EGIT_REPO_URI="https://github.com/RPCS3/rpcs3.git"
EGIT_COMMIT="v${PV}"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="alsa pulseaudio evdev vulkan +llvm gdb libav"

RDEPEND=">=dev-qt/qtcore-5.10:5=
   >=dev-qt/qtgui-5.10:5=
   >=dev-qt/qtdbus-5.10:5=
   >=dev-qt/qtwidgets-5.10:5=
   media-libs/libpng:0=
   virtual/opengl
   virtual/glu
   media-libs/glew:0=
   x11-libs/libX11
   virtual/libudev:=
   sys-libs/zlib:=
   media-libs/openal
   llvm? ( sys-devel/llvm:8 )
   alsa? ( media-libs/alsa-lib )
   pulseaudio? ( media-sound/pulseaudio )
   evdev? ( dev-libs/libevdev )
   vulkan? ( media-libs/vulkan-loader )
   libav? ( media-video/libav:= )
   !libav? ( media-video/ffmpeg:= )"
DEPEND="${RDEPEND}
   >=sys-devel/gcc-5.1"

DOCS=( README.md CONTRIBUTING.md )

src_configure() {
   CMAKE_BUILD_TYPE="RELEASE"

   local mycmakeargs=(
      -DWITHOUT_LLVM="$(usex llvm OFF ON)"
      -DUSE_ALSA="$(usex alsa)"
      -DUSE_PULSE="$(usex pulseaudio)"
      -DUSE_LIBEVDEV="$(usex evdev)"
      -DUSE_VULKAN="$(usex vulkan)"
      -DWITH_GDB="$(usex gdb)"
      -DUSE_SYSTEM_LIBPNG=ON
      -DUSE_SYSTEM_FFMPEG=ON
   )
   cmake-utils_src_configure
}

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
argen
n00b
n00b


Joined: 26 Apr 2019
Posts: 23

PostPosted: Wed May 29, 2019 7:30 am    Post subject: Reply with quote

fedeliallalinea wrote:
rpcs3-9999 require llvm-9 but this version isn't in tree, not sure if llvm-9999 can be considered version 9.


I run llvm-9999, it is currently considered llvm 9.
Back to top
View user's profile Send private message
picarica
n00b
n00b


Joined: 11 Aug 2018
Posts: 70

PostPosted: Wed May 29, 2019 12:26 pm    Post subject: Reply with quote

fedeliallalinea wrote:
I used rpcs3-0.0.5.ebuild from jm-overlay, I renamed it in rpcs3-0.0.6.ebuild and applied my proposed changes and program has compiled fine.
rpcs3-0.0.6.ebuild:
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils git-r3

DESCRIPTION="Open source PlayStation 3 emulator"
HOMEPAGE="https://rpcs3.net/"

EGIT_REPO_URI="https://github.com/RPCS3/rpcs3.git"
EGIT_COMMIT="v${PV}"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="alsa pulseaudio evdev vulkan +llvm gdb libav"

RDEPEND=">=dev-qt/qtcore-5.10:5=
   >=dev-qt/qtgui-5.10:5=
   >=dev-qt/qtdbus-5.10:5=
   >=dev-qt/qtwidgets-5.10:5=
   media-libs/libpng:0=
   virtual/opengl
   virtual/glu
   media-libs/glew:0=
   x11-libs/libX11
   virtual/libudev:=
   sys-libs/zlib:=
   media-libs/openal
   llvm? ( sys-devel/llvm:8 )
   alsa? ( media-libs/alsa-lib )
   pulseaudio? ( media-sound/pulseaudio )
   evdev? ( dev-libs/libevdev )
   vulkan? ( media-libs/vulkan-loader )
   libav? ( media-video/libav:= )
   !libav? ( media-video/ffmpeg:= )"
DEPEND="${RDEPEND}
   >=sys-devel/gcc-5.1"

DOCS=( README.md CONTRIBUTING.md )

src_configure() {
   CMAKE_BUILD_TYPE="RELEASE"

   local mycmakeargs=(
      -DWITHOUT_LLVM="$(usex llvm OFF ON)"
      -DUSE_ALSA="$(usex alsa)"
      -DUSE_PULSE="$(usex pulseaudio)"
      -DUSE_LIBEVDEV="$(usex evdev)"
      -DUSE_VULKAN="$(usex vulkan)"
      -DWITH_GDB="$(usex gdb)"
      -DUSE_SYSTEM_LIBPNG=ON
      -DUSE_SYSTEM_FFMPEG=ON
   )
   cmake-utils_src_configure
}


yes i didit everything u did i even made my own local overlay and it was compiling very loong i thought it was finally working but then it crashed again, the compilaton and no furrther acces , i am posting the output of commadn now

--info and -pqv in one, i hope its easy to read

and here is build.log i had to send it thorught firefox send beacuse it has 2M and cant use bpaste or pastebin
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21675
Location: here

PostPosted: Wed May 29, 2019 5:33 pm    Post subject: Reply with quote

The only difference is that I compiled with gcc-8.3.0. Just for info I also installed the program an run without problem but change the DOCS line in ebuild from
Code:
DOCS=( README.md CONTRIBUTING.md )

to
Code:
DOCS=( README.md )

I see also that package (version 0.0.6) compile also with llvm-7 so I don't know what is the minor version required
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
picarica
n00b
n00b


Joined: 11 Aug 2018
Posts: 70

PostPosted: Thu May 30, 2019 6:51 pm    Post subject: Reply with quote

fedeliallalinea wrote:
The only difference is that I compiled with gcc-8.3.0. Just for info I also installed the program an run without problem but change the DOCS line in ebuild from
Code:
DOCS=( README.md CONTRIBUTING.md )

to
Code:
DOCS=( README.md )

I see also that package (version 0.0.6) compile also with llvm-7 so I don't know what is the minor version required


that can be issue with me i use gcc 7.4 ill try gcc 84.

EDIT: it didnt worked here is result with gcc 8.4 i even tried gcc 9 but no results too

here is builkd.log its little bit longer than last one but still fails in the end

and here is --info and -pqv
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum