Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NVidia drivers again [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 797
Location: Queensland

PostPosted: Sun Jun 02, 2019 8:04 pm    Post subject: NVidia drivers again [SOLVED] Reply with quote

Hello, I've searched for gentoo nvidia and variations, and studied the wiki, but still can't get NVidia hardware working. The closest I got is this; lightdm starts but I can't start a session because no /dev/fb0 is created. Any ideas?
_________________
Michael Mounteney


Last edited by mounty1 on Wed Jun 05, 2019 10:56 am; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7506
Location: Saint Amant, Acadiana

PostPosted: Sun Jun 02, 2019 8:27 pm    Post subject: Reply with quote

32-bit install makes me think the hardware is old. Is your nVidia card even supported any more by binary drivers?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 797
Location: Queensland

PostPosted: Sun Jun 02, 2019 10:04 pm    Post subject: Not the problem, I reckon Reply with quote

I don't think that's the problem since there's nothing in Xorg.0.log about 32 bitness problems. It just says no /dev/fb0 without saying how that situation arose.
lspci | grep VGA:
01:00.0 VGA compatible controller: NVIDIA Corporation GK208B [GeForce GT 710] (rev a1)

_________________
Michael Mounteney
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4402
Location: Dallas area

PostPosted: Sun Jun 02, 2019 10:21 pm    Post subject: Reply with quote

I don't run nvidia drivers on my card, but you might need to turn on the nvidia fb drivers, look under drivers, graphic cards, framebuffer devices.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
drillsar
n00b
n00b


Joined: 08 Sep 2010
Posts: 33

PostPosted: Mon Jun 03, 2019 12:39 am    Post subject: Reply with quote

what is your use tags?

According to Nvidia site your card can support 430.14. Most likely an issue with Kernel

Under Kernel make sure the following is set; important is to remove everything under graphics support like I mentioned except VGA arbitration and Bootup logo. Don't use Direct Rendering or AGP kernel we will use Nvidia one.

Code:
Kernel Configuration:
[*] Enable loadable module support --->

Processor type and features --->[*] MTRR (Memory Type Range Register) support

Bus options (PCI etc.) --->[*] Mark VGA/VBE/EFI FB as generic system framebuffer

Device Drivers --->
Character devices --->[*] IPMI top-level message handler

Device Drivers ---> (ONLY THINGS THAT SHOULD BE ENABLED UNLESS YOUR CARD IS AGP)
Graphics support --->
-*- VGA Arbitration
[*] Bootup logo

Frame buffer Devices ---> (ONLY THINGS THAT SHOULD BE ENABLED)
<*> Support for frame buffer devices --->
<*> Enable Video Mode Handling Helpers
<*> Enable Tile blitting support
<*> Simple frame buffer support

Of course after you build kernel you need to recompile nvidia-driver

Code:
emerge @module-rebuild

reboot and use pastebin for dmesg post results
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2650
Location: Canada

PostPosted: Mon Jun 03, 2019 8:14 am    Post subject: Reply with quote

Jaglover wrote:
32-bit install makes me think the hardware is old. Is your nVidia card even supported any more by binary drivers?



Well. if one downloads drivers from Nvidia site, it surely is, they go back to 76 series. Kernel support is another issue.
Back to top
View user's profile Send private message
hhfeuer
Apprentice
Apprentice


Joined: 28 Jul 2005
Posts: 184

PostPosted: Mon Jun 03, 2019 10:38 am    Post subject: Reply with quote

32bit kernels are no longer supported by the latest nvidia drivers. Please use the 390 legacy release.
https://devtalk.nvidia.com/default/topic/1032650/linux/unix-graphics-feature-deprecation-schedule/
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 797
Location: Queensland

PostPosted: Mon Jun 03, 2019 7:27 pm    Post subject: 32-bit compatible Reply with quote

Answering the question about use tags and version:
$ equery u nvidia-drivers:
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for x11-drivers/nvidia-drivers-390.116-r2:
 U I
 + + X           : Install the X.org driver, OpenGL libraries, XvMC libraries, and VDPAU libraries
 + + acpi        : Add support for Advanced Configuration and Power Interface
 + + compat      : Install non-GLVND libGL for backwards compatibility
 + + driver      : Install the kernel driver module
 + + gtk3        : Install nvidia-settings with support for GTK+ 3
 + + kms         : Enable support for kernel mode setting (KMS)
 - - static-libs : Build static versions of dynamic libraries as well
 + + tools       : Install additional tools such as nvidia-settings
 + + wayland     : Enable dev-libs/wayland backend
So I do have the 390 series drivers. I've updated my .config as per drillsar's recommendations and it is still here. Dmesg otput here. Just in case it's relevant: Xorg.0.log. Thanks for looking.

With the above configuration, I no longer get a lightdm login screen.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
hhfeuer
Apprentice
Apprentice


Joined: 28 Jul 2005
Posts: 184

PostPosted: Mon Jun 03, 2019 7:43 pm    Post subject: Reply with quote

The kernel module now loads fine but the xserver does not find the nvidia DDX. Please try this xorg.conf:
Code:

Section "Files"
  ModulePath  "/usr/lib/xorg/modules"
EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"
    Option         "AllowEmptyInitialConfiguration"
EndSection

and check if nvidia_drv.so is in the path /usr/lib/xorg/modules/drivers. If not, find it and change the ModulePath accordingly.
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 797
Location: Queensland

PostPosted: Tue Jun 04, 2019 7:33 pm    Post subject: This ticket closed Reply with quote

Thanks to everyones help, it's now at the stage where there are no errors reported in /var/log/Xorg.0.log or /var/log/lightdm/* but when Cinnamon starts, it's to the dreaded Cinnamon is running in fallback mode dialog, and no mouse. But that's a separate matter, it seems to me, so I'll open another thread. Thanks to those who got me this far.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
sleepingsun
Guru
Guru


Joined: 03 May 2006
Posts: 384
Location: Bosnia

PostPosted: Tue Jul 09, 2019 7:21 am    Post subject: Reply with quote

Similiar problem with same graphic card cant start graphic mode and found this post and just need inforamation how you put in /etc/portage/make.conf think VIDEO_CARDS="" nvidia, nv or noveaou ?

to do same and recompile kernel and install nvidia-drivers again
_________________
Gentoo is Rocks
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 797
Location: Queensland

PostPosted: Thu Jul 18, 2019 11:23 am    Post subject: Reply with quote

sleepingsun wrote:
Similiar problem with same graphic card cant start graphic mode and found this post and just need inforamation how you put in /etc/portage/make.conf think VIDEO_CARDS="" nvidia, nv or noveaou ?
VIDEO_CARDS="nvidia".

Have a look at my other thread as well.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
mimosinnet
l33t
l33t


Joined: 10 Aug 2006
Posts: 679
Location: Barcelona, Spain

PostPosted: Wed Jul 24, 2019 8:49 am    Post subject: Re: 32-bit compatible Reply with quote

mounty1 wrote:
Answering the question about use tags and version:[code="$ equery u nvidia-drivers"][ Legend : U - final flag setting for installation]
[ : I - package is installed with flag ]
[ Colors : set, unset ]
* Found these USE flags for x11-drivers/nvidia-drivers-390.116-r2:
U I
+ + compat : Install non-GLVND libGL for backwards compatibility
here. Dmesg otput here. Just in case it's relevant: Xorg.0.log. Thanks for looking.

With the above configuration, I no longer get a lightdm login screen.


For further upgrades of the driver, consider bug 684324: you may need to disable the compat use flag.[/u]
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved.
Take care of the community answering unanswered posts.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum