Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Firmware error.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
drillsar
n00b
n00b


Joined: 08 Sep 2010
Posts: 33

PostPosted: Sat Jun 08, 2019 10:52 pm    Post subject: [SOLVED] Firmware error. Reply with quote

I am getting the following message in dmesg and no clue on what this is

platform regulatory.0: Direct firmware load for regulatory.db failed with error -2


Last edited by drillsar on Sun Jun 09, 2019 2:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6480

PostPosted: Sat Jun 08, 2019 11:23 pm    Post subject: Reply with quote

You're missing net-wireless/wireless-regdb.
Back to top
View user's profile Send private message
drillsar
n00b
n00b


Joined: 08 Sep 2010
Posts: 33

PostPosted: Sat Jun 08, 2019 11:37 pm    Post subject: Reply with quote

It says it's installed.. ?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 15294

PostPosted: Sat Jun 08, 2019 11:46 pm    Post subject: Reply with quote

Did you include the firmware in the kernel? If not, are you trying to load the firmware before you mount the filesystem that contains the firmware?
Back to top
View user's profile Send private message
drillsar
n00b
n00b


Joined: 08 Sep 2010
Posts: 33

PostPosted: Sat Jun 08, 2019 11:53 pm    Post subject: Reply with quote

How I load the firmware into the kernel? New to that..
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 592

PostPosted: Sun Jun 09, 2019 5:28 pm    Post subject: Reply with quote

drillsar wrote:
How I load the firmware into the kernel? New to that..


In kernel menuconfig
Device drivers
--> Generic driver options
-->Firmware loader
--> Firmware blobs root directory
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3238

PostPosted: Mon Jun 17, 2019 2:47 pm    Post subject: Re: [SOLVED] Firmware error. Reply with quote

drillsar wrote:
I am getting the following message in dmesg and no clue on what this is

platform regulatory.0: Direct firmware load for regulatory.db failed with error -2

Same problem here:
dmesg wrote:
[ 1.941196] dell_laptop: Using i8042 filter function for receiving events
[ 1.991583] input: Dell WMI hotkeys as /devices/platform/PNP0C14:00/wmi_bus/wmi_bus-PNP0C14:00/9DBB5994-A997-11DA-B012-B622A1EF5492/input/input13
[ 1.992447] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[ 1.993686] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[ 1.994466] ALSA device list:
[ 1.995240] #0: HDA Intel PCH at 0xf7e30000 irq 30
[ 1.996056] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[ 1.996887] cfg80211: failed to load regulatory.db

net-wireless/wireless-regdb-20190603 is installed.

grep 80211 /usr/src/linux-4.19.44-gentoo/.config wrote:
CONFIG_CFG80211=y
# CONFIG_NL80211_TESTMODE is not set
# CONFIG_CFG80211_DEVELOPER_WARNINGS is not set
# CONFIG_CFG80211_CERTIFICATION_ONUS is not set
CONFIG_CFG80211_REQUIRE_SIGNED_REGDB=y
CONFIG_CFG80211_USE_KERNEL_REGDB_KEYS=y
CONFIG_CFG80211_DEFAULT_PS=y
# CONFIG_CFG80211_DEBUGFS is not set
# CONFIG_CFG80211_CRDA_SUPPORT is not set
# CONFIG_CFG80211_WEXT is not set
CONFIG_MAC80211=y
CONFIG_MAC80211_HAS_RC=y
CONFIG_MAC80211_RC_MINSTREL=y
CONFIG_MAC80211_RC_MINSTREL_HT=y
# CONFIG_MAC80211_RC_MINSTREL_VHT is not set
CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
CONFIG_MAC80211_RC_DEFAULT="minstrel_ht"
# CONFIG_MAC80211_MESH is not set
CONFIG_MAC80211_LEDS=y
# CONFIG_MAC80211_DEBUGFS is not set
# CONFIG_MAC80211_MESSAGE_TRACING is not set
# CONFIG_MAC80211_DEBUG_MENU is not set
CONFIG_MAC80211_STA_HASH_MAX_SIZE=0
# CONFIG_MAC80211_HWSIM is not set


So which of these filemanes would I need to add to the CONFIG_EXTRA_FIRMWARE?
Quote:
-rw-r--r-- 1 root root 4248 Jun 5 06:50 /lib/firmware/regulatory.db
-rw-r--r-- 1 root root 1182 Jun 5 06:50 /lib/firmware/regulatory.db.p7s
wrote:
CONFIG_EXTRA_FIRMWARE="intel-ucode/06-3a-09"
CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum